LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-24-2002, 10:11 AM   #1
Artamir
Member
 
Registered: Nov 2001
Location: Canada
Posts: 41

Rep: Reputation: 15
RP-PPPoE-3.4


Hey guys,

I just installed Roaring Penguin's rp-pppoe-3.4 package, but I can't get it to work. >_< I ran the go script and configured everything correctly, but when I typed adsl-start, I got the following error:

/usr/sbin/adsl-star: line 191: 570 Terminated $CONNECT ''$@'' >/dev/null 2>&1

The 570 number changes everytime I run the adsl-start script. Any ideas on what the problem could be? I'm running Slackware 8.0
 
Old 06-24-2002, 10:20 AM   #2
zLinuxz
Senior Member
 
Registered: Feb 2002
Location: Shanghai, CHINA
Distribution: RH 5.0,5.1 6.0,6.1 7.0,7.1,7.2,7.3.,8.0,9.0, RH Enterprise, Fedora C1, C2
Posts: 1,216

Rep: Reputation: 45
this same message comes up when ever ANYTHING is not configured correctly in RP. Check your email and your password are correctly setup. What dsl are you using? and what services?...the problem with that message is that it doesn't tell you anything specific..it's just screaming but saying nohting.
So give more info and check all your data.
 
Old 06-24-2002, 10:47 AM   #3
Artamir
Member
 
Registered: Nov 2001
Location: Canada
Posts: 41

Original Poster
Rep: Reputation: 15
I'm using the Bell Sympatico High Speed internet access (dsl) and everything is supposed to be configured correctly..unless they changed their DNS..

I'll try to find out whether they did change them or not, because I'm 100% sure that everything else is correct in the configuration.

Thanks for your answer!

[EDIT: Nope, I just checked with my ISP and I have the correct DNS addresses.. 0_o]

Last edited by Artamir; 06-24-2002 at 10:51 AM.
 
Old 06-24-2002, 10:50 AM   #4
orgcandman
Member
 
Registered: May 2002
Location: dracut MA
Distribution: Fedora, RHEL
Posts: 600

Rep: Reputation: 109Reputation: 109
<flame>
RP-PPPOE is raw unadulturated crap! It totally licks my [radio-edit] as hard as it can. Kernel space pppoe is better now.
</flame>

just configure your /etc/ppp/pap-secrets correctly (or you could use the adsl-setup) and voila! of course, I don't execute rp-pppoe the "normal" way when I use it anymore. all the debugging junk decided to screw it up, so I just execute pppd manually

hope this helps
Aaron
 
Old 06-24-2002, 10:53 AM   #5
Artamir
Member
 
Registered: Nov 2001
Location: Canada
Posts: 41

Original Poster
Rep: Reputation: 15
Quote:
or you could use the adsl-setup
I did configure everything with adsl-setup.

I'll try using pppd instead, and I'll post the results here.
 
Old 06-24-2002, 11:56 AM   #6
Artamir
Member
 
Registered: Nov 2001
Location: Canada
Posts: 41

Original Poster
Rep: Reputation: 15
I tried executing pppd from the console, but all I got is some weird garbage that never ends. Do you have any other suggestions?
 
Old 06-24-2002, 12:33 PM   #7
orgcandman
Member
 
Registered: May 2002
Location: dracut MA
Distribution: Fedora, RHEL
Posts: 600

Rep: Reputation: 109Reputation: 109
::laughing like crazy:: you can't just type pppd....you have to state where pppd should look, what options...etc...

here, try this:

--begin shell script--

#!/bin/bash
#written by orgcandman for quick 'n dirty connection without
#roaring penguin breaking everything I do...
#note I haven't tested this particular version on a system yet
#ymmv
#find important programs

export PPPOE=`which pppoe`
export PPPD=`which pppd`
export IFCONFIG=`which ifconfig`

#now time for some important vars...change these
export ETH="eth0"
export user="foo@bar.com"
export clampmss=""

#bring up the interface with the correct MTU rate
$IFCONFIG $ETH up mtu 1500

#install the correct ppp modules
modprobe ppp_generic > /dev/null 2>&1
modprobe ppp_async > /dev/null 2>&1
modprobe ppp_synctty > /dev/null 2>&1


$PPPD pty "$PPPOE -I $ETH -T 60 " noipdefault noauth default-asyncmap defaultroute hide-password nodetach mtu 1492 mru 1492 noaccomp noccp nobsdcomp nodeflate nopcomp novj novjccomp user $USER lcp-echo-interval 60 lcp-echo-failure

-- end shell script --

save that as /etc/sysconfig/network-scripts/connection.sh
chmod 0755 /etc/sysconfig/network-scripts/connection.sh

and in a separate terminal:
/etc/sysconfig/network-scripts/connection.sh

and hopefully, your connection should be up...
I suggest learning what options can be passed to pppd and pppoe so that you can figure out how to fine tune this script

Aaron
 
Old 06-24-2002, 12:59 PM   #8
Artamir
Member
 
Registered: Nov 2001
Location: Canada
Posts: 41

Original Poster
Rep: Reputation: 15
Now I get this...

eth0: unkoen interface: No such device
SIOCSIFMTU: No such device
/usr/sbin/pppd: too few parameters for option lcp-echo-failure

I'm sure eth0 is my modem, because I was using that for other distros...

Also, what do I need to put in export clampmss='''' ?
 
Old 06-24-2002, 01:56 PM   #9
orgcandman
Member
 
Registered: May 2002
Location: dracut MA
Distribution: Fedora, RHEL
Posts: 600

Rep: Reputation: 109Reputation: 109
apparently, I was too hasty....

eth0 is the network interface that your modem is attached to.
make sure that you actually have ethernet devices setup in /etc/conf.modules or /etc/modules.conf (depending on your distro) and that they point to the right network cards.

Also, clampmss should only be set if you are providing network access to multiple machines with this one being your gateway. If that's the case, the reccommended setting is 1200 (I think)

try this modified version. I'm pretty sure it's closer to what I've used in the past.

PS: the laughing like crazy part wasn't to be condescending, I just remember a few years ago when I was doing the same thing...

modified:


#!/bin/bash
#written by orgcandman for quick 'n dirty connection without
#roaring penguin breaking everything I do...
#note I haven't tested this particular version on a system yet
#ymmv
#find important programs

export PPPOE=`which pppoe`
export PPPD=`which pppd`
export IFCONFIG=`which ifconfig`

#now time for some important vars...change these
export ETH="eth0"
export USER="foo@bar.com"
export CLAMPMSS=""

#bring up the interface with the correct MTU rate
$IFCONFIG $ETH up mtu 1500

#install the correct ppp modules
modprobe ppp_generic > /dev/null 2>&1
modprobe ppp_async > /dev/null 2>&1
modprobe ppp_synctty > /dev/null 2>&1


#if this doesn't work, try experimenting with different eth
#devices...etc

$PPPD pty "$PPPOE -I $ETH -T 60 $CLAMPMSS" noipdefault \
noauth default-asyncmap defaultroute hide-password nodetach \
mtu 1492 mru 1492 noaccomp noccp nobsdcomp nodeflate \
nopcomp novj novjccomp user $USER lcp-echo-interval 30 \
lcp-echo-failure 60
 
Old 06-25-2002, 11:00 AM   #10
zLinuxz
Senior Member
 
Registered: Feb 2002
Location: Shanghai, CHINA
Distribution: RH 5.0,5.1 6.0,6.1 7.0,7.1,7.2,7.3.,8.0,9.0, RH Enterprise, Fedora C1, C2
Posts: 1,216

Rep: Reputation: 45
Ehmm, ok, we cannot assume everything is in the kernel already compiled. You need to check if your ethernet card is configured. Check the ifconfig commang and see what it prompts out.
If only the lo comes out and no eth0 comes out...you need to compiled your card into the kernel!, so that you can access the internet. Also you need to enable all the PPPoE options in the kernel. If you don't do this, PPPoE is guaranteed not to work. Everything that has to do with PPPoE protocol you must enable in the kernel.
So check for these things before you continue trying doing what orgcandman
 
Old 06-25-2002, 06:15 PM   #11
Artamir
Member
 
Registered: Nov 2001
Location: Canada
Posts: 41

Original Poster
Rep: Reputation: 15
Alright, thanks to both of you!

I'm leaving on a vacation in two days so I won't be able to try either of these solutions, so I'll bookmark the thread and get back to you in a week or so.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Pppoe redice Linux - Networking 3 08-27-2005 02:03 PM
adsl-status can't read pppoe PID file with rp-pppoe program setup Smarvy Linux - Newbie 2 03-14-2004 12:35 AM
rp-pppoe KptnKrill Arch 0 11-17-2003 04:09 PM
rp-pppoe LinuxNewby Linux - Networking 2 09-03-2003 09:24 AM
PPPoE ztopher Linux - Networking 0 11-21-2002 05:50 PM


All times are GMT -5. The time now is 03:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration