LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-28-2015, 02:59 PM   #1
dunnery
Member
 
Registered: May 2010
Location: East Stroudsburg
Distribution: Debian Jessie
Posts: 211

Rep: Reputation: 8
router username and password


is there a way via terminal to reset the username and password for my router?
i have recently started working with the terminal and in order to use ssh im going to need to download some software and enter the username and password for the router which i havent a clue what it is. im not sure i ever set the username and password on it????

if i could re make the username and password for my router i would then be able to get this ssh working.

or is this not possible?
 
Old 04-28-2015, 03:02 PM   #2
strick1226
Member
 
Registered: Feb 2005
Distribution: CentOS, Fedora, OS X, SLES, Ubuntu
Posts: 326

Rep: Reputation: 63
Probably not possible with most consumer-grade routers.

Usually there's a reset button located on the back/bottom of the hardware you can hold in for so many seconds while unplugging from power and plugging it back in that resets it to factory defaults.

What brand/model router is it? More info would be helpful...
 
1 members found this post helpful.
Old 04-28-2015, 03:11 PM   #3
dunnery
Member
 
Registered: May 2010
Location: East Stroudsburg
Distribution: Debian Jessie
Posts: 211

Original Poster
Rep: Reputation: 8
its an Arris CM820 A
 
Old 04-28-2015, 03:16 PM   #4
strick1226
Member
 
Registered: Feb 2005
Distribution: CentOS, Fedora, OS X, SLES, Ubuntu
Posts: 326

Rep: Reputation: 63
That's a cable modem, not a router.
 
Old 04-28-2015, 03:23 PM   #5
dunnery
Member
 
Registered: May 2010
Location: East Stroudsburg
Distribution: Debian Jessie
Posts: 211

Original Poster
Rep: Reputation: 8
actually its the apple extreme. i thought the modem would produce the public ip but after calling the cable company its the apple router
 
Old 04-28-2015, 03:29 PM   #6
strick1226
Member
 
Registered: Feb 2005
Distribution: CentOS, Fedora, OS X, SLES, Ubuntu
Posts: 326

Rep: Reputation: 63
Right, well then -- easy enough:

https://support.apple.com/en-us/HT201945

You definitely can't change any settings on the Apple Airport AP's without using their proprietary configuration utility which, unfortunately, only has Windows, OS X, and iOS "official" versions. That said, many people report having success running the Windows version using WINE in linux.

Good luck!


strick
 
2 members found this post helpful.
Old 04-28-2015, 03:36 PM   #7
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Found something that might help:
http://portforward.com/default_usern...word/Apple.htm
 
1 members found this post helpful.
Old 04-28-2015, 06:17 PM   #8
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
The router username & password may be on the bottom of router, if not google your router model default password.
 
1 members found this post helpful.
Old 04-29-2015, 02:27 PM   #9
dunnery
Member
 
Registered: May 2010
Location: East Stroudsburg
Distribution: Debian Jessie
Posts: 211

Original Poster
Rep: Reputation: 8
i got the username and password as it was actually in the airport utility but <im afraid <i think that strick1126 is right in that you can only use a mac and windows for port forwarding. The terminal prompt times out when my friend from england tries to contact me in terminal via ssh.

i would like to document what <i have done so far just in case anyone else has this issue.

both my friend (in the UK) and I (in the USA) installed ssh via terminal.
i used the adduser command in terminal to set up an account on my machine for him.
I sent him the username and password and my public ip address.
i set up the airport utility for ssh and typed in my personal ip address for my computer to allow port forwarding.

he types ssh user@(my public ip address)
his terminal command hits my router (public ip) and then forwards the message or connection to the computer designated in the apple airport utility ?

I believe this is right.

everything works until it hits my router and then the terminal prompt times out.

one more thing, i know his account works because i can log into it from inside my network so the problem is not the username or password.

can anyone confirm that apple airport doesnt allow linux ssh?
 
Old 04-29-2015, 03:15 PM   #10
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
The airport utility is your wireless card, am I correct?
If correct then you are only forwarding the port on your computer. I thought you were trying to open port on router.
 
Old 04-29-2015, 03:20 PM   #11
strick1226
Member
 
Registered: Feb 2005
Distribution: CentOS, Fedora, OS X, SLES, Ubuntu
Posts: 326

Rep: Reputation: 63
The Airport Extreme should be fine with allowing any incoming traffic you specify to be OK to reach your internal (private) network.

Presuming your ISP is not actively blocking 22/tcp, verify you have enabled port forwarding of 22/tcp.

This is from memory, I think it's accurate:

--In the Airport Configuration Utility (ACU), right-click on your Airport and select "Edit" .
--Click on the Network tab.
--Click the plus (+) button for Port Settings.
--Name the service (such as "ssh") and select 22 and protocol TCP.
--I think the ACU might even automatically populate the destination computer IP address for you, being the one you're using to access it... if not, enter the local/private IP address of the computer to which you want this particular traffic to reach.
--Click Update.

One other thing to check: what about the firewall (if present) on the destination computer? Are you sure the default SSH port (again 22/tcp) is open to incoming traffic on that machine, specifically?
 
Old 04-29-2015, 05:15 PM   #12
dunnery
Member
 
Registered: May 2010
Location: East Stroudsburg
Distribution: Debian Jessie
Posts: 211

Original Poster
Rep: Reputation: 8
oh man, it just doesnt seem to work. i dont know what to try next.
is there anyone out there i can give an account to and connect with terminal? i can send you username and apssword and see if you can get in or you give me one and <ill see if i can get to yours?
 
Old 04-29-2015, 07:07 PM   #13
strick1226
Member
 
Registered: Feb 2005
Distribution: CentOS, Fedora, OS X, SLES, Ubuntu
Posts: 326

Rep: Reputation: 63
Have you verified that the firewall on the destination computer is configured to allow incoming SSH connections?

It looks like you might be using Ubuntu; if that's correct, the easiest tool there to manage the local firewall is gufw:

https://help.ubuntu.com/community/Gufw


You can use that to temporarily turn the computer's local firewall off altogether, at which point you should be able to ssh in from outside if the Airport has been configured properly.


If you don't have it installed then simply go to a terminal prompt and type the following:

Code:
mycomputer:~$ sudo apt-get install gufw -y
 
Old 04-29-2015, 11:23 PM   #14
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Even if you open the port on computer if the router is setup to block then the change must also be done for the router. You don't have to unblock for everything but for the computer that you want to forward port on.
Just type your gateway address into browser & login to it.
 
Old 04-30-2015, 09:23 AM   #15
strick1226
Member
 
Registered: Feb 2005
Distribution: CentOS, Fedora, OS X, SLES, Ubuntu
Posts: 326

Rep: Reputation: 63
Quote:
Originally Posted by EDDY1 View Post
Even if you open the port on computer if the router is setup to block then the change must also be done for the router. You don't have to unblock for everything but for the computer that you want to forward port on.
Right. See post #11.

Quote:
Originally Posted by EDDY1 View Post
Just type your gateway address into browser & login to it.
Generally that's the way to go, yes, but this is an Apple Airport Extreme router. There isn't a WebGUI; as previously mentioned, these routers require a proprietary Airport Configuration Utility to configure / make changes to them which, unfortunately, is only officially available on Windows, Mac, and iOS platforms.

Still waiting to hear back from dunnery, but it rather sounds as if he was able to get into configuring it at some point, so I'm hoping he can access the configuration of the router again and verify the port forwarding settings for SSH -- as well as verify his local computer isn't blocking it as well.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to username password and sort by weakest password rhbegin Programming 8 11-07-2012 09:39 AM
atheros AR9285 Router username and password information dwallace Linux - Newbie 3 07-07-2011 08:28 AM
username and password a7mlinux Linux - Security 14 08-11-2009 11:27 AM
Username/Password Help FindingWaldo763 Linux - Newbie 7 12-18-2005 08:15 PM
No username and password Tec1 Linux - Software 1 08-10-2003 10:38 AM


All times are GMT -5. The time now is 06:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration