LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-18-2005, 02:28 AM   #1
palmoswince
LQ Newbie
 
Registered: Oct 2005
Location: Malaysia
Posts: 4

Rep: Reputation: 0
Question root login not allowed


Hi all,

I have installed red hat enterprise linux 4 es. Only root login was created. Upon login in to the system for the first time, I entered the root id/pwd but an error 'Root logins not allowed'. Why is this happening since this is the first time I'm entering the system since the installation and no config files has been touched? And how do I enable root to login?

Thanks.

-LJT-
 
Old 10-18-2005, 02:42 AM   #2
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
You will hear this more than once: never run as root. Use the system as a normal user, and only become the root account temporarily to do system administration.

RedHat normally does not allow root to log into the GUI environment partly because it's a serious risk to the stability of the system. Do not run as root for normal day-to-day use.

During install, there should have been a dialog box asking what users to create. At least one should be created at that step. If the rest of this reply makes no sense, you might consider reinstalling to avoid the confusion and making sure you create a regular, non-root user at this step of the install.

If you don't want to reinstall or can't, then you can log in to a text-based terminal. Hold down this key combination: Ctrl-Alt-F1. That should take you to a text login. The root account should be accessible from here. Use it to create a regular user with the useradd command. Type man useradd if read how to issue the command. After the user is created, change the user's password with passwd <new_username>. Then logout of the root account, hit Ctrl-Alt-F7 (which should return you to the GUI - otherwise try F5), and then log into the GUI with the normal user.

If the text-based login does not allow root to connect, then you'll either need to boot into single user mode or use the install disk to enter "rescue" mode. If none of that makes sense, then it would probably just be easiest to reinstall
 
Old 10-18-2005, 03:20 AM   #3
palmoswince
LQ Newbie
 
Registered: Oct 2005
Location: Malaysia
Posts: 4

Original Poster
Rep: Reputation: 0
Thumbs up

thanks man...

i booted the system into a single mode and created the new user from there...manage to login now using the newly created user...

not too sure why wasnt i prompted to create new user during installation..usually when will that appear? in my installation, after entering the root password-select packages, the installation completed after installing all the files from the CDs

-LJT-
 
Old 10-18-2005, 11:17 AM   #4
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
In my experience, the opportunity to create regular users almost always comes after the prompt for root's password. I'll qualify that though and say I've never installed RH Enterprise.

Regardless, I'm glad it's working for you.
 
Old 05-12-2008, 05:15 AM   #5
Lee Barker
Member
 
Registered: Jan 2005
Location: London
Distribution: Fedora 6
Posts: 31

Rep: Reputation: 15
Logging on as root

I totally agree that users should not be logging on as root.

However a Linux OS should still provide that option. An installation asks for a root password to be created - and the option, however ill-advised, should still be there to log-in as root.

So, back to the original question of why does Fedora prevent root sign-on and how do we change this restriction?

Regards.
Elracorey
 
Old 05-12-2008, 07:11 AM   #6
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
The option to login as root is still there as you can login in a terminal as root. So there's no restriction
 
Old 05-12-2008, 07:20 AM   #7
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Quote:
Originally Posted by Lee Barker View Post
So, back to the original question of why does Fedora prevent root sign-on and how do we change this restriction?

Regards.
Elracorey
The original question (2.5 years ago) was not about Fedora. The only distro that disables root by default is Ubuntu....but that's easy to fix (sudo passwd root).

I think you mean sign into the GUI (desktop) as root. Really bad idea, but can be enabled in the login manager.
 
Old 05-12-2008, 07:31 AM   #8
kalleanka
Member
 
Registered: Aug 2003
Location: Mallorca, Spain
Distribution: xubuntu
Posts: 551

Rep: Reputation: 38
some distros do not give you the option to create a user during installation. So one has to login as root the first time to set up the system. I think the option should be there.
 
Old 05-12-2008, 10:22 AM   #9
seraphim172
Member
 
Registered: May 2008
Posts: 101

Rep: Reputation: 15
Fedora allows GUI logins

Fedora does allow GUI logins as root, though it gives a message to be careful. The current case is either RHEL specific or more likely a missed opportunity to create a common user during install.

Linux Archive

Last edited by seraphim172; 06-25-2008 at 05:22 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
root login not allowed allelopath Linux - Software 6 09-07-2005 05:34 PM
Linux Host no Root login allowed or so it says? Other Linux Distros? mattnedgus Linux - Newbie 6 02-24-2005 04:22 PM
Root Logins are not allowed martincho Debian 10 01-30-2005 07:55 PM
Account Allowed Login Times? c0uchm0nster Linux - Security 3 08-18-2004 05:32 AM
ssh access allowed only to root user? zovres Linux - Newbie 5 09-25-2003 05:19 PM


All times are GMT -5. The time now is 01:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration