LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-24-2006, 01:07 PM   #1
SP7
Member
 
Registered: Aug 2005
Location: US
Distribution: MX-14.4 in a custom desktop tower and in a Dell laptop
Posts: 55

Rep: Reputation: 15
Root file system not being checked during bootup process


I see that the bootup process for my system says it "can't check the
root file system because it's not mounted read-only". [There's a red
star by this line.] Since I generally don't examine carefully the fast
moving bootup lines (and I just found out how to stop them: use Scroll
Lock), I don't know when this started. This line and the red star
might have been there for weeks-- I don't know. [During the last 2
weeks, I've been installing the latest versions of various packages.
And, also during the last 2 weeks, I've installed one or two entirely
new packages that I never had before doing this.]

I know how to check the properties of files and how to change
permissions but I don't know how to make the entire root file system
'read-only'. Where and how do I do that?

[I use Mepis 3.4-3 and my root <in ext3 file system> is in /dev/hda1.
My computer, Mepis, Linux, Firefox, etc. seem to be working fine
inspite of the failure of the bootup process to check the root file
system.]


Thanks,

Stan
 
Old 07-24-2006, 01:43 PM   #2
hfawzy
Member
 
Registered: Aug 2002
Location: Egypt
Distribution: Debian Sarge, Slackware 10.0
Posts: 163

Rep: Reputation: 30
To mount the root filesystem read-only, you have to modify the /etc/fstab configuration file.
Open this file and locate the line concerning your root filesystem (should begin with /dev/hda1 / ext3) and add to the 4th column (the options column) the "ro" option. If there are others options, you should delimit these by a comma (,).
 
Old 07-24-2006, 02:16 PM   #3
SP7
Member
 
Registered: Aug 2005
Location: US
Distribution: MX-14.4 in a custom desktop tower and in a Dell laptop
Posts: 55

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by hfawzy
To mount the root filesystem read-only, you have to modify the /etc/fstab configuration file.
Open this file and locate the line concerning your root filesystem (should begin with /dev/hda1 / ext3) and add to the 4th column (the options column) the "ro" option. If there are others options, you should delimit these by a comma (,).
Thanks for the help. Here's the first line of my fstab:

# Pluggable devices are handled by uDev, they are not in fstab
/dev/hda1 / ext3 defaults,noatime 1 1


So I should change 'defaults' to ' ro ' and follow ro with ' ,noatime 1 1 '. Is that correct?
 
Old 07-24-2006, 02:23 PM   #4
hfawzy
Member
 
Registered: Aug 2002
Location: Egypt
Distribution: Debian Sarge, Slackware 10.0
Posts: 163

Rep: Reputation: 30
Yes, seems ok to me. You can go on and try with this new option.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot process dies during forced file system check mepaco Fedora - Installation 1 04-11-2006 08:42 AM
Read-only file system error during bootup after installing Mandrake ontop of Suse fuoms Mandriva 1 11-27-2005 06:43 AM
Boot Error: Root file system /dev/root adtomar Linux - Networking 0 12-27-2004 11:50 AM
/dev/hde9 (root partition) has gone 14051 days without being checked... frieza Linux - General 1 07-09-2002 10:18 PM
When a process locks up the system - what is the created image file called? thatgentleman Linux - General 3 03-22-2002 10:36 PM


All times are GMT -5. The time now is 03:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration