LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-02-2004, 12:46 PM   #1
LiNuXn00biE_2.4
LQ Newbie
 
Registered: Oct 2004
Distribution: Red Hat 9
Posts: 26

Rep: Reputation: 15
Apache and Install woes


I would like to install apache on my normal user account but it keeps telling me permission denied when creating a new directory. It is Apache 1.3.x.x So what my question is how do I give root permissions to the normal user account I am sure this question has been asked but I have a lot to do and do not have the time to go searching for the answer

Last edited by LiNuXn00biE_2.4; 11-04-2004 at 05:12 PM.
 
Old 11-02-2004, 12:47 PM   #2
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
you don't grant root permissions to a normal user, you login as root to accomplish tasks such as installations
 
Old 11-02-2004, 12:54 PM   #3
NoSpHeRaTu
LQ Newbie
 
Registered: Oct 2004
Location: Cuba
Posts: 22

Rep: Reputation: 15
how he say. Enter as root and install. Is that easy
 
Old 11-02-2004, 12:55 PM   #4
michael_j_w
LQ Newbie
 
Registered: Oct 2004
Location: Portland, OR USA
Distribution: mandrake 9.2/fc2
Posts: 13

Rep: Reputation: 0
you could just use the su command

$ su
password: <root password>
#

after install don't forget to exit out of su mode

# exit
$

you might make notice of the change in the promt, this is a quick way of telling what mode your in
 
Old 11-02-2004, 01:16 PM   #5
LiNuXn00biE_2.4
LQ Newbie
 
Registered: Oct 2004
Distribution: Red Hat 9
Posts: 26

Original Poster
Rep: Reputation: 15
Thanks that worked much better and I now have apache somewhat installed and now I need help with this :

You now have successfully built and installed the |
| Apache 1.3 HTTP server. To verify that Apache actually |
| works correctly you now should first check the |
| (initially created or preserved) configuration files |
| |
| /usr/local/apache/conf/httpd.conf
| |
| and then you should be able to immediately fire up |
| Apache the first time by running: |
| |
| /usr/local/apache/bin/apachectl start
| |
| Thanks for using Apache. The Apache Group |
| http://www.apache.org/ |
+--------------------------------------------------------+
[root@localhost apache_1.3.32]# cd /usr/local/apache
[root@localhost apache]# /usr/local/apache/bin/apachect1 start


Now what do I do to start it up ?? it says no File or directory exists


Last edited by LiNuXn00biE_2.4; 11-02-2004 at 01:45 PM.
 
Old 11-02-2004, 06:40 PM   #6
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
ctl -- control -- all letters, not numbers --

apachectl, not apachect1
 
Old 11-03-2004, 01:01 PM   #7
LiNuXn00biE_2.4
LQ Newbie
 
Registered: Oct 2004
Distribution: Red Hat 9
Posts: 26

Original Poster
Rep: Reputation: 15
root@localhost apache_1.3.33]# cd /usr/local/apache
[root@localhost apache]# /usr/local/apache/conf/httpd.conf
bash: /usr/local/apache/conf/httpd.conf: Permission denied
[root@localhost apache]# /usr/local/apache/bin/apachectl start
[Wed Nov 3 11:59:34 2004] [warn] Apache does not support line-end comments. Consider using quotes around argument: "#-1"
Syntax error on line 564 of /usr/local/apache/conf/httpd.conf:
Regular expression could not be compiled.
/usr/local/apache/bin/apachectl start: httpd could not be started
[root@localhost apache]#

This is my latest erorr it says it can't be started but WHY?!?!?!
 
Old 11-03-2004, 02:50 PM   #8
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
you have an error in your conf file, but this is not an executible file -- that is why you got permission denied

i think RH prefers nano to pico, so...
run:
nano /usr/local/apache/conf/httpd.conf
as root, and look around 564

--i can't help you any more unless i see your conf file
 
Old 11-03-2004, 03:23 PM   #9
LiNuXn00biE_2.4
LQ Newbie
 
Registered: Oct 2004
Distribution: Red Hat 9
Posts: 26

Original Poster
Rep: Reputation: 15
Ok thanks I will do that
 
Old 11-03-2004, 03:43 PM   #10
LiNuXn00biE_2.4
LQ Newbie
 
Registered: Oct 2004
Distribution: Red Hat 9
Posts: 26

Original Poster
Rep: Reputation: 15
Ok heres what I am getting now I used httpd-2.3.33 and everything Launched but now when I go to http://localhost/ it tells me Forbidden and that I do not have access to / so what do I do now? I am looking at this as a success but I don't know what to do from here
 
Old 11-03-2004, 04:05 PM   #11
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
check file permissions, directory index, and the likes -- this is either a mis-config in .conf file, or file permissions error.
 
Old 11-03-2004, 04:11 PM   #12
LiNuXn00biE_2.4
LQ Newbie
 
Registered: Oct 2004
Distribution: Red Hat 9
Posts: 26

Original Poster
Rep: Reputation: 15
where do I do that at??
 
Old 11-03-2004, 04:46 PM   #13
LiNuXn00biE_2.4
LQ Newbie
 
Registered: Oct 2004
Distribution: Red Hat 9
Posts: 26

Original Poster
Rep: Reputation: 15
oh I was also wondering if the Server being connected to a Windows machine which is connected to a router could be causing any sort of Problems


I will try to detail it

Cable modem > Router

Router > Windows Machine
Router >Wireless adapter > Windows Machine
Router> Windows Machine > Linux Server

Last edited by LiNuXn00biE_2.4; 11-03-2004 at 04:52 PM.
 
Old 11-03-2004, 04:55 PM   #14
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
ls -l /var/www
ls -l /var/www/ht??
^ that's how you check file/directory permissions, it is your DocumentRoot variable in conf file...

you also need to check DirectoryIndex variable, and check your options in your dirctory directives of your conf file... the stuff in
<directory />
...
</directory>
 
Old 11-03-2004, 05:04 PM   #15
LiNuXn00biE_2.4
LQ Newbie
 
Registered: Oct 2004
Distribution: Red Hat 9
Posts: 26

Original Poster
Rep: Reputation: 15
I had to restart the server and now I get this error

[root@localhost apache]# /root/local/apache/bin/apachectl start
[Wed Nov 3 16:01:38 2004] [warn] Apache does not support line-end comments. Consider using quotes around argument: "#-1"
Syntax error on line 564 of /root/local/apache/conf/httpd.conf:
Regular expression could not be compiled.
/root/local/apache/bin/apachectl start: httpd could not be started
[root@localhost apache]# cd /root/local/apache
[root@localhost apache]# /root/local/apache/bin/apachectl start
[Wed Nov 3 16:02:19 2004] [warn] Apache does not support line-end comments. Consider using quotes around argument: "#-1"
Syntax error on line 564 of /root/local/apache/conf/httpd.conf:
Regular expression could not be compiled.
/root/local/apache/bin/apachectl start: httpd could not be started
[root@localhost apache]#

But before it started just fine.... I am gonna do the whole process over and see what happens I hate going in circles and thank you for your help Sec. I will be sure to check it as soon as I am done doing the process over
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't su into root as normal user darin3200 Linux - General 13 03-18-2010 11:03 AM
Root? normal user? what does it all mean? Zieroth Linux - Newbie 5 07-16-2004 04:06 PM
Games runs slow as normal user, but fast as root user mcore Linux - Software 2 06-07-2004 11:11 PM
Can print as root but not normal user paranoia1980 Linux - Newbie 4 07-18-2003 04:07 PM
Root and normal user Smooth Linux - Newbie 4 05-27-2003 10:15 AM


All times are GMT -5. The time now is 10:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration