LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-11-2012, 07:23 PM   #76
omizt
Member
 
Registered: Feb 2012
Posts: 56

Original Poster
Rep: Reputation: Disabled

Thanks Thor and T3RM1NVT0R,

now I am in root account, I can't access the internet
firfox &
[2] 774
ifconfig
eth0 Link encap:Ethernet HWaddr 00:25:64:B2:71:BA
inet addr:129.112.14.31 Bcast:129.112.255.255 Mask:255.255.255.0
inet6 addr: fec0::a:225:64ff:feb2:71ba/64 Scope:Site
inet6 addr: 2002:8170:6a59:a:225:64ff:feb2:71ba/64 Scope:Global
inet6 addr: fe80::225:64ff:feb2:71ba/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:8637801 errors:0 dropped:211 overruns:0 frame:566
TX packets:16611 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1090296806 (1.0 GiB) TX bytes:2322758 (2.2 MiB)
Interrupt:185

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:27168 errors:0 dropped:0 overruns:0 frame:0
TX packets:27168 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:6609752 (6.3 MiB) TX bytes:6609752 (6.3 MiB)

[2]- Done firefox


route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
129.112.14.0 * 255.255.255.0 U 0 0 0 eth0

cat /etc/resolv.conf
search dhcp.swmed.org
nameserver 199.242.236.1
nameserver 199.242.237.1

ls -a /etc/skel
. .. .bash_logout .bash_profile .bashrc .emacs .mozilla
cat /etc/default/useradd
# useradd defaults file
GROUP=100
HOME=/home
INACTIVE=-1
EXPIRE=
SHELL=/bin/bash
SKEL=/etc/skel
CREATE_MAIL_SPOOL=yes
 
Old 02-11-2012, 07:36 PM   #77
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

Code:
eth0 Link encap:Ethernet HWaddr 00:25:64:B2:71:BA
inet addr:129.112.14.31 Bcast:129.112.255.255 Mask:255.255.255.0
inet6 addr: fec0::a:225:64ff:feb2:71ba/64 Scope:Site
inet6 addr: 2002:8170:6a59:a:225:64ff:feb2:71ba/64 Scope:Global
inet6 addr: fe80::225:64ff:feb2:71ba/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:8637801 errors:0 dropped:211 overruns:0 frame:566
TX packets:16611 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1090296806 (1.0 GiB) TX bytes:2322758 (2.2 MiB)
Interrupt:185
As I can see from this output

Machine IP: 129.112.14.31
Bcast:129.112.255.255
Mask:255.255.255.0

Subnet mask says that your IP has been subnetted as class C IP address then how come broadcast address be 129.112.255.255. If I go as per theory the first 3 octect should not be changed with the subnet of 255.255.255.0.

So basically what I am trying to say is that in that IP range if you are using subnet of 255.255.255.0 then the network address should be 129.112.14.0 and the broadcast address should be 129.112.14.255. So that is first thing that is looking weird to me. Did you make any changes in your ifconfig-eth0 file?

Second thing, I would like to know is the default gateway ip. In earlier posts you said that you think it could be 129.112.14.254. Are we sure on that? Because without default gateway we are not going anywhere.

Code:
cat /etc/resolv.conf
search dhcp.swmed.org
nameserver 199.242.236.1
nameserver 199.242.237.1
Is this how your resolv.conf file initially looks like or there are any modifications?

Please do not make any modifications inf any files for now because we will not be knowing then whats going on
 
Old 02-11-2012, 07:40 PM   #78
omizt
Member
 
Registered: Feb 2012
Posts: 56

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by T3RM1NVT0R View Post
Code:
eth0 Link encap:Ethernet HWaddr 00:25:64:B2:71:BA
inet addr:129.112.14.31 Bcast:129.112.255.255 Mask:255.255.255.0
inet6 addr: fec0::a:225:64ff:feb2:71ba/64 Scope:Site
inet6 addr: 2002:8170:6a59:a:225:64ff:feb2:71ba/64 Scope:Global
inet6 addr: fe80::225:64ff:feb2:71ba/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:8637801 errors:0 dropped:211 overruns:0 frame:566
TX packets:16611 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1090296806 (1.0 GiB) TX bytes:2322758 (2.2 MiB)
Interrupt:185
As I can see from this output

Machine IP: 129.112.14.31
Bcast:129.112.255.255
Mask:255.255.255.0

Subnet mask says that your IP has been subnetted as class C IP address then how come broadcast address be 129.112.255.255. If I go as per theory the first 3 octect should not be changed with the subnet of 255.255.255.0.

So basically what I am trying to say is that in that IP range if you are using subnet of 255.255.255.0 then the network address should be 129.112.14.0 and the broadcast address should be 129.112.14.255. So that is first thing that is looking weird to me. Did you make any changes in your ifconfig-eth0 file?

Second thing, I would like to know is the default gateway ip. In earlier posts you said that you think it could be 129.112.14.254. Are we sure on that? Because without default gateway we are not going anywhere.

Code:
cat /etc/resolv.conf
search dhcp.swmed.org
nameserver 199.242.236.1
nameserver 199.242.237.1
Is this how your resolv.conf file initially looks like or there are any modifications?

Please do not make any modifications inf any files for now because we will not be knowing then whats going on
initially, the resolv.conf have 4 lines
first line is
;generated by /sbin/dhcient-script
and then
search dhcp.swmed.org
nameserver 199.242.236.1
nameserver 199.242.237.1
 
Old 02-11-2012, 07:41 PM   #79
omizt
Member
 
Registered: Feb 2012
Posts: 56

Original Poster
Rep: Reputation: Disabled
there is a note on the computer

network mask:255.255.255.0
gateway: 129.112.14.254

so I think this gateway is right
and when I ping 129.112.14.254
I can get a long result, looks it's OK.
 
Old 02-11-2012, 07:45 PM   #80
omizt
Member
 
Registered: Feb 2012
Posts: 56

Original Poster
Rep: Reputation: Disabled
I may changed ifconfig-eth0 file couple of mouth ago.
I think I already change it back to the original one. but I am not sure.
 
Old 02-11-2012, 07:49 PM   #81
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

Output of cat /etc/resolv.conf looks OK to me if search dhcp.swmed.org is the name of your domain. If not them comment out this line. From the output of route command I can see that there is no default gateway is defined. If you are sure that
Quote:
gateway: 129.112.14.254
is the gateway then run the following command:

Code:
route add default gw 129.112.14.254
But wait, that will not be it if your system's IP configuration itself is not proper. So don't run that command for now. I would like to see the IP configuration of your machine first. Run the following command:

Code:
cat /etc/sysconfig/network-scripts/ifcfg-eth0
 
Old 02-11-2012, 07:54 PM   #82
omizt
Member
 
Registered: Feb 2012
Posts: 56

Original Poster
Rep: Reputation: Disabled
cat /etc/sysconfig/network-scripts/ifcfg-eth0
# Broadcom Corporation NetXtreme BCM5761 Gigabit Ethernet PCIe
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:25:64:B2:71:BA
ONBOOT=yes
TYPE=Ethernet
USERCTL=yes
IPV6INIT=no
PEERDNS=yes
 
Old 02-11-2012, 07:58 PM   #83
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

Alright. Output looks good to me. You can run the route add command as I mentioned in my previous post after checking on more thing. Have look at your /etc/sysconfig/network file. If you find anything that says:

Quote:
IPV6_NETWORKING=YES
Then comment out that line. Run the following command:

Code:
service network restart
And then

Code:
route add default gw 129.112.14.254
Once done check if you are able to connect to internet atleast using root account.
 
Old 02-11-2012, 08:01 PM   #84
omizt
Member
 
Registered: Feb 2012
Posts: 56

Original Poster
Rep: Reputation: Disabled
i typed

route add default gw 129.112.14.254

and now the root can access internet again
I am going to check the other accounts

Last edited by omizt; 02-11-2012 at 08:06 PM.
 
Old 02-11-2012, 08:03 PM   #85
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

No. Just put a # sign before the line. Like this:

#IPV6_NETWORKING=yes
 
Old 02-11-2012, 08:08 PM   #86
omizt
Member
 
Registered: Feb 2012
Posts: 56

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by T3RM1NVT0R View Post
No. Just put a # sign before the line. Like this:

#IPV6_NETWORKING=yes
in the network file,
there is a line
NETWORKING_IPV6=no
 
Old 02-11-2012, 08:10 PM   #87
omizt
Member
 
Registered: Feb 2012
Posts: 56

Original Poster
Rep: Reputation: Disabled
now I log on the other account
can access on google only
 
Old 02-11-2012, 08:17 PM   #88
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

Code:
NETWORKING_IPV6=no
Leave it as it is. Sorry I mentioned the wrong syntax
Quote:
IPV6_NETWORKING=yes
Back to issue. Are you able to browse all the sites now using root? As you said that you are able to browse google using regular user. If I am getting it correctly we are back to where we were. Right? If yes, could you try the things that I mentioned in my first post in this thread. Here is the abstract:

Quote:
Hello everyone,

Just trying to catch up.

Let us start from beginning. As OP said that the issue is he is able to browse sites when he log in with root account but he is only able to browse google when he login with any other account. At first instance it does not appear to be me as a network issue the reason being if it was then root user should also not be able to browse the internet. I may be wrong but this is what I think.

omizt,

Is the issue still the same? Are you able to browse the sites with root user and not with a regular user? If yes, could you please try creating a test account and see if you are able to browse sites using that account. If not then try the following thing:

1. Login to the machine using test user account which you have created.
2. Open up terminal
3. su - root
4. Enter the root password. Make sure your prompt chage from $ to #.
5. Run the following command:

Code:
firefox &
Try to browse the sites using this firefox and let us know if you are able to browse. If yes, then it appears to me it has either sometime to do with permission. If not then it has something to do with profile.
I would also like to see the output of the following command:

Code:
ls -a /home/user
Where, user will be the test user accounts home directory.
 
Old 02-11-2012, 08:31 PM   #89
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
(deleted)
Posted irrelevant comment :/
 
Old 02-11-2012, 08:33 PM   #90
omizt
Member
 
Registered: Feb 2012
Posts: 56

Original Poster
Rep: Reputation: Disabled
in the test account, can log on google only.

after using "su" command, and then "firefox &", in the new pop-up browser, I can access the other websites.

[root@swan test]# firefox &
[1] 2725
[root@swan test]#
(Gecko:2742): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.

[root@swan test]# ls -a /home/test
. .eggcups .gnome2_private .recently-used.xbel
.. .emacs .gstreamer-0.10 .redhat
.bash_logout .esd_auth .gtkrc-1.2-gnome2 .thumbnails
.bash_profile .gconf .ICEauthority .Trash
.bashrc .gconfd .metacity .xsession-errors
Desktop .gnome .mozilla
.dmrc .gnome2 .nautilus
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
root access to user account RudraB Linux - Newbie 16 06-30-2010 03:11 AM
Root Account Access Security iconicmoronic Linux - Security 2 04-14-2007 03:17 PM
How do I access root account in Mandrake 10? dbz Linux - Security 4 04-03-2004 12:00 PM
Can Access Sites with root but not user account Obelus Linux - Networking 4 12-21-2003 04:28 PM
FTP access using root account - restrictions alaerte Linux - Software 7 04-03-2003 02:33 PM


All times are GMT -5. The time now is 01:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration