LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-19-2016, 06:30 AM   #1
abarmyms
LQ Newbie
 
Registered: May 2016
Posts: 2

Rep: Reputation: Disabled
rndc: connect failed: 127.0.0.1#953: connection refused


Hello All,

Can someone help me with my Bind Server, I found out if i remove rndc on bind it might work, but i can't find any thread on out to do this. i am a newbie to Linux.
After configuring my Bind9, it refuses to run by giving this error msg.

WARNING: key file (/etc/bind/rndc.key) exists, but using default configuration file (/etc/bind/rndc.conf)
rndc: connect failed: 127.0.0.1#953: connection refused
root@kano-a:~#

Thanks
 
Old 05-19-2016, 12:33 PM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,516

Rep: Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501
Hi,

If you want to disable rndc, use:
Code:
controls { };
in /etc/named.conf. You can also comment out any other occurrence of rndc in /etc/named.conf.

But, I don't recommend doing that.
Since rndc is handy for managing named, better configure rndc for use with bind. See this for a quick howto

Regards

Last edited by bathory; 05-19-2016 at 12:44 PM.
 
Old 05-27-2016, 06:08 AM   #3
abarmyms
LQ Newbie
 
Registered: May 2016
Posts: 2

Original Poster
Rep: Reputation: Disabled
Thanks bathory,

Can you guide me through the removing process as i am completely new to this.

Cheers.
 
Old 05-27-2016, 07:10 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,516

Rep: Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501
Quote:
Originally Posted by abarmyms View Post
Thanks bathory,

Can you guide me through the removing process as i am completely new to this.

Cheers.
From my previous post:
Quote:
If you want to disable rndc, use:

controls { };

in /etc/named.conf.
You can also comment out any other occurrence of rndc in /etc/named.conf.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
rndc: connect failed: 127.0.0.1#953: connection refused milindras Linux - Server 41 08-20-2013 06:33 AM
rndc: connect failed: connection refused mahmoud Linux - Newbie 2 06-07-2006 03:23 AM
rndc: connect failed: connection refused jkmartha Linux - Software 0 06-20-2005 02:35 AM
rndc: connect failed: connection refused Justalk Linux - Software 2 06-28-2004 04:45 PM
rndc: connect failed: connection refused Atroxic Linux - Networking 1 10-24-2003 02:01 PM


All times are GMT -5. The time now is 08:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration