LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-08-2004, 03:46 PM   #1
siepmann
LQ Newbie
 
Registered: Sep 2004
Location: Nottingham, UK
Posts: 28

Rep: Reputation: 15
rmmod usb-storage EVERY TIME!


I have my /etc/auto.tero set up to auto mount /dev/sda and /dev/sda1.

So, I plug in my Digital Camera and turn it on. Lights flicker, and a directory appears in /mnt/auto/autofs. I can do whatever, turn off the camera, wait a few seconds, and the folder disappears.

I then unplug the camera and plug in my USB stick. Lights flicker, no directory appears but /var/log/messages is full of errors.

If I then do a /sbin/rmmod usb-storage and try again, all's well.

What is going on?! Surely I shouldn't have to rmmod usb-storage every single time?!

Grateful for any pointers. I'm on FC1 (soon to upgrade to FC2).

On a related topic, does anyone know of a program that will pop up a dekstop icon when a usb device is plugged in? Just so I don't have to cd /mnt/auto/autofs all the time. So lazy!

Thank you,

Peter Siepmann
 
Old 09-08-2004, 06:28 PM   #2
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
hi siepmann, welcome to lq. this may be of interest

http://lists.debian.org/debian-lapto.../msg00120.html

found that from a google, seems to address your problem. hope it helps. if it matters this was my search, you may find something more usefull, that was the first thing i saw that looked like a "fix".

http://www.google.com/search?hl=en&i...=Google+Search

good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
After plug in apacer ht202 usb mass storage into usb port. Nothing appear. tellmeimhong Linux - Hardware 3 02-04-2006 02:32 AM
USB Storage cccc828 Slackware 9 05-06-2005 01:38 AM
forcing a USB device to use usb-storage eantoranz Linux - Hardware 1 11-13-2004 07:44 AM
USB Drive \ Mp3 + USB Storage imonfya Linux - Hardware 2 07-09-2004 10:54 PM
USB-Stick/usb-storage JC_at_LQ Linux - General 2 07-14-2003 06:56 AM


All times are GMT -5. The time now is 02:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration