Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 05-26-2009, 12:41 PM   #1
LQ Newbie
Registered: May 2009
Posts: 20

Rep: Reputation: 0
[Solved - Clock] RHEL5: Kerberos Authentication

The Explanation:

I am currently in the process of trying to get RHEL5 to properly authenticate to Kerberos.

The problem:

I have created a test account corresponding to the Username within the Kerberos server, all attempts to switch/login to this user using the Kerberos set password fail.

If I issue a $kinit <username> it will than allow me to login to the username following Kerberos authentication however it is not automatically fetching this information, it has to be manually entered every time (the kinit).



It appears I already had all the packages needed pre-installed during the installation of RHEL5...

Results of (typed) $rpm -qa | grep krb

Initially I went to System > Administration > Authentication

Checked the pretty box named Kerberos and manually replaced the /etc/krb5.conf with an appropriate one.

This is the contents of /etc/pam.d/system-auth (unchanged by hand):

auth        required
auth        sufficient nullok try_first_pass
auth        requisite uid >= 500 quiet
auth        sufficient use_first_pass
auth        required

account     required broken_shadow
account     sufficient uid < 500 quiet
account     [default=bad success=ok user_unknown=ignore]
account     required

password    requisite try_first_pass retry=3
password    sufficient md5 shadow nullok try_first_pass use_authtok
password    sufficient use_authtok
password    required

session     optional revoke
session     required
session     optional
session     [success=1 default=ignore] service in crond quiet use_uid
session     required
session     optional

Unfortunality I can't find any documentation to help with this issue or perhaps I am just not aware of what to look for properly.

Last edited by zachet; 05-26-2009 at 02:28 PM. Reason: Solved
Old 05-26-2009, 01:23 PM   #2
LQ Newbie
Registered: Aug 2004
Location: NY
Distribution: Ubuntu,Red Hat,Centos 5
Posts: 29

Rep: Reputation: 0
Do you have SELinux running? Might be an issue with permissions from it there. You can check your logs (/var/log/messages and /var/log/audit/audit.log) to see if there are any clues of it flagging your login attempts. Since you're able to login using $kinit <username> it's obvious the login your using is correct, something is blocking access to it...and I'll bet it's SELinux if you do have that enabled.
Old 05-26-2009, 02:08 PM   #3
LQ Newbie
Registered: May 2009
Posts: 20

Original Poster
Rep: Reputation: 0
I went ahead and disabled SELinux, it's taking a moment longer on checking the password however it is still returning with an "su: incorrect password".

I went through the logs didn't notice anything too distinguishing, if needed I will drag them out here and just replace the username with <username>.

I deleted and recreated the user I was using verifying the UID was over 1000 and deleted the /tmp/krb* cache, still nothing.


The 'time' on the machine was an hour off, resolved -_-

Last edited by zachet; 05-26-2009 at 02:22 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
using kerberos for login authentication narendra.pant Red Hat 0 09-11-2007 04:31 PM
Kerberos Authentication in SUSE 10.1 paranoid_buddha SUSE / openSUSE 1 06-13-2006 12:28 PM
Kerberos Authentication Comatose51 Linux - Security 2 08-30-2005 07:44 AM
Kerberos Authentication cwinter00 Linux - Security 1 06-16-2005 01:56 PM
Authentication via Kerberos grubjo Linux - Security 0 07-30-2004 12:48 PM

All times are GMT -5. The time now is 09:45 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration