LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-10-2014, 05:31 AM   #1
myus3rname
LQ Newbie
 
Registered: Dec 2014
Posts: 1

Rep: Reputation: Disabled
Talking RHEL 6.5 GLIBC Update


Hi all,

I can appreciate this is a definite newb question, the right place for it.

I have a piece of software I need to install on a RHEL 6 (<6.5) platform which requires GLIBC at version 2.3.4, however - using YUM I can only install version 2.12 and there are no further updates available (No Packages Marked For Update)

I've tried to manually update this from RPMs across the internet (glibc, -headers, -common, -devel) to no avail.

In order to update to later GLIBC versions do I need a better RHEL subscription? or does anyone have a way (or could provide a package list) of upgrading GLIBC without causing a total meltdown

From my reading, I understand the risks associated, but this is purely a test lab instance of RHEL, so I'm not bothered about data-loss/corruption in this instance. But I've seen many posts of users detailing their GLIBC versions for the RHEL build as being much higher that what I'm able to grab via YUM, so surely there is a 'supported' way?

I'm currently using RHEL 6.5.

Thanks for reading

Sam

Last edited by myus3rname; 12-10-2014 at 05:34 AM. Reason: Added current RHEL ver.
 
Old 12-10-2014, 08:31 AM   #2
gdejonge
Member
 
Registered: Aug 2010
Location: Netherlands
Distribution: Kubuntu, Debian, Suse, Slackware
Posts: 317

Rep: Reputation: 73
Quote:
Originally Posted by myus3rname View Post
Hi all,

I can appreciate this is a definite newb question, the right place for it.

I have a piece of software I need to install on a RHEL 6 (<6.5) platform which requires GLIBC at version 2.3.4, however - using YUM I can only install version 2.12 and there are no further updates available (No Packages Marked For Update)
You are aware that 2.12 is a newer than 2.3.x?

Quote:
I've tried to manually update this from RPMs across the internet (glibc, -headers, -common, -devel) to no availo.
Installing a random version of glibc that you downloaded from somewhere is not a good idea, because libc has to be compiled against the kernel it has to operate with.

Quote:
In order to update to later GLIBC versions do I need a better RHEL subscription? or does anyone have a way (or could provide a package list) of upgrading GLIBC without causing a total meltdown
You don't tell us what subscription you currently have, so it's hard to tell.

Quote:
From my reading, I understand the risks associated, but this is purely a test lab instance of RHEL, so I'm not bothered about data-loss/corruption in this instance. But I've seen many posts of users detailing their GLIBC versions for the RHEL build as being much higher that what I'm able to grab via YUM, so surely there is a 'supported' way?

I'm currently using RHEL 6.5.
As i stated before, 2.12 should be good enough if the application expects 2.3.4.

You haven't told us if you tried to install the application and got error messages about the glibc version and what those error messages are.

Cheers,
 
Old 12-10-2014, 10:19 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156
Quote:
software I ... which requires GLIBC at version 2.3.4
Not really. Old software can require a component from glibc-2.3.4.

Have you tried to install this <unknown-software> ?

Some glibc-2.3.4 components are present in versions later than 2.3.4 .

-
 
Old 12-10-2014, 10:21 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156
P.S. :

Glibc is your OS (together with the kernel)
... and cannot be changed.
 
Old 12-10-2014, 01:35 PM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,980

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
Quote:
I have a piece of software I need to install
1) well what is this unknown software ?
2) for WHAT version of redhat was it built for ?

3) and where did you get this unknown program?
a url link would help
 
Old 12-28-2014, 04:11 PM   #6
debguy
Member
 
Registered: Oct 2014
Location: U.S.A.
Distribution: mixed, mostly debian slackare today
Posts: 207

Rep: Reputation: 19
i dont agree with anyone. tell me what GLIBC i have ... (and what it depends on, ld-linux.so perhaps)

objdump -s -s /lib/libc.so.?

now if you see GLIBC.foo defined - you have it, if not, you need it. if RH has a package for it (check their site dont as yum) then see if it's installable if no: you still need it.

upgrading /lib/libc.so or adding a new one (ie, in some cases we have /lib/libc.so.5 /lib/libc.so.6) is NOT TRIVIAL. maybe see the linux documentation project (tldp.org?) to tell you what's involved - a tool chain.

BUT FIRST: in a toolchain you might need new gcc glibc and new other tools. depends on "a software". FIRST FIND OUT WHAT ELSE need after the need you know of GLIBC is met. if you dont know ask "a piece of software" author?

> a piece of software

really you cannot tell us what software (or ie from what distro?)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
glibc problem on RHEL 6.5 Ujio Linux - Server 2 08-31-2014 06:32 PM
glibc errors with passwd on RHEL 4.2 shapptastic Red Hat 0 10-26-2009 02:13 PM
Upgrading RHEL 4 update 4 to RHEL 4 update 6?? your_shadow03 Linux - Newbie 4 09-05-2008 02:16 AM
updating RHEL AS4 update 1 to update 5 via CDs? icemaker Linux - Software 1 06-09-2007 07:29 PM
glibc 2.2 installation on RHEL kars_jk Red Hat 4 01-20-2006 06:19 AM


All times are GMT -5. The time now is 10:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration