LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-12-2012, 09:52 AM   #1
adol83
Member
 
Registered: Jul 2012
Location: Rome
Distribution: RHEL6, CentOs
Posts: 92

Rep: Reputation: 1
Rhel 6.0 santiago passwd no affected in single user mode


Hello,

New installation of Rhel6. No pass settled for root nor user01. I rebooted accessing in single-user mode to input new pass for root and when i'm in command line in single user mode i launch

Code:
[root@localhost]# passwd
but nothing happens and the command line returns

Code:
[root@localhost]#
If i try to login again i cannot.
output of

Code:
 /etc/passwd |grep root
is
Code:
 root:x:0:0:root:/root:/bin/bash
operator:x:11:0:operator:/root:/sbin/nologin
Anyone had this problem before?

Thank you

Davide

Last edited by adol83; 11-12-2012 at 09:56 AM. Reason: added output from /etc/passwd
 
Old 11-12-2012, 10:15 AM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,916

Rep: Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689
Quote:
Originally Posted by adol83 View Post
Hello,
New installation of Rhel6. No pass settled for root nor user01. I rebooted accessing in single-user mode to input new pass for root and when i'm in command line in single user mode i launch
Code:
[root@localhost]# passwd
but nothing happens and the command line returns
Code:
[root@localhost]#
If i try to login again i cannot. output of
Code:
 /etc/passwd |grep root
is
Code:
 root:x:0:0:root:/root:/bin/bash
operator:x:11:0:operator:/root:/sbin/nologin
Anyone had this problem before?
Well, you could try putting in "passwd root" or "passwd user01", and see if it then prompts you for a password. If not, the passwords are probably kept in /etc/shadow. You can remove whatever password is there by editing that file, and removing everything between the first and second colons ( for a particular user. Then, that user will have no password when booting up, and you can see if things behave differently.

And, since you're using RHEL, have you contacted Red Hat support?? You have access to it with your purchase of RHEL.
 
Old 11-12-2012, 10:48 AM   #3
hamlindsza
Member
 
Registered: Aug 2012
Distribution: Debian, CentOS
Posts: 74

Rep: Reputation: Disabled
Hi,

SELinux could be preventing you from chaging root's password.

Disable SeLinux and try again.

lokkit --disabled
 
Old 11-12-2012, 11:01 AM   #4
adol83
Member
 
Registered: Jul 2012
Location: Rome
Distribution: RHEL6, CentOs
Posts: 92

Original Poster
Rep: Reputation: 1
Hello,

I solved. The issue was because of me.

I was loading the image via external disk unplugged and i noticed only later.

The installation because of vmware configuration was automatically starting from cd-rom.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] passwd command not working in single user mode schrodingore Linux - Newbie 19 12-19-2012 12:15 PM
[SOLVED] forgot root passwd, kernel boot in single mode still asks for root passwd nass Slackware 11 05-08-2012 01:37 PM
Non root user cannot login - RHEL 6.0 ( Santiago) saraswathi55 Red Hat 2 12-14-2011 07:47 PM
Unable to Access to Single User Mode or Emergency Mode Pinglu Linux - Newbie 3 10-17-2011 02:25 PM
Emergency mode can mount the HDD with FS error but not in rescue or single user-mode kayod_jj Linux - Newbie 3 12-01-2010 08:03 PM


All times are GMT -5. The time now is 03:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration