LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-12-2007, 09:01 PM   #1
pendulum83
LQ Newbie
 
Registered: Jul 2007
Posts: 4

Rep: Reputation: 0
RHEL 5 Dependancy Issue


I typed "yum update" in terminal (logged in as root),
and here is what I get

Quote:
[root@localhost ~]# yum update
Loading "rhnplugin" plugin
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
rhel-i386-client-5 100% |=========================| 1.4 kB 00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package yelp.i386 0:2.16.0-15.el5 set to be updated
---> Package evolution.i386 0:2.8.0-33.0.1.el5 set to be updated
---> Package vixie-cron.i386 4:4.1-70.el5 set to be updated
---> Package cups-libs.i386 1:1.2.4-11.5.1.el5 set to be updated
---> Package firefox.i386 0:1.5.0.12-1.el5 set to be updated
---> Package samba-client.i386 0:3.0.23c-2.el5.2.0.2 set to be updated
---> Package samba-common.i386 0:3.0.23c-2.el5.2.0.2 set to be updated
---> Package cups.i386 1:1.2.4-11.5.1.el5 set to be updated
---> Package ekiga.i386 0:2.0.2-7.0.2 set to be updated
--> Running transaction check
error: rpmdbNextIterator: skipping h# 406 Header V3 DSA signature: BAD, key ID 37017186
error: rpmdbNextIterator: skipping h# 406 Header V3 DSA signature: BAD, key ID 37017186
error: rpmdbNextIterator: skipping h# 406 Header V3 DSA signature: BAD, key ID 37017186
error: rpmdbNextIterator: skipping h# 354 Header V3 DSA signature: BAD, key ID 37017186
error: rpmdbNextIterator: skipping h# 354 Header V3 DSA signature: BAD, key ID 37017186
error: rpmdbNextIterator: skipping h# 354 Header V3 DSA signature: BAD, key ID 37017186
error: rpmdbNextIterator: skipping h# 354 Header V3 DSA signature: BAD, key ID 37017186
--> Processing Dependency: libpam_misc.so.0 for package: vixie-cron
--> Processing Dependency: libpam.so.0 for package: samba-common
--> Processing Dependency: scrollkeeper for package: ekiga
--> Processing Dependency: libpam.so.0 for package: cups
--> Processing Dependency: libpam.so.0 for package: vixie-cron
--> Processing Dependency: pam >= 0.77-66.8 for package: vixie-cron
--> Processing Dependency: libpam.so.0(LIBPAM_1.0) for package: cups
--> Processing Dependency: scrollkeeper for package: yelp
--> Processing Dependency: libpam.so.0(LIBPAM_1.0) for package: samba-common
--> Processing Dependency: scrollkeeper >= 0.1.4 for package: evolution
--> Processing Dependency: libpam.so.0(LIBPAM_1.0) for package: vixie-cron
--> Finished Dependency Resolution
Error: Missing Dependency: libpam_misc.so.0 is needed by package vixie-cron
Error: Missing Dependency: libpam.so.0 is needed by package samba-common
Error: Missing Dependency: scrollkeeper is needed by package ekiga
Error: Missing Dependency: libpam.so.0 is needed by package cups
Error: Missing Dependency: libpam.so.0 is needed by package vixie-cron
Error: Missing Dependency: pam >= 0.77-66.8 is needed by package vixie-cron
Error: Missing Dependency: libpam.so.0(LIBPAM_1.0) is needed by package cups
Error: Missing Dependency: scrollkeeper is needed by package yelp
Error: Missing Dependency: libpam.so.0(LIBPAM_1.0) is needed by package samba-common
Error: Missing Dependency: scrollkeeper >= 0.1.4 is needed by package evolution
Error: Missing Dependency: libpam.so.0(LIBPAM_1.0) is needed by package vixie-cron
So I search for whatever rpm I am supposed to be missing... on RHN.


It turns out that

'scrollkeeper' is already installed in my system
'libpam' package is nowhere to be found in RHN

Please help me on this issue.
 
Old 07-13-2007, 05:33 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
Learn to use yum to help you find what's is missing;

yum whatprovides libpam.so.0

pam.i386 0.99.6.2-3.14.el5 rhel-x86_64-client
Matched from:
libpam.so.0

You state scrolkeeper is already installed, which version???
scrollkeeper >= 0.1.4 is needed by package evolution
$ rpm -qa scrollkeeper
scrollkeeper-0.3.14-9.el5

Try installing the missing pam package first, but yum should have added the package for installation.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cron Issue on RHEL AS r4 Update 2 jonnynoh Linux - General 7 05-30-2009 11:07 AM
yum dependancy issue ghostmac Linux - Software 1 08-12-2006 07:17 AM
Java Library Issue (RHEL) ptreves Linux - General 1 07-20-2005 03:56 AM
RHEL 3 AS U4 Issue alexander_goron LinuxQuestions.org Member Success Stories 0 04-12-2005 09:52 PM
another RHEL 3 issue with xfree86 hitesh_linux Linux - Enterprise 3 01-26-2005 01:45 PM


All times are GMT -5. The time now is 12:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration