LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 05-06-2008, 02:52 PM   #1
mccartjd
Member
 
Registered: Apr 2008
Posts: 107

Rep: Reputation: 15
Cool RHEL 4 64bit Workstation


what command do i type to disable ftp service running on my system. Later if I want to enable ftp what command would i type?

Thanks
John
 
Old 05-06-2008, 03:07 PM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 13,827

Rep: Reputation: 2370Reputation: 2370Reputation: 2370Reputation: 2370Reputation: 2370Reputation: 2370Reputation: 2370Reputation: 2370Reputation: 2370Reputation: 2370Reputation: 2370
What FTP server are you using? Or are you using SFTP?

You probably want to edit the appropriate FTP config file in /etc/xinetd.d, probably proftpd. Change the line that says "DISABLE=YES" to "DISABLE=NO", then type in "/etc/init.d/xinetd restart". You should be up then.

If you're using vsftpd, you may have to edit the vsftpd.conf file, and start/stop the service manually, with "/etc/init.d/vsftpd start".

SFTP is a better way to go, and is enabled with your SSH server.
 
Old 05-06-2008, 03:30 PM   #3
mccartjd
Member
 
Registered: Apr 2008
Posts: 107

Original Poster
Rep: Reputation: 15
Smile Type of FTP are you Running

I really don't know, just plain FTP I guess. I'm really new at LINUX Earlier you mentioned:

What FTP server are you using? Or are you using SFTP?

You probably want to edit the appropriate FTP config file in /etc/xinetd.d, probably proftpd. Change the line that says "DISABLE=YES" to "DISABLE=NO", then type in "/etc/init.d/xinetd restart". You should be up then.

If I want to be down do I ensure "DISABLE=NO"

Thanks
John
 
Old 05-06-2008, 06:26 PM   #4
frndrfoe
Member
 
Registered: Jan 2008
Distribution: RHEL, CentOS
Posts: 373

Rep: Reputation: 38
Code:
#chkconfig --list | grep ftp
vsftpd          0:off   1:off   2:off   3:on    4:on    5:on    6:off
#chkconfig vsftpd off
#service vsftpd stop
line 1: Find out what FTP you have
line 3: Make it so that ftp will not restart on boot
line 4: turn off ftp service

if line 2 is says off all the way across and you can still telnet to the machine you must have a ftp server built from source and launched from xinitd and you can follow the above instructions... probably.

Last edited by frndrfoe; 05-06-2008 at 06:29 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Ruby on RHEL 4 64bit Neruocomp Linux - Software 2 09-26-2012 05:43 PM
Using RHEL 64bit Not sure how to unlock an account mccartjd Linux - Newbie 2 04-24-2008 06:26 AM
RHEL 5 & VMWare Workstation Beta 6 SimoneDice Red Hat 9 04-18-2007 12:03 PM
RHEL Workstation and AS | Registration the_gripmaster Red Hat 2 09-13-2006 08:25 AM
Cannot install RHEL workstation 3.0 on VIA C3 architechture anybody1234 Linux - Hardware 2 02-17-2006 04:11 AM


All times are GMT -5. The time now is 01:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration