LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-14-2004, 11:16 PM   #1
ignorant
LQ Newbie
 
Registered: Sep 2003
Distribution: RedHat9
Posts: 11

Rep: Reputation: 0
RH9 X server fails


Problem: I can not start X server.
Bigger Problem: I have never done any Linux of any kind what so ever.

Hardware:
Motherboard: Gigabyte GA - 7n400 Pro
Memory: 1 Gig
Video Card 1: GeForce FX 5200 128 MB DDR AGP
Video Card 2: Matrox Millenium
HD: WD 40G
floppy & CDR/DVD
2 nics
Monitor: Samsung 900DF (which has never been recongnized by ANY OS)


I need "never done it before, step by step instructions."
Meaning: the book 'Linux for Dummies' is over my head.

Below is the output.

====================

xfree86 version 4.3.0 (red hat linux release: 4.3.0-2)
release date: 27 february 2003
x protocol version 11, revision 0, release 6.6
build operating system: linux 2.4.20-3bigmem i686 [elf]
build date: 27 february 2003
build host: proky.devel.redhat.com

(==) log file: "/var/log/xfree86.0.log , time: wed apr 14 21:40:33 2004
(==) using config file: /etc/x11/xf86config
(EE) No devices detected.
v(+) ( 77%)

===================

Would you like for me to run the X configuration program?

Yes.

===================


ddcprobe returned bogus values....
Hsync: none
Vsync: none
(it was too fast to get more than that, and I specifically remember telling it H and V sync values during setup)

===================

I will now try to restart the X server again.

OK.

===================

I cannot start the X server (your graphical interface.) It is likely that it is not set up correctly. Would yuou like to view the X server output to diagnose the problem?

Yes.

===================

Back to output. A vicious circle.

===================
 
Old 04-15-2004, 02:48 AM   #2
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
OK I think this is a monitor problem.

get into a terminal <ctr> + <alt> + <F1>

your Xserver terminal is <ctr> + <alt> + <F7>

type in the user

root

and the password with is what you set up during installation


type

Code:
vi /etc/X11/XF86Config
you will get back something like this


# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LG StudioWorks 74m"
DisplaySize 320 240
HorizSync 30.0 - 50.0
VertRefresh 50.0 - 90.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection







have a look at the monitor section


Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LG StudioWorks 74m"
DisplaySize 320 240
HorizSync 30.0 - 50.0
VertRefresh 50.0 - 90.0
Option "dpms"
EndSection



replace the values with the correct ones for your monitor.

QUICK VI TUTORIAL

To insert type

i

to move around make sure you are out of insert mode by taping <ESC> key, then you can move with arrow keys.

to delete go into insert mode and press backspace.

the main thing is that to type stuff in you will have to be in insert mode to do this.

to save the changes type

:wq

note the :

this just says write and quit

to quit without saving type

:q!

good luck
 
Old 04-15-2004, 07:54 PM   #3
ignorant
LQ Newbie
 
Registered: Sep 2003
Distribution: RedHat9
Posts: 11

Original Poster
Rep: Reputation: 0
jax8,

Thank you very much for donating this information. I appreciate it.

I did just as you suggested.

The monitor values were already correct. I verified with Samsung to ensure that the Sync rates were correct, they are.

I still get the same exact output. Again, I am at a loss.
 
Old 04-15-2004, 09:21 PM   #4
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
try pulling one of you graphics cards out.

restart the computer and go though the diagnostics program again.
 
Old 05-04-2004, 06:54 PM   #5
ignorant
LQ Newbie
 
Registered: Sep 2003
Distribution: RedHat9
Posts: 11

Original Poster
Rep: Reputation: 0
jax8, thanks for the suggestions. I still get the same issue. I have considered using a hammer to fix it, but then thought bettter of blaming my hardware..... I keep tinkering with it. I have no idea what to do next, but maybe it'll start working by FM. (FM = f'ing magic)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RH9 FTP install fails moosedrool42 Red Hat 3 02-02-2005 03:56 AM
upgrade RH7.3 to RH9 fails guenter.k Linux - Newbie 0 01-22-2004 11:56 AM
RPM install on RH9 fails hotblack Linux - Software 6 09-02-2003 04:02 AM
RH9 Fails to install under MS-DOS nysethe Linux - General 0 07-28-2003 11:48 AM
RH9 installation fails on boot JezzerP Linux - Distributions 1 07-06-2003 07:20 AM


All times are GMT -5. The time now is 06:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration