LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-15-2003, 07:37 AM   #1
mib
Member
 
Registered: Mar 2003
Location: Canada
Distribution: RedHat 8.0 (Psyche)
Posts: 34

Rep: Reputation: 15
Angry RH8 Lagging Like Crazy


My RedHat 8.0 system is lagging like crazy, especially after I messed with my "Look and Feel" settings. My system is setup like this:

Intel Celeron 733MHz
320MB SDRAM
30GB HDD (split: 15GB for Linux, 10GB for XP, ~2GB for Swap)
40x12x40 Samsung CD-RW
Dual Booting XP Pro and RH8
Running KDE on RH8
Resolution is like 1400xsomething (dont remember; the second highest option)
ADSL Connection
Kernel is 2.4.18-something

Anyone know how I can get RH8 to even come close to match the performance of XP? XP is at least ten times faster than my RH8... when I open something in RH8, it takes at least a full minute before it appears on the screen... and when I'm browsing the internet, it lags like crazy, especially when it's using Java such as on Yahoo! Pool. Oh, and by the way, which is better and why: KDE or Gnome?
 
Old 03-15-2003, 08:00 AM   #2
yngwin
Member
 
Registered: Dec 2002
Location: China
Distribution: Arch
Posts: 359

Rep: Reputation: 33
Which windowmanager is better is mostly a question of taste. You may like to try a lighter desktop like IceWM or XFce, they will run faster than KDE and Gnome, although with your specs there shouldn't be a problem. Also I would suggest using Galeon for webbrowser, it's faster than Mozilla. And besides, there's probably no need for 2 gigs of swap. Someone told me a swap partition of more than 256MB will slow down the system, although you can have more than one swap partition if you really need the space.

And if you really want a more performance enhanced Linux distro, you should try Gentoo.
 
Old 03-15-2003, 08:14 AM   #3
mib
Member
 
Registered: Mar 2003
Location: Canada
Distribution: RedHat 8.0 (Psyche)
Posts: 34

Original Poster
Rep: Reputation: 15
Ok, so where do I get these different "Window Managers"? And how can I resize that swap partition? Tell me more about this Gentoo thing. Thanks.
 
Old 03-15-2003, 08:17 AM   #4
Capt_Caveman
Senior Member
 
Registered: Mar 2003
Distribution: Fedora
Posts: 3,658

Rep: Reputation: 69
Something is wrong with your system. It shouldn't take that long for it to do normal activities especially with a 733MHz processor and 320M RAM. A good rule of thumb for the size of SWAP is anywhere from 1X to 2X the amount of RAM, but I don't think it should slow the system down that much.

When you notice a slowdown run the top command to see what is running. Also the ps command might be informative. Check /var/log/messages for errors. I would go back to look and feel and turn some of the settings back down. Things like animated menu effects can really hog memory. Plus your resolution is really high...1400x!

Some processes will be faster in XP, but RH should be as fast if not faster for the majority of things. You might want to be more specific as to what things are running slow.

As far as KDE vs Gnome, I think they're both great desktops and it's really a matter of your own opinion. You can be more adventurous and try one of the NextStep-ish desktops like yngwin mentioned as well, though they do take getting used to.
 
Old 03-15-2003, 08:22 AM   #5
yngwin
Member
 
Registered: Dec 2002
Location: China
Distribution: Arch
Posts: 359

Rep: Reputation: 33
If you like minimal windowmanagers, I think there's nothing better than waimea, my favourite. Also fluxbox is popular. As you are running RedHat now, look for packages on your install cds, or maybe they have some ftp-site?

For Gentoo check www.gentoo.org
 
Old 03-20-2003, 12:49 PM   #6
pyeager
LQ Newbie
 
Registered: Mar 2003
Distribution: RH 7.2, RH 8
Posts: 4

Rep: Reputation: 0
I'm glad I found this thread! I seem to have the same problem.

Shouldn't the performance of RH8 be at least in the ballpark with Win98? I just installed RH8 on a Compaq Armada 7710MT Laptop (Pentium 150, 144 MB ram), on a removable hard drive (the kind that is standard on this computer) of it's own.

I was shocked to find how slow things seemed to be. The boot process is not inordinately long, but once you get KDE or Gnome running, starting a program takes forever. Once programs are loaded, things don't seem too bad.

It does not appear that anything is wasting CPU cycles, as the load average is in the .1 range when the machine is idle.

Any suggestions on where I might look for the cause of this would be appreciated.
 
Old 03-20-2003, 01:21 PM   #7
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
This does sound rather odd. A minute is certainly far too long for most apps.

Try adding a CPU monitor applet, then starting a program. If it hits 100%, run top in another xterm and see what is sucking up all your CPU time.

If you have an nVidia card, ensure you are using the nVidia binary drivers but NOT the latest one, the version before that is OK though.
 
Old 03-20-2003, 03:04 PM   #8
daviddiemer
LQ Newbie
 
Registered: Mar 2003
Posts: 3

Rep: Reputation: 0
Unhappy

I have a Dell Inspiron 8200 with the following configuration:

1.8 GHz processor
1GB RAM
60GB HD
DVD/CD-RW
1600x1200 LCD panel
NVIDIA GeForce 4 Go 440

I installed Red Hat 8.0 and cannot believe how incredibly SLOW this damn OS is! Mandrake and SuSE had no speed problems. I always run GKRELLM and see the CPU almost always fluctuating between 1 and 6%.

When I just ran the updatedb command, with paths pruned to the core files I'd want to search, it ran for more than 5 minutes. The GNOME System Monitor constantly showed it using 0% CPU during this time.

When I start ANY program, shell, utility, it really doesn't matter, it takes upwards of 1-2 minutes before the program loads.

Finally, when I drag a window, or other such operation, the window is constantly "behind" the cursor movement.

This is totally unlike ANYTHING I've seen before with the other versions of Linux.

Any ideas would surely be appreciated.
 
Old 03-20-2003, 03:08 PM   #9
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
Update to the 3123 build of the nVidia drivers, the default one has extremely poor 2D performance. Do NOT get the latest driver, that also has piss poor 2D performance. 3123 is fine though
 
Old 03-20-2003, 06:59 PM   #10
qulnxsh
Member
 
Registered: Mar 2003
Distribution: Debian Sid
Posts: 50

Rep: Reputation: 15
One question, does hard disk DMA have to do anything with the slowdown? Maybe that is the problem, it happened to be the problem with a PII 366 Mhz laptop with 64 MB of RAM I was working on. I enabled DMA, and then the system was so much faster.
 
Old 03-20-2003, 07:15 PM   #11
JayCnrs
Member
 
Registered: Mar 2003
Location: Winnipeg
Distribution: Suse 9.3 Pro
Posts: 404

Rep: Reputation: 30
Yes more than likely DMA isn't enabled try:

hdparm /dev/hda (if using ide hdd)

Then see if DMA=1 which means that it is on, if not you will have to enable it I found this website about hdparm quite informative:

hdparm command

I have a 1.6 Ghz Dell Inspiron and have had no problems with speed of KDE, but you could try a lighter one such as Blacbox or Fluxbox people seem to be really enjoying Fluxbox.
 
Old 03-21-2003, 07:44 AM   #12
pyeager
LQ Newbie
 
Registered: Mar 2003
Distribution: RH 7.2, RH 8
Posts: 4

Rep: Reputation: 0
JayCnrs seems to be on to something!

hdparm's buffered disk read test reports a pathetic 2.39 MB/sec!

Unfortunately, when I try to set DMA mode, hdparm says:
HDIO_SET_DMA failed: Operation not permitted

Yes, I did run the hdparm command as root! 8^)

Can anyone suggest why I can't set DMA mode, or anything else helpful?

TIA!

Paul
 
Old 03-24-2003, 07:44 AM   #13
pyeager
LQ Newbie
 
Registered: Mar 2003
Distribution: RH 7.2, RH 8
Posts: 4

Rep: Reputation: 0
it's the driver! (and perhaps more) READ THIS if you have Armada 7700

First, thanks to all who responded! Hopefully, the following will be helpful to someone in the future!

As installed, hdparm and the drivers would not allow DMA to be enabled, although enabling 32-bit transfers (hdparm -c1 <device>)
did increase performance from approx 2.3 to 3.4 MB/s.

Examination of dmesg output revealed that there was no support present for the Compaq IDE controller. Some web searching revealed that a driver has been recently written, and is part of the 2.4.21-pre5 kernel.

Building and installing that kernel improved things to around 10.5 MB/s, but there appears to room for improvement. It appears that the drive remains in mdma2 mode, when it is capable of at least udma2.
 
Old 03-25-2003, 01:05 PM   #14
daviddiemer
LQ Newbie
 
Registered: Mar 2003
Posts: 3

Rep: Reputation: 0
There IS some kind of configuration problem with Red Hat 8.0 (fully patched or unpatched). I already tuned my hard drive like this:
hdaprm -a64 -A1 -c3 -d1 -k1 -K1 -m16 -r0 -S36 -u1 -W1 /dev/hda

For the DVD/CD-RW, I configured it like this:
hdparm -c3 -d1 -k1 -K1 -r0 -u1

Here's the interesting point, when I ran hdparm -t -T /dev/hda on Red Hat BEFORE X starts, the numbers look great:
timing buffer-cache reads: 343.14 MB/sec
timing buffered disk reads: 21.24 MB/sec

Now take a look after X starts on Red Hat:
timing buffer-cache reads: 346.14 MB/sec
timing buffered disk reads: 10.32MB/sec

Compare that to Mandrake Linux 9.0:
timing buffer-cache reads: 387.88 MB/sec
timing buffered disk reads: 20.71 MB/sec

And this isn't the only machine this is happening on. I've installed RH 8.0 on a Dell server, a Dell workstation, and a Dell laptop (mine). ALL have the same lousy performance characteristics. Unless a program has been loaded already and is in cache, we ALWAYS wait 15-17 seconds (at a minimum) before the program actually opens. When I opened OpenOffice writer on my laptop, the program required 1 minute and 22 seconds to load!

Good luck to those of you sticking with Red Hat. Our company has decided to move to a more responsive Linux: Mandrake.
 
Old 03-25-2003, 01:35 PM   #15
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
Try filing a bug with bugzilla, if they don't have an answer, then maybe it'll be fixed in future.

FWIW this issue seems to be pretty rare, though I have heard of people having large startup times, it's definately unusual.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
openGL Lagging logosys Linux - Newbie 1 09-25-2005 03:08 AM
Lagging music from cdrom dopefish Linux - Software 0 03-29-2004 05:00 AM
lagging running slackware wrathiron Slackware 3 08-25-2003 07:38 PM
Lagging after installed RH9 Contempt Linux - Software 2 07-24-2003 05:49 AM
PC suddenly lagging SiriusAB Linux - Newbie 3 05-21-2003 11:33 PM


All times are GMT -5. The time now is 11:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration