LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-01-2004, 09:35 PM   #1
air4time
Member
 
Registered: Aug 2004
Distribution: Slackware 10.2
Posts: 35

Rep: Reputation: 15
RH 9 upgraded Kernel, then tried to update Gimp. Now X windows does not work???


I have RH 9 installed on my Dell laptop(Latitude CPi). Everything worked fine until I tried to get upgrade the Kernel to 2.6. I thought everything went ok but then RPM woud not work. And the mods seem not to work either but since I buit in al my laptop had that did not bother me.

So mosty my laptop was running ok. X was runing fine, was able to get my wireless card working , was able to map all network drives on my local network.

Then I tried to update Gimp. Make a very long story short now my X does not work. I tried updating Xfree86 and it seem to work fine. But when I try to start X
it crashes. And at reboot the start up GUI now is just a gray screen with a "X" for the cursor and when I move it a question some what pops up (can not tel what it says some of the letters or ether missing or missed up) no matter which of the two I pick it seems to refresh and go back to gray.

Now I can access a shared drive and that is where I have downloaded most of the upgrade stuff. One problem I have I no longer have access to a cdrom so a restall is not a option(I hope). I duel boot the laptop and have win98 on it also.

I think I have some stuff looking in /usr and other stuff looking in /usr/local . Because at first I only was using sorce files not RPM.

I would like to fix this instead of reinstall since it appears other then X stuff Linu x (2.6 ) is running fine. I would like to get rid of all I can and fix what I have. Any log files that may be needed please let me know and I will put them up. I just thought after I explain what I had done the problem would be clear , just the solution hard.

Thanks for all help in advance
 
Old 08-01-2004, 09:52 PM   #2
zero79
Member
 
Registered: Nov 2003
Location: Ohio
Distribution: Debian Unstable
Posts: 460

Rep: Reputation: 30
if you're using the nvidia driver, you need to recompile it after a kernel update, just do

Code:
su -c "nvidia-installer --force-update"
 
Old 08-01-2004, 10:10 PM   #3
air4time
Member
 
Registered: Aug 2004
Distribution: Slackware 10.2
Posts: 35

Original Poster
Rep: Reputation: 15
It has the Neomagic 256 av card. X worked fine ti I tried the upgrade of Gimp and all it's deps. I think it was "GTK+" that was the one but am unsure. I did not catch the problem until a reboot and I was not using X before hand so not really sure which did it.

Thx Lonnie
 
Old 08-01-2004, 10:18 PM   #4
zero79
Member
 
Registered: Nov 2003
Location: Ohio
Distribution: Debian Unstable
Posts: 460

Rep: Reputation: 30
if gtk is broken, you may need to use kdm instead of gdm until you get that fixed. switch to a virtual console (CTRL-ALT-F1), log in as root and type

Code:
/etc/init.d/gdm stop
/etc/init.d/kdm start

Last edited by zero79; 08-01-2004 at 10:19 PM.
 
Old 08-01-2004, 10:52 PM   #5
air4time
Member
 
Registered: Aug 2004
Distribution: Slackware 10.2
Posts: 35

Original Poster
Rep: Reputation: 15
Thought you had it. It looked a lot better(more color) but almost same resuts got into a restart loop had to manual stop. But next time I started with "kdm start >& kdm.log" and here is the results:


_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/linuxlaptop2:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

XFree86 Version 4.4.0
Release Date: 29 February 2004
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.6.6 i686 [ELF]
Current Operating System: Linux linuxlaptop2 2.6.6 #5 Sun Jun 20 15:22:54 CDT 2004 i686
Build Date: 12 July 2004
Changelog Date: 29 February 2004
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sun Aug 1 22:37:54 2004
(==) Using config file: "/etc/X11/XF86Config"
Could not init font path element /usr/X11R6/lib/X11/fonts/TTF/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
X Error of failed request: BadLength (poly request too large or internal Xlib length error)
Major opcode of failed request: 155 (RENDER)
Minor opcode of failed request: 20 (RenderAddGlyphs)
Serial number of failed request: 147
Current serial number in output stream: 203
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/linuxlaptop2:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

XFree86 Version 4.4.0
Release Date: 29 February 2004
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.6.6 i686 [ELF]
Current Operating System: Linux linuxlaptop2 2.6.6 #5 Sun Jun 20 15:22:54 CDT 2004 i686
Build Date: 12 July 2004
Changelog Date: 29 February 2004
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sun Aug 1 22:38:06 2004
(==) Using config file: "/etc/X11/XF86Config"
Could not init font path element /usr/X11R6/lib/X11/fonts/TTF/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
X Error of failed request: BadLength (poly request too large or internal Xlib length error)
Major opcode of failed request: 155 (RENDER)
Minor opcode of failed request: 20 (RenderAddGlyphs)
Serial number of failed request: 147
Current serial number in output stream: 203
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/linuxlaptop2:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

XFree86 Version 4.4.0
Release Date: 29 February 2004


Hope this heps and thx so much for your help

Lonnie

PS I am having to reboot to use windoz for browsering. :-)
 
Old 08-01-2004, 10:58 PM   #6
air4time
Member
 
Registered: Aug 2004
Distribution: Slackware 10.2
Posts: 35

Original Poster
Rep: Reputation: 15
sorry here is the rest

Changelog Date: 29 February 2004
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sun Aug 1 22:38:18 2004
(==) Using config file: "/etc/X11/XF86Config"
Could not init font path element /usr/X11R6/lib/X11/fonts/TTF/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
X Error of failed request: BadLength (poly request too large or internal Xlib length error)
Major opcode of failed request: 155 (RENDER)
Minor opcode of failed request: 20 (RenderAddGlyphs)
Serial number of failed request: 147
Current serial number in output stream: 203
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/linuxlaptop2:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

XFree86 Version 4.4.0
Release Date: 29 February 2004
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.6.6 i686 [ELF]
Current Operating System: Linux linuxlaptop2 2.6.6 #5 Sun Jun 20 15:22:54 CDT 2004 i686
Build Date: 12 July 2004
Changelog Date: 29 February 2004
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sun Aug 1 22:38:29 2004
(==) Using config file: "/etc/X11/XF86Config"
Could not init font path element /usr/X11R6/lib/X11/fonts/TTF/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
X Error of failed request: BadLength (poly request too large or internal Xlib length error)
Major opcode of failed request: 155 (RENDER)
Minor opcode of failed request: 20 (RenderAddGlyphs)
Serial number of failed request: 147
Current serial number in output stream: 203
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgraded to 9.2, you thinks I have 9.1. Can't update. gkiagia Suse/Novell 7 09-04-2005 09:22 AM
upgraded kernel to 2.6.10 but several things do not work now! parv Fedora 2 02-28-2005 10:22 AM
Upgraded kernel, NDISwrapper don't work no more nyghtone Linux - Laptop and Netbook 2 04-15-2004 10:27 PM
After kernel update some things dont work Vencalator Linux - Newbie 9 09-18-2003 04:10 AM
upgraded kernel and now modem won't work... lowlight Linux - Networking 0 09-11-2003 01:06 AM


All times are GMT -5. The time now is 08:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration