LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-10-2003, 07:27 PM   #1
VKellyV
LQ Newbie
 
Registered: Aug 2003
Posts: 11

Rep: Reputation: 0
RH 9 and Win XP dual boot, no GRUB upon boot?


I have done a large amount of reading and finally tried to install Red Hat Linux 9 so I could dual boot it with my already installed Windows XP pro OS.

I started by using Partition Magic 7 to open up some free unallocated space (previously under my windows partition) at the end of my hard drive.

I rebooted from rh 9 cd 1 and went through the steps to install the OS. I chose the GRUB boot loader and requested that it be placed on the first sector of the boot partition (since I have read in numerous places that problems can occur when placing it on the MBR).

I rebooted and no GRUB boot loader showed up, it just started up in windows.

So I tried rebooting by using the linux boot diskette I created during the installation. The first time I tried installing, it simply stated BOOT FAILED. The second time I installed it, it would print some intro lines (not anything that gave me an indication it was starting, just like introductory material), and then gave the BOOT FAILED message again.

The diskette doesn't work and I don't get an option to choose win xp or linux when I start, so cannot start linux even though the installation seemed to work fine.

I could maybe create a new diskettee by running linux rescue mode under the cd but don't know the specific commands needed to do this, could anyone give me a step-by-step to do this?

Also, I have a feeling that maybe the boot loader doesn't work because my computer must still follow the 1024 cylinder boundary rule for the /boot partition. All the partitions are at the end of the hard drive after my win xp partition. Everyone says that newer computers don't have this restriction but I can't find a listing anywhere of what they mean by "newer." My computer is a 2001 and has a Maxtor 5T040H4, Ultra ATA, Hard Drive. I got this idea since I read somewhere that the ATA doesn't have the capability of booting beyond the 1024 cylinder boundary but the ATA2 does.

Can anyone tell me if this is the case if you've had a similar problem? I might have to try to put the /boot partition before the 1024 cylinder boundary but am worried about what it will do to windows when I try to move that partition over to make room for the /boot partition. If anyone has done this, could you give me a step-by-step of what you did (if using Partition Magic)?

Thanks,
Kelly

Dell Dimension 8100
40 GB
1.7 GHz
256 MB RAM
32 MB NVIDIA GeForce 2 GTS/GeForce 2 Pro
Turtle Beach Santa Cruz Sound Card
 
Old 08-11-2003, 04:28 AM   #2
VKellyV
LQ Newbie
 
Registered: Aug 2003
Posts: 11

Original Poster
Rep: Reputation: 0
Talking Solution to my problem

Ok, I finally got this windows xp and red hat linux 9 dual boot on one hard drive to work!! I figure I should post everything I did in case anyone else has the same problem:

Windows XP pro was already installed on my computer (FAT32 file system). I used Partition Magic 7 to created unallocated space out of unused space in the windows partition (at the end of the hard drive).

I rebooted with the Red Hat installation cd 1. I went through installing everything, using automatic partitioning of the unallocated space (but reviewing the partitions it created). I chose Grub as my boot loader but placed it on the first sector of the boot partition (/boot). I put it here rather than on the MBR because I read how people ran into trouble a lot of times (especially with being able to boot windows) when they did this.

After the installation, I rebooted and then I was not given any option to start linux, windows just started automatically like always. So now I basically followed the instructions in this article:

http://www.geocities.com/epark/linux...w2k-HOWTO.html

I put cd 1 back into the drive and rebooted. At the boot: prompt, I typed “linux rescue”. I then changed to the root by typing “chroot /mnt/sysimage”. Here I found out which was my /boot partition by using the “df” command. In my case, my boot partition was /dev/hda2. So then I typed “grub-install /dev/hda2”. I displayed my /etc/grub.conf file by using the “cat” command and verified that it had an entry for windows (it called it dos).

Next, I copied the linux.bin file to a floppy by doing the following. My /dev/fd0 device was not listed in my /etc/fstab file, but I was still able to mount it by creating a directory called “floppy” in the mnt directory. After creating the directory, I made sure I had a floppy in my a: drive (as it is called in windows) and typed “mount –t msdos /dev/fd0 /mnt/floppy”. After mounting, I typed “dd if=/dev/hda2 of=/mnt/floppy/linux.bin bs=512 count=1”. This copied the file to the floppy. I then exited and rebooted into windows.

I copied linux.bin from the floppy into the c:\ directory. Then I opened the boot.ini file in notepad by going to Start->Run and entering “notepad C:\boot.ini”. I then added the line c:\linux.bin=”Linux” to the end of the file and saved it.

I was able to alter the file but it is possible that someone else’s file may be set as read-only. You can’t even see the file in My Computer because it is hidden. To make it visible and uncheck read-only so you can alter the file, you can go to Tools on the menu->Folder Options->View and then select “Show hidden files and folders” and deselect “Hide protected operating system files (Recommended)”. After this, you should be able to see the boot file. You can then right-click it and select Properties. In the dialog box, unselect read-only so you can alter the file. After you alter the file by adding that line to the end, save it, and change all the settings back to how they were (i.e. recheck read-only, etc).

After this, I rebooted. A text window came up and gave me the option of booting into windows xp professional or linux. If I chose windows xp, xp started like it usually does. If I chose linux, then I got another window asking me to chose linux or dos. If I chose linux, then linux started up. Because it was my first time starting it, I had to go through a little set-up tutorial and on the final box before linux started, I got this error:

Could not look up internet address for x1-6-00-5b-1b-99-60. This will prevent GNOME from operating correctly. It may be possible to correct the problem by adding x1-6-00-5b-1b-99-60 to the file /etc/hosts.

I said log in anyway and everything seemed ok. This is the last question I have about my setup. What should I do here? How do I add whatever that is to /etc/hosts?

Otherwise, I am very happy with this setup because if I ever wanted to make my computer windows only again upon booting, I just have to alter the boot.ini file and it will start up just in windows as if linux wasn’t even on my hard drive.

Kelly

Dell Dimension 8100
40 GB
1.7 GHz
256 MB RAM
32 MB NVIDIA GeForce 2 GTS/GeForce 2 Pro
Turtle Beach Santa Cruz Sound Card
 
Old 08-12-2003, 12:05 AM   #3
slackmagic
Member
 
Registered: Aug 2003
Distribution: Slackware
Posts: 253

Rep: Reputation: 32
great you got the dual boot to work!

here is some useful info for that prompt you're getting with GNOME:

http://www.linuxquestions.org/questi...threadid=81088



Hope this helps!
 
Old 08-12-2003, 12:09 AM   #4
slackmagic
Member
 
Registered: Aug 2003
Distribution: Slackware
Posts: 253

Rep: Reputation: 32
I'm sorry Vkelly, but I just realized what I just read.

It sems that you're not really having the "proper" dual boot as it's supposed to be.

Usually either with grub or lilo, it gives u 2 options - either option should bring you straight into the O/S you have selected without asking for a "second" choice screen

you might want to check into this:

http://www.linuxquestions.org/questi...threadid=80965

for a proper dual boot...and repost if u have any other questions..
 
Old 08-12-2003, 04:08 AM   #5
VKellyV
LQ Newbie
 
Registered: Aug 2003
Posts: 11

Original Poster
Rep: Reputation: 0
Yes, I think I should have two boot screens when loading Linux though having only one would be ideal. Here is why:

I installed grub on the first sector of the linux /boot partition, not the MBR so windows still owns the MBR. I altered the windows boot loader (boot.ini) to point to the linux.bin file which I copied from linux to windows c:\ drive. So when I boot, windows boot loader asks me to choose between windows or linux, if I pick linux, then grub loads and asks me to pick between linux or dos. But if I pick windows from the windows boot loader, then windows starts right away without the extra step.

I guess I could have tried to install grub on the MBR to avoid this extra step. But I was afraid to after reading a bunch of posts about other people trying to do the same dual boot and who had installed grub on the MBR and then were unable to get back into windows. They had to use a windows rescue disk and rewrite the MBR using fdisk. Did you put grub or lilo on the MBR?

Right now I think I can live with it as I am still very new at linux. Plus, it is very fast to go from one boot loader to the next. It is almost like pressing enter just one more time to get it to go into linux.

Now I just need to figure out how to maybe add another partition to transfer files between the two operating systems. Have you done this?

Thanks,
Kelly

Windows XP pro and Red Hat Linux 9 dual boot with grub
Dell Dimension 8100
40 GB
1.7 GHz
256 MB RAM
32 MB NVIDIA GeForce 2 GTS/GeForce 2 Pro
Turtle Beach Santa Cruz Sound Card
 
Old 08-12-2003, 07:34 AM   #6
slackmagic
Member
 
Registered: Aug 2003
Distribution: Slackware
Posts: 253

Rep: Reputation: 32
hi there again,

sure have

what you need to do is you will have to create a FAT32 partition - I think anything less than 32GB or 30 (I forgot) can be set as a FAT32 partition when formatted. Anything after that will end up being a NTFS (which) is already supported partly, but as READ ONLY under Linux.

Once you have created an extended (logical) FAT32 Partition, Windows as well as Linux will be able to READ / WRITE to it.

IF you want to find out more about this, simply go to SEARCH and use keywords like:

Search: mount windows in linux
-
including these keyswords: mounting AND vfat

that should bring up the pretty well discussed threads about how to mount a fat32 (vfat under linux) and it will allow you to share data between the two o/s.

hope this helps
 
Old 08-12-2003, 07:34 AM   #7
seidren
Member
 
Registered: May 2003
Distribution: Ubuntu, Windows XP
Posts: 90

Rep: Reputation: 16
Installing Windows 98, XP and Linux

This is what happened to me when I installed Windows 98, XP and Red Hat Linux 9

I first Install Windows 98 on my C:\
Then I Install Windows XP on My D:\

Now when I boot up I get the boring prompt to choose between 98 and XP
ok fine
then I install Red Hat 9
When I am offered to choose the boot loader I choose grub. But I dont even bother going in to the advanced boot options. I just let Red Hat Figure out what to do.
The setup also tells me that it found another OS and calls it DOS
I dont do anything to it, I put Linux as the default and continue setup.

After everything is done When I boot up I get the lovely boot screen with Red Hat Linux and Dos listed.
When I choose 'Red Hat' linux starts properly
When I choose DOS I go to the boring prompt to choose from Windows 98 or XP

I go to Windows 98 and change the boot.ini file so that windows XP is loaded by default and there is no timeout.

This is my boot.ini file

[boot loader]
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Windows XP" /fastdetect
C:\="Windows 98"

Dont Worry, at this stage you can only boot Linux and
XP.

Now you have to reboot and go to linux and change the
entries in the Grub.conf file

For the moment there should be 2 entries
One for Linux and One for 'DOS'
Change the name dos to read Windows XP
Create another entry for Windows 98 (this is simple
you should be able to guess this from the way the
other entries are created)

This is what my grub.conf looks like

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,9)
# kernel /vmlinuz-version ro root=/dev/hda11
# initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=10
splashimage=(hd0,9)/grub/splash.xpm.gz
title Red Hat Linux
root (hd0,9)
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ hdd=ide-scsi
initrd /initrd-2.4.20-8.img
title Windows XP
rootnoverify (hd0,0)
chainloader +1
title Windows 98
rootnoverify (hd0,0)
chainloader /bootsect.dos

the bootsect.dos is a hidden file in C:\ and it boots Windows 98. By the way I found this accidentally.

So Now you should be able to choose from booting into windows 98, XP or Linux all in one boot screen. And best of all the boot screen is good looking and you can change the background image etc... as well.

FINE ISNT IT ???.
The problem is that I dont know what the default action of the Red Hat installer is. We have a choice of choosing to install grub on the MBR or the Boot Sector of the boot partition. But choosing them explicitly will screw up. When you let the installer figure it out, it works.

Any one who knows what REALLY is happening please tell me.

For the moment I can load Windows 98. XP and Red Hat 9 without any problem.

I hope that this post come useful to all of you
 
Old 08-12-2003, 07:46 AM   #8
slackmagic
Member
 
Registered: Aug 2003
Distribution: Slackware
Posts: 253

Rep: Reputation: 32
first of all I need to congratulate you. What you've done is actually very nice!

I would have done the same thing as per Grub or lilo being able to choose between Linux and 'Dos' and then get a second prompt up on the DOS selection since you are running win98 and winxp there.

Didn't even think of configuring the grub.conf and setting it all up through 1 boot manager. hehe...great job!

I have installed RH with configuring and withou configuring the boot manager and I haven't had a problem with that yet, so I think it doesn't matter if you let it set it up automatically or whether you kinda change options such as boot as MBR or from boot sector of boot partition - this is just to my knowledge and might only be like that because of RH 7.3 / 9.0 and my system setup...I'm not sure.

Anyhow, it's great to know that you can set it all up under one thing and yes, I definetely like the capability to change background images etc...through lilo or grub hehe

RH 7.3 and RH 9.0 - I had LILO running the first time as recommended by others - I think it's maybe more customizable, however the first look was not good or let's say not what I wanted to see. GRUB however looked pretty neat on its first appearance...so..it's definetely upon your own taste whether u choose grub or lilo...i'd say test them both out and you'll gonna find it out
 
Old 08-12-2003, 08:08 AM   #9
seidren
Member
 
Registered: May 2003
Distribution: Ubuntu, Windows XP
Posts: 90

Rep: Reputation: 16
You know something I actually installed windows 98, XP and Linux all three in one day and guess what, I installed them all 4 times (FOUR).

I was on the machine from 6.00AM to 3.00AM next day.
And I was glad that I finally figured out how to get it done.
 
Old 08-12-2003, 08:32 AM   #10
slackmagic
Member
 
Registered: Aug 2003
Distribution: Slackware
Posts: 253

Rep: Reputation: 32
hehe...that's dedicated hard work!

hope you had your wife/gf, beer and chips with you hehehehe
 
Old 08-12-2003, 09:25 AM   #11
seidren
Member
 
Registered: May 2003
Distribution: Ubuntu, Windows XP
Posts: 90

Rep: Reputation: 16
Hey dude! I am not married yet!!!
lol
Todays my birthday and I am just 18 have a long way to go

Though I have a gf. She is so stupid that she will never understand what I do on my computer !!!!
 
Old 08-12-2003, 10:21 AM   #12
slackmagic
Member
 
Registered: Aug 2003
Distribution: Slackware
Posts: 253

Rep: Reputation: 32
no comment hehe
 
Old 08-12-2003, 04:13 PM   #13
VKellyV
LQ Newbie
 
Registered: Aug 2003
Posts: 11

Original Poster
Rep: Reputation: 0
Re: Installing Windows 98, XP and Linux

Quote:
Originally posted by seidren

The problem is that I dont know what the default action of the Red Hat installer is. We have a choice of choosing to install grub on the MBR or the Boot Sector of the boot partition. But choosing them explicitly will screw up. When you let the installer figure it out, it works.
I know that the default is for linux to install the boot loader on the MBR. If you go to advanced settings during the install, you will see that MBR is selected. Then, you have the choice of changing it to put the boot loader on the first sector of the /boot partition if you want.

Now I am thinking maybe I should have just installed it on the MBR as it seems you didn't have any problems after doing so. Then I would have the nice grub interface only.

Quote:
Originally posted by seidren

Though I have a gf. She is so stupid that she will never understand what I do on my computer !!!!
Oh, and I can't believe you said that about your girlfriend on the board, lol. Just be glad you didn't say that about girls in general, .

Kelly
 
Old 08-12-2003, 05:41 PM   #14
slackmagic
Member
 
Registered: Aug 2003
Distribution: Slackware
Posts: 253

Rep: Reputation: 32
rofl
 
Old 08-12-2003, 11:36 PM   #15
seidren
Member
 
Registered: May 2003
Distribution: Ubuntu, Windows XP
Posts: 90

Rep: Reputation: 16
Quote:
Now I am thinking maybe I should have just installed it on the MBR as it seems you didn't have any problems after doing so.
I didnt choose to install it on the MBR!!!
Quote:
I installed them all 4 times (FOUR).
The first time was the default. I didnt choose any options and the whole thing worked.
But then I found out that the partition I set for my MP3s was too small so I repartitoned the whole drive from beginning.
Then I installed 98 and XP again, and then when installing Linux I chose to install grub in the MBR.
When I booted I Could only boot Red Hat.
Actually the Windows XP bootloader has to be on the MBR to boot at all.
So now again I format the drives and install 98 and xp for the 3rd time and then when installing linux I chose to install it in the boot partition.
But now when I rebooted I dont see grub loaded, only the boring screen where I can only choose from Windows 98 and XP.

So finally I do everything again and install RedHat with NO ADVANCED BOOT OPTIONS.
And everything works fine!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual Boot Problem: FC4 and Win XP; GRUB not appearing ZeroIdea Fedora - Installation 7 11-18-2005 11:50 PM
Trying to Dual boot Win XP & FC4. Grub doesnt come up at all. Gordon99 Fedora - Installation 3 10-05-2005 10:09 AM
MBR and/or 1st Sector of HDA1 kaputt after attemting dual boot (win/suse9.1) w/ grub Nathanael Linux - General 2 05-29-2004 08:08 AM
GRUB unfound on dual boot RH9 & Win XP TCDnewbie Linux - Laptop and Netbook 1 02-13-2004 07:52 AM
Problems booting with GRUB on RH 7.3/ Win XP Dual Boot pasta4u2 Linux - Newbie 8 10-07-2002 11:22 PM


All times are GMT -5. The time now is 10:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration