LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-13-2003, 11:05 PM   #1
the_idoru
LQ Newbie
 
Registered: Feb 2003
Posts: 5

Rep: Reputation: 0
Question RH 8 sound with an Asus A7N8X mobo


i have an Asus A7N8X motherboard that has integrated sound and i recently installed RedHat 8 (totally new to linux, btw). sound wouldn't work, so i downloaded and installed the nForce2 drivers from nVidia (http://www.nvidia.com/view.asp?IO=linux_nforce_1.0-0248). i know they installed properly because i am accessing the internet via the onboard ethernet card. In Gnome as root, System Settings > Soundcard Detection gives me a tab that says:

Vendor: Unknown vendor
Model: Generic nvaudio device
Module: nvaudio

but no sound plays when i hit "play test sound". the speakers are turned up, so i go to check the volume settings to make sure they're up too. Sound & Video > Volume Control gives me an error message:

Error (gnome_volume_control) I was not able to open your audio device. Please check that you have permission to open /dev/mixer and make sure you have sound support compiled into your kernel.

again, i'm root so 'permission' shouldn't be a problem. i've even installed sndconfig and run that. it gives me:

Model: Unknown vendor | Generic nvaudio device

but then says that it's not currently supported and quits.

so giving up on onboard audio, i plunked in my old SB Live! card. surely, that will work, right? nonono. first off, sndconfig quits after detecting and dismissing the nvaudio device, so it never even gets to see the SB Live (there is no jumper on the mobo for disabling the onboard audio so no way around it). System Settings > Soundcard Detection detects the SB Live. it says the module is emu10k1 but "play test sound" does nothing. i've been up and down this thread (http://www.linuxquestions.org/questi...highlight=live) and have tried anything and everything. but no dice.

oh, and i've searched my BIOS for a way to disable Plug n Play devices but the options seem a bit cryptic. i disabled what seemed to be the closest option. can't remember what it was called but it seemed close at the time. whatever it was, the computer's still running with it disabled.

ugh. so that's where i am now. a very quiet RH 8 box. i'm really getting tired of listening to the fans so if anyone could lend a hand, i'd *really* appreciate it.
 
Old 02-14-2003, 10:20 AM   #2
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
You need to disable the on-board audio in the BIOS to have the SB live work right.

# Redhat links
Red Hat Linux Manuals
Maximum RPM
rpmfind
Easier software management: APT-RPM - Red Carpet

# Redhat 8.0 configuration commands
Configure soundcard:
redhat-config-soundcard
Configure X server:
redhat-config-xfree86

Last edited by fancypiper; 02-14-2003 at 10:22 AM.
 
Old 02-14-2003, 10:55 PM   #3
the_idoru
LQ Newbie
 
Registered: Feb 2003
Posts: 5

Original Poster
Rep: Reputation: 0
bingo

THANK YOU JEBUS! i mean, fancypiper.

with all the things i've been through trying to get the sound to work, you'd think i would have tried that. whatever, it works and i am greatly indebted. thanks!
 
Old 02-14-2003, 11:05 PM   #4
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
If you have realplay installed, now you can listen to me play here:

http://naomisfancy.virtualave.net/1stcd.html
 
Old 04-08-2003, 09:25 PM   #5
angeoj
LQ Newbie
 
Registered: Apr 2003
Distribution: RH9
Posts: 3

Rep: Reputation: 0
Same issue here

I'm in the same situation as the_idoru originally posted. I have the A7N8X Deluxe mobo. RH 8.0 Distro. I've downloaded and installed the latest RPM from nVidia's site. The onboard soundcard doesn't work, but yes, my nVidia NIC works fine. However, I don't have a separate soundcard to install onto my mobo. How can I get the onboard soundcard to work?
 
Old 04-08-2003, 11:48 PM   #6
sinokonka
LQ Newbie
 
Registered: Apr 2003
Posts: 12

Rep: Reputation: 0
to angeoj:

I 've encountered the same. And I use the "hwinfo" utility to check the chipset on the sound card automatically.
Then, I surf the URL or google for solutions.

 
Old 04-09-2003, 09:29 PM   #7
angeoj
LQ Newbie
 
Registered: Apr 2003
Distribution: RH9
Posts: 3

Rep: Reputation: 0
More info, please

To sinokonka:

Do you have any more information? Please provide URLs from your Google searches, and more details about how you solved this annoying problem. Also, what is the hwinfo? Is it the same as hwbrowser? When I run hwbrowser, a window about 1/4 the size of my screen flashes up and disappears quickly. I think that may mean that everything is OK with my hardware, but yet still no sound.
 
Old 04-10-2003, 11:06 AM   #8
sinokonka
LQ Newbie
 
Registered: Apr 2003
Posts: 12

Rep: Reputation: 0
the "hwinfo" is a routine based on the ms-dos. you can surf this site for download:

http://down.96669.com/down/hwinf488.zip

Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
sound with ASUS A7N8X-X KhalidB Linux - Hardware 2 01-17-2005 07:11 PM
Red Hat 9.0 on an Asus A7N8x Mobo lamedavis Linux - Hardware 7 01-23-2004 01:39 PM
Asus A7N8X mobo + RH 7.3 bones996 Red Hat 1 11-22-2003 08:03 AM
asus a7n8x Deluxe Sound def4ult Linux - Hardware 3 11-18-2003 11:04 AM
Audigy 2, Intagrated A7n8x mobo sound, Mandrake 9.1 help SonKun Linux - General 3 11-02-2003 06:49 AM


All times are GMT -5. The time now is 07:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration