LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-06-2002, 11:16 PM   #1
necromanx13x
LQ Newbie
 
Registered: Oct 2002
Posts: 3

Rep: Reputation: 0
Rh 8.0 Ntfs


i know this question has probably been asked before but what is the easiest was to set up Red Hat 8.0 for NTFS support and how exactly do you do it? Thanks for the help.
 
Old 10-06-2002, 11:27 PM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
See if it's loaded on a default install first:
Open up a terminal;
su -
enter root password
modprobe ntfs
lsmod (LSMOD lowercase)
and make sure ntfs is listed.

If so, now try mounting the partition in question:
mount -t ntfs /dev/hdxx /mnt/winbloze
Where XX represents the letter/number of your NTFS drive. If you don't know what that is, type:
fdisk -l (FDISK -L lowercase)
and look for hpfs/ntfs and that's your drive.

Cool
 
Old 10-08-2002, 12:05 PM   #3
zentsang
LQ Newbie
 
Registered: Oct 2002
Posts: 4

Rep: Reputation: 0
if NTFS isn't listed though...what's the fix?

if NTFS isn't listed though...what's the fix?
 
Old 10-08-2002, 08:14 PM   #4
nerfherder64
LQ Newbie
 
Registered: Oct 2002
Location: Fort Wayne, Indiana USA
Distribution: Redhat 8.0
Posts: 9

Rep: Reputation: 0
Check this out:

http://www.getlinuxonline.com/omp/di.../ompntfs2.html

You'll have to recompile the kernel, but it's not as scary as it sounds. The instructions are exactly the same for Redhat 8.0 except that you'll probably be using kernel version 2.4.18-14. I've enabled NTFS support on Redhat 8.0 myself, so it's not too tough--just time-consuming.
 
Old 10-23-2002, 12:39 AM   #5
Mikest
LQ Newbie
 
Registered: Oct 2002
Posts: 15

Rep: Reputation: 0
I'm trying to do the samething...NTFS isn't list and the above link in invalid?

# modprobe: Can't locate module ntfs

I've heard a lot bad things about accessing an NTFS partition for HD 8.0 I'm I looking for trouble.
 
Old 10-23-2002, 10:31 AM   #6
Linuxidiot
Member
 
Registered: Feb 2002
Location: Dallas, Tx
Distribution: RedHat 8.0
Posts: 70

Rep: Reputation: 15
What i did was go here http://linux-ntfs.sourceforge.net/ and follow their instructions i now have access to my hdb1 and hda1 didnt have to re-compile the kernel
 
Old 10-24-2002, 10:45 PM   #7
Mikest
LQ Newbie
 
Registered: Oct 2002
Posts: 15

Rep: Reputation: 0
javascript:smilie('') It worked!

I blindly followed the instructions like a good newbie and it worked.

Based on the intstructions for maping the drive...
mount /dev/hda1 /mnt/NTFS_C -t ntfs -r -o umask=0222

I played around with my my etc/fastab file and got it to auto-mount
/dev/hda1 /mnt/NTFS_C ntfs ro,umask=0222 0 0

For anyone out there that has a little more experence can you help me with what I'm doining in the fastab file?

-t seems to be the standard anytime you mount a drive, doesn't seem to be necessary in the fastab file

-r I'm assuming read-only which I guess translates to “ro” in the fastab file?

Umask=0222...I have no idea?

0 0 again no idea...I did notice that my “Label /” maping had a 1 1

Any knowledge on the subject would be great.
 
Old 11-29-2002, 02:50 AM   #8
mporras1
LQ Newbie
 
Registered: Nov 2002
Location: OR USA || HE Costa Rica
Distribution: 8.0
Posts: 1

Rep: Reputation: 0
the -t option is the device type specification switch; followed by ntfs means a ntfs device. Other values for -t can be found by reading it's man page. The fastab table has the same info; but instead of a switched command is a formated file.

umask is the default permissions specification command; you can use umask as stand alone tool to set which permision will be granted every time you create a new file. Man page again for details. I think 222 will give r r r permisions (not sure)

the 0 0 at the end of the fastab table is unknown to me.

Last edited by mporras1; 11-29-2002 at 02:55 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Copy files from NTFS to NTFS ThaHackBoy Linux - Hardware 2 05-21-2005 07:36 PM
Writing to an NTFS volume using captive-ntfs (repairing boot.ini) macskeeball Linux - General 3 02-06-2005 10:28 PM
NTFS (winxp) drive is accessible only by root, why NTFS (winxp) drive not accessible Samppa72 Linux - Software 1 07-26-2004 04:13 PM
Ntfs whkoh Debian 2 06-25-2004 02:12 PM
Captive NTFS -- full r/w ntfs access for Linux spurious Linux - Software 6 01-09-2004 01:29 AM


All times are GMT -5. The time now is 01:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration