LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-08-2002, 11:57 AM   #1
marcoc
Member
 
Registered: Mar 2002
Location: Rome, Italy
Distribution: Mandrake 10.1 Community, Suse 9.2, Fedora Core 2
Posts: 35

Rep: Reputation: 15
Angry RH 7.3 does not start X !!


Hello!

I updated my home pc from RH 7.2 to 7.3. The update was completely succesfull, but after the first reboot (after the upgrade) I discovered that the system does NOT recognize my monitor anymore (strangely, since this monitor, an "olivetti", worked perfectly with RH 7.2, and I only made an upgrade and not a fresh installation).

Now I obtain a dark screen without possibility to login with X. What could I do? Can I start RH in text mode? How? Or should you suggest to make a fresh installation in order to bypass this problem...?

...Thanks in advance for any help !

Marco
 
Old 06-08-2002, 12:34 PM   #2
shoot2kill
Member
 
Registered: Jan 2002
Location: California
Distribution: Red Hat
Posts: 402

Rep: Reputation: 30
I think the GUI is not configure properly after the upgrade to 7.3, u can press ctrl-alt-backspace to kill the x-server, this will allow u to go to text prompt, and from there u can login and then do Xconfigurator to set things right.

to change from GUI login to text login, u may check your /etc/inittab file, try understanding the different run level, to change to text login, simply change the statement id:5:default(something like that, can't remember) to 3.

luck!
 
Old 06-08-2002, 05:06 PM   #3
Noerr
Member
 
Registered: May 2002
Location: Dalec, HU
Distribution: Redhat 7.3
Posts: 696

Rep: Reputation: 30
go for Xconfigurator again
 
Old 06-08-2002, 07:26 PM   #4
marcoc
Member
 
Registered: Mar 2002
Location: Rome, Italy
Distribution: Mandrake 10.1 Community, Suse 9.2, Fedora Core 2
Posts: 35

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by shoot2kill
I think the GUI is not configure properly after the upgrade to 7.3, u can press ctrl-alt-backspace to kill the x-server,
Thanks but... strangely, it seems this not work, the only sequence of keys the system recognize in this "state of black screen" is ctrl-alt-del to force a new reboot...

I wonder if I can tell GRUBE to perform a not grafical boot of linux, since it seems impossible to kill the X server... could I?

Thanks again,

Marco
 
Old 06-09-2002, 04:14 AM   #5
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
To boot into non-graphical mode, when you get the grub menu, select linux and then press the ' E ' key. You'll get a screen that will list the lines from the menu.lst file. Look for the ' kernel ' line and select it. Press the ' E ' key and add init=? to the end of the line. Next, press ENTER and then the ' B ' key. Replace the ? with the runlevel that you want. If you want single user mode, use the number 1 ( one ). You could also use the word single instead of init=1
 
Old 06-11-2002, 05:06 AM   #6
marcoc
Member
 
Registered: Mar 2002
Location: Rome, Italy
Distribution: Mandrake 10.1 Community, Suse 9.2, Fedora Core 2
Posts: 35

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by linuxcool
To boot into non-graphical mode, when you get the grub menu, select linux and then press the ' E ' key. You'll get a screen that will list the lines from the menu.lst file. Look for the ' kernel ' line and select it. Press the ' E ' key and add init=? to the end of the line. Next, press ENTER and then the ' B ' key. Replace the ? with the runlevel that you want. If you want single user mode, use the number 1 ( one ). You could also use the word single instead of init=1
Ok, it may appear strange, but... it seems this don't work in my situation!
Onestly, I am not sure of what the problem may be.

At any rate, I think that also a fresh installation would not bypass this problem: in fact, one of the first message displayed when I try to start a fresh installation is "Unable to probe monitor"... Maybe that my monitor configuration is recognised by RH 7.2 and not by RH 7.3 ? And why I can't manage to start in no graphical mode?


Anyway, thanks to all for your kind help!

Marco
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
when i try to start samba pdc's smb service nmbd failed to start . sandeepchau123 Linux - Newbie 2 10-20-2007 01:59 PM
disable cold start and warm start snmp traps chkisco Linux - Newbie 0 10-28-2005 02:58 AM
fc2-gnome : Applications dont start / very slow to start nox104 Linux - Software 0 08-18-2004 08:53 PM
Can I gett KPPP to start when I start a browser on a network machine? duffboygrim Linux - Networking 0 03-25-2004 04:49 PM
cannot start kdeas user ,can start icewm,fluxbox jackren Debian 1 02-29-2004 11:06 PM


All times are GMT -5. The time now is 08:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration