LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-02-2015, 11:11 AM   #1
PoleStar
Member
 
Registered: Jul 2010
Posts: 165

Rep: Reputation: 2
RH 5 cluster fence problem on Vitual box


I created 3 test machine and made them into cluster.
On Virtual
"Virtual Machine Manager 0.9.0"
Machines them selves are CentOS 5.11.

Code:
<cluster name="mycluster" config_version="3">
   <clusternodes>
     <clusternode name="one" nodeid="1">
         <fence>
         </fence>
     </clusternode>
     <clusternode name="two" nodeid="2">
         <fence>
         </fence>
     </clusternode>
     <clusternode name="three" nodeid="3">
         <fence>
         </fence>
     </clusternode>
   </clusternodes>
   <fencedevices>
   </fencedevices>
   <rm>
   </rm>
</cluster>
When I start cman service. I see get this:

Code:
[root@one ~]# time service cman restart
Stopping cluster: 
   Stopping fencing... done
   Stopping cman... done
   Stopping ccsd... done
   Unmounting configfs... done
                                                           [  OK  ]
Starting cluster: 
   Loading modules... done
   Mounting configfs... done
   Starting ccsd... done
   Starting cman... done
   Starting daemons... done
   Starting fencing... failed

                                                           [FAILED]

real	5m7.353s
user	0m0.063s
sys	0m0.095s
[root@one ~]#
clustat:

Code:
[root@one ~]# clustat 
Cluster Status for mycluster @ Tue Jun  2 11:10:28 2015
Member Status: Inquorate

 Member Name                                            ID   Status
 ------ ----                                            ---- ------
 one                                                        1 Online, Local
 two                                                        2 Offline
 three                                                      3 Offline

[root@one ~]#
Thank you.

Last edited by PoleStar; 06-02-2015 at 11:20 AM.
 
Old 06-02-2015, 02:43 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
well if you ARE using RH5
the redhat os that came out in 1997
you WILL have a problem

RH5 ( Hurricane) is from 1997 ( 1 December 1997)
it is 18 years OLD
and has been unsupported for over a decade
 
Old 06-02-2015, 05:34 PM   #3
PoleStar
Member
 
Registered: Jul 2010
Posts: 165

Original Poster
Rep: Reputation: 2
I have to test thing in RH 5 environment. No choice there.
I remember I create similar cluster last year and did testing, But I don't have that confg
saved. I wonder if dummy ACP fence would work.
 
Old 06-04-2015, 10:19 AM   #4
PoleStar
Member
 
Registered: Jul 2010
Posts: 165

Original Poster
Rep: Reputation: 2
This issue is resolved. I used luci web interface to create cluster. It worked.
Resulting cluster.conf file looks like this.
Code:
<?xml version="1.0"?>
<cluster alias="TEA" config_version="1" name="TEA">
	<fence_daemon post_fail_delay="0" post_join_delay="3"/>
	<clusternodes>
		<clusternode name="three" nodeid="1" votes="1"/>
		<clusternode name="two" nodeid="2" votes="1"/>
		<clusternode name="one" nodeid="3" votes="1"/>
	</clusternodes>
	<cman/>
	<fencedevices/>
	<rm/>
</cluster>
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Red Hat Cluster and fence problem gontolal Red Hat 2 02-02-2010 03:51 PM
cluster without fence Ammad Linux - General 1 12-14-2009 06:41 PM
Redhat CLuster fence failed - problem aaron28 Linux - Server 7 03-23-2009 10:45 AM
RH Cluster Fence Password Script quackerjack_98 Red Hat 0 08-15-2007 01:38 PM


All times are GMT -5. The time now is 04:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration