LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   reverse proxy? (http://www.linuxquestions.org/questions/linux-newbie-8/reverse-proxy-385633/)

bwall 11-22-2005 06:13 PM

reverse proxy?
 
Let me start this with the reason why this idea started.

I have an apache server setup on one of my machines hosting multiple sites that are all accessible from the www. Everything is setup and running and been working fine with help from this site and the users and members here. THANKS A BUNCH! This site made it possible for me to pull this off.

I then decided to put and asp.net user and messageboard site up on the apache server that is accessed from inside my site by use of a username and pass (from me) that gets you to the main page of the messageboard site (where you can then register for the messageboard).

To do this I installed the aspdotnet_2.0.0 software http://weblogs.asp.net/israelio/arch...11/424852.aspxfrom apache to run the asp.net sites. I set this up like stated in the blog. This worked and everything was cool for a while. Then the site started to crash randomly throwing the System.Data.OleDb.oleDbException: Unspecified error.

After some research I came upon this solution
I used this article for help, it states the problem and a resolution
http://support.microsoft.com/default...b;en-us;825738

I'm having problems locating my Temp file to change the permissions, because its apache on windows setup.

Basically to sum up the article at microsoft, My permissions are incorrect on the temp file that the DB connects to. They may not be set to read/write.

Here is my web.config file:
[Code]
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<system.web>
<identity impersonate="true" />
<customErrors mode="Off" />
<compilation debug="true" />
<authentication mode="Windows" />
</system.web>
</configuration>
[Code]


The site will work for a while then crash whenever it feels like it. I then do a apache restart and it works again for a while until next random crash.

Back to the topic of this post:
I was trying to think of an idea to run the asp sites on my IIS that is on the same machine as the apache server at the same time. My apache is set up and I understand it better than IIS. I also have to enable a php site this week and I just like apache better.

But I need to try to keep the asp.net site up and not crashing so others can view it. All the code in the site pages is correct and good working, but the permissions are crashing it or the fact that is is on apache server is a problem.

Any suggestions on this:
1.)help finding the Temp folder to check the permissions
2.)a way to access Apache and IIS from the same machine at the same time having both servers live and taking incoming hits together (so I could put asp sites on IIS and leave rest on Apache)
3.)Suggestions from the great minds that take part in this site, because I'm lost

I came up with this from some help
I went in and uncommented some of the proxy server directives and put the code here how it looks in my http.config. Not sure if I opend the right code, to much of it or if I need more. ??


Code:

# Proxy Server directives. Uncomment the following lines to
# enable the proxy server:
#
#<IfModule mod_proxy.c>
#ProxyRequests On
#
#<Proxy *>
#    Order deny,allow
#    Deny from all
#    Allow from .your-domain.com
#    Allow from .robertwallaceii.com
#</Proxy>

ProxyPass /Inetpub/wwwroot/ http://localhost:8888/
ProxyPassReverse /Inetpub/wwwroot/ http://localhost:8888/

#
# Enable/disable the handling of HTTP/1.1 "Via:" headers.
# ("Full" adds the server version; "Block" removes all outgoing Via: headers)
# Set to one of: Off | On | Full | Block
#
#ProxyVia On

#
# To enable the cache as well, edit and uncomment the following lines:
# (no cacheing without CacheRoot)
#
#CacheRoot "c:/apachefriends/xampp/apache/proxy"
#CacheSize 5
#CacheGcInterval 4
#CacheMaxExpire 24
#CacheLastModifiedFactor 0.1
#CacheDefaultExpire 1
#NoCache a-domain.com another-domain.edu joes.garage-sale.com

#</IfModule>
# End of proxy directives.


I didn't see in mod_rewrite areas to uncomment.

These are the Modules that I have loaded that seemed to pertain to proxy and mod_rewrite.


Code:

#Example
# LoadModule foo_module modules/mod_foo.so
#
LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_connect_module modules/mod_proxy_connect.so
LoadModule proxy_http_module modules/mod_proxy_http.so
LoadModule proxy_ftp_module modules/mod_proxy_ftp.so

LoadModule rewrite_module modules/mod_rewrite.so


Here is my virtual host area. I copied the code that you posted and then added my info in the blah spaces. Below (the 2nd V.H. listing) is and idea that I was trying to use earlier today, but it didn't seem to work.
Code:

#:8888 ASP.NET SITES FROM IIS Windows#
<VirtualHost *:80>
  ServerAdmin webmaster@blah.com
        ServerName www.blah.com
        ServerAlias www.blah.com *.blah.com
        LogLevel warn

        <IfModule mod_rewrite.c>
                RewriteEngine On
                RewriteRule ^/(.*) \
                http://localhost:8888/$1 [L,P]
        </IfModule>
</VirtualHost>

Getting the error here:
http://localhost:8888/$1 [L,P]

Thanks for taking the time to read this long one.

bosewicht 11-22-2005 07:42 PM

Wouldn't you would have better luck posting on a windows or apache forum.


All times are GMT -5. The time now is 11:31 PM.