LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-08-2007, 11:10 AM   #1
d0pe
LQ Newbie
 
Registered: Feb 2007
Location: Ontario, Canada
Distribution: Fedora Core 4
Posts: 3

Rep: Reputation: 0
Unhappy Reverse DNS issue


I'm having trouble with setting up reverse DNS. I have added the following lines to /etc/named.conf

zone "196.144.18.64.in-addr.arpa" {
type master;
file "pz/db.196.144.18.64.in-addr.arpa";
};

and in the file I created /var/named/db.196.144.18.64.in-addr.arpa :

$ORIGIN 196.144.18.64.in-addr.arpa.
@ IN SOA d0pe.net. root.d0pe.net. (
2007010001 ; serial, todays date + todays serial #
8H ; refresh, seconds
2H ; retry, seconds
4W ; expire, seconds
1D ) ; minimum, seconds
NS YOUR.NAME.SERVER1.
NS YOUR.NAME.SERVER2.

196 IN PTR d0pe.net.


Now when I try and start named, I get the following error:

Starting named:
Error in named configuration:
zone localdomain/IN: loaded serial 42
zone localhost/IN: loaded serial 42
zone 0.0.127.in-addr.arpa/IN: loaded serial 1997022700
zone 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN: loaded serial 1997022700
zone 255.in-addr.arpa/IN: loaded serial 42
zone 0.in-addr.arpa/IN: loaded serial 42
zone 196.144.18.64.in-addr.arpa/IN: loading master file db.196.144.18.64.in-addr.arpa: file not found
_default/196.144.18.64.in-addr.arpa/IN: file not found
[FAILED]

Any help would be greatly appreciated. The server is running Fedora Core 4. I am very new to linux and am using this VPS to learn about it.
 
Old 02-08-2007, 12:26 PM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,732

Rep: Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584
Quote:
zone 196.144.18.64.in-addr.arpa/IN: loading master file db.196.144.18.64.in-addr.arpa: file not found
As you see from the above, bind cannot find the zone file.
Note that the localion of this file is: /some/directory/pz/db.196.144.18.64.in-addr.arpa, where "/some/directory" is the path defined by the
Code:
"directory "/some/directory";
line in your named.conf.
Check that the whole path to that file is correct and that is readable by the user running named:
Code:
ls -l /path/to/zonefiles/pz/db.196.144.18.64.in-addr.arpa
 
Old 02-08-2007, 12:52 PM   #3
d0pe
LQ Newbie
 
Registered: Feb 2007
Location: Ontario, Canada
Distribution: Fedora Core 4
Posts: 3

Original Poster
Rep: Reputation: 0
ok I have changed /etc/named.conf to read:
Quote:
zone "196.144.18.64.in-addr.arpa" {
type master;
file "db.196.144.18.64.in-addr.arpa";
};
(removed the dir /pz to see if it would make a difference)

also in named.conf the directory setting is:
Quote:
directory "/var/named";
and to show that the file is actually there:
Quote:
[root@smoke named]# ls -l /var/named/db.196.144.18.64.in-addr.arpa
-rw-r--r-- 1 root root 283 Feb 8 10:58 /var/named/db.196.144.18.64.in-addr.arpa
but I still get this error when starting named:
Quote:
zone 196.144.18.64.in-addr.arpa/IN: loading master file db.196.144.18.64.in-addr.arpa: file not found
_default/196.144.18.64.in-addr.arpa/IN: file not found
[FAILED]
by the way, I am running named under root. Is this a bad idea?
thanks for your help, it is very appreciated!
 
Old 02-08-2007, 01:20 PM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,732

Rep: Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584
Since your other zone files are loading correctly you must make sure that the file db.196.144.18.64.in-addr.arpa is in the same directory and has the same permissions.
You can also check your config for errors, running:
Code:
named-checkconf -z
named-checkzone 196.144.18.64.in-addr.arpa /var/named/db.196.144.18.64.in-addr.arpa
Quote:
by the way, I am running named under root. Is this a bad idea?
If you mean that you are running named as user root, then it is a bad idea. You should create a user named to run named, or use the nobody user. You can also run named chrooted as described in this howto.
 
Old 02-08-2007, 03:25 PM   #5
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
By the way, there is one major problem with what you are trying to do, and that is you are not who gets asked for the PTR for those IP addresses. Look ->
Code:
jim@jimsworktop:~/installs$ dig -x 64.18.144.196

; <<>> DiG 9.3.4 <<>> -x 64.18.144.196
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 12229
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;196.144.18.64.in-addr.arpa.    IN      PTR

;; AUTHORITY SECTION:
144.18.64.in-addr.arpa. 1800    IN      SOA     ns1.justedge.net. noc.justedge.net. 2002042467 28800 14400 3600000 86400

;; Query time: 102 msec
;; SERVER: 207.69.188.186#53(207.69.188.186)
;; WHEN: Thu Feb  8 16:13:15 2007
;; MSG SIZE  rcvd: 100


jim@jimsworktop:~/installs$ whois 64.18.144.196

OrgName:    JustEdge Networks Inc.
OrgID:      JUSTE
Address:    71 Ackerman Ave #161
City:       Clifton
StateProv:  NJ
PostalCode: 07011
Country:    US

ReferralServer: rwhois://rwhois.justedge.net:4321

NetRange:   64.18.128.0 - 64.18.159.255
CIDR:       64.18.128.0/19
NetName:    JE-BLK-2
NetHandle:  NET-64-18-128-0-1
Parent:     NET-64-0-0-0-0
NetType:    Direct Allocation
NameServer: NS1.JUSTEDGE.NET
NameServer: NS2.JUSTEDGE.NET
Comment:
RegDate:    2004-08-24
Updated:    2005-04-05

RNOCHandle: JUSTE-ARIN
RNOCName:   JustEdge
RNOCPhone:  +1-866-458-7833
RNOCEmail:  info@justedge.net

OrgTechHandle: JUSTE-ARIN
OrgTechName:   JustEdge
OrgTechPhone:  +1-866-458-7833
OrgTechEmail:  info@justedge.net

# ARIN WHOIS database, last updated 2007-02-07 19:10
# Enter ? for additional hints on searching ARIN's WHOIS database.


Found a referral to rwhois.justedge.net:4321.

Timeout.
The particularly important part of that output is this -
Code:
;; AUTHORITY SECTION:
144.18.64.in-addr.arpa. 86400   IN      SOA     ns1.justedge.net. noc.justedge.net. 2002042467 28800 14400 3600000 86400
That tells us that ns1.justedge.net is the server to be asked for any PTR in the 64.18.144.0 -> 64.18.144.255 range. Your address falls in that range, so nobody is asking your machine for the PTR you are trying to create. You need to get justedge to create you a PTR, or try and get them to delegate that to you. Most ISPs will delegate down, but only if you have an entire class C, which would be every address from 64.18.144.0 -> 64.18.144.255.

It doesn't hurt to clear up your problem, but it is pointless. I'd just rip the in.address.arpa zones out of your named.conf.

Peace,
JimBass
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No reverse DNS??? DragonM15 Linux - Networking 5 11-22-2005 12:06 AM
reverse DNS in C? Thinking Programming 3 04-27-2005 12:05 PM
Reverse DNS davespink Linux - Networking 2 02-27-2005 06:44 PM
Reverse DNS issue... WeNdeL Linux - Software 4 09-16-2004 02:35 PM
eMail Blocked due to Reverse DNS Issue VorlonInfoTech Linux - Networking 4 06-23-2004 04:23 PM


All times are GMT -5. The time now is 12:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration