LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 04-15-2004, 06:25 PM   #1
unwrittenLaww
LQ Newbie
 
Registered: Apr 2004
Location: San Diego, CA
Distribution: RHEL 3.0
Posts: 8

Rep: Reputation: 0
Restarting X Server


How do I restart the X server in RHEL 3.0?

Thanks
 
Old 04-15-2004, 06:30 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
A ctrl-alt-backspace usually does the trick.
 
Old 04-15-2004, 06:33 PM   #3
unwrittenLaww
LQ Newbie
 
Registered: Apr 2004
Location: San Diego, CA
Distribution: RHEL 3.0
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks. I still can't get the right resolution though. If I change the display settings via the gui, it asks to restart the X server and log out. Which Ctrl+Alt Backspace does, but the screen resolution stays the same...
 
Old 04-15-2004, 06:52 PM   #4
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Try changing the default resolutions logged out of X from your XF86Config file and then startx to test it.
 
Old 04-15-2004, 07:02 PM   #5
unwrittenLaww
LQ Newbie
 
Registered: Apr 2004
Location: San Diego, CA
Distribution: RHEL 3.0
Posts: 8

Original Poster
Rep: Reputation: 0
Ok, I edited XF86Config and added 1280x1024 to the line for resolutions. I know the video card and monitor can handle this resolution. But when I save the changes to the file and logout, log back in...its still at 800x600..
 
Old 04-15-2004, 08:46 PM   #6
chii-chan
Member
 
Registered: Sep 2003
Location: chikyuu (E103N6)
Distribution: Redhat 8.0 (2.4.25-custom), Fedora Core 1 (2.4.30-custom)
Posts: 357

Rep: Reputation: 30
ctrl-alt-plus/minus. And can you give us the XF86Config?
 
Old 04-16-2004, 09:42 AM   #7
JrLz
Member
 
Registered: Mar 2004
Location: Jakarta
Posts: 164

Rep: Reputation: 30
you have to restart X , logout only doesn't help
 
Old 04-20-2004, 12:49 PM   #8
unwrittenLaww
LQ Newbie
 
Registered: Apr 2004
Location: San Diego, CA
Distribution: RHEL 3.0
Posts: 8

Original Poster
Rep: Reputation: 0
I thought I restarted the X server by doing ctrl+alt+backspace? How do I restart it from the command line? I tried to find it in X --info, but no luck...

I can't cut and paste XF86Config, because the problem is on a different computer. But it looks correct according to the examples I've seen, and I only added the "1280x1024" option to the "Modes" line. The rest of the file is untouched from a clean install.
 
Old 04-20-2004, 12:59 PM   #9
javierj
LQ Newbie
 
Registered: Mar 2004
Location: Guatemala
Distribution: suse 9,knoppix
Posts: 24

Rep: Reputation: 15
start in runlevel 2 and then configure the xf86config, and then do init 5 and see if it works,
 
Old 04-20-2004, 01:01 PM   #10
unwrittenLaww
LQ Newbie
 
Registered: Apr 2004
Location: San Diego, CA
Distribution: RHEL 3.0
Posts: 8

Original Poster
Rep: Reputation: 0
Ok, could you give me a quick description of how to do that? And what does 'runlevel' and 'init' actually do? Sorry for the newb questions..
 
Old 04-20-2004, 01:27 PM   #11
javierj
LQ Newbie
 
Registered: Mar 2004
Location: Guatemala
Distribution: suse 9,knoppix
Posts: 24

Rep: Reputation: 15
when lilo or grub starts, they give you options, runlevel 2, its only text mode, like command-prompt in windows, and init makes you change from a certain runlevel to another, if you start in runlevel 2, (probably when lilo start, it has a little textbox, just put a 2 ) it will start as i already said,
in text mode, change the xf86 and then do init 5 and it will change to runlevel 5 (graphic mode, ) if u want to know more, try a google search about run levels, i believe there are 6 or something like that
 
Old 04-20-2004, 02:34 PM   #12
unwrittenLaww
LQ Newbie
 
Registered: Apr 2004
Location: San Diego, CA
Distribution: RHEL 3.0
Posts: 8

Original Poster
Rep: Reputation: 0
ok, i'll try that..thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
change from Clone to LeftOf mode without restarting X server malo_umoran Slackware 1 11-24-2005 07:34 PM
restarting x server igracgq Red Hat 4 12-14-2004 10:44 PM
Does sending processes the 9 signal, or restarting the X server cause damage? Squall Linux - General 1 06-07-2004 11:14 AM
Restarting the X Server jworld900 Linux - General 12 01-28-2004 12:21 PM
restarting x server? pyschomike15 Linux - General 4 11-02-2003 08:13 AM


All times are GMT -5. The time now is 10:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration