LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-17-2008, 08:26 AM   #1
sandeepthug
Member
 
Registered: Nov 2008
Posts: 38

Rep: Reputation: 15
Restarting dns service


Hi am not able to resolve hostnames in LAN
however on server it is working fine

quick response would be appreciated

thanks
sandeep
 
Old 12-17-2008, 08:32 AM   #2
eco
Member
 
Registered: May 2006
Location: BE
Distribution: Debian/Gentoo
Posts: 412

Rep: Reputation: 48
Hi,

Have a look on both server and workstation what's in /etc/resolv.conf

This will list what DNS servers are being used. I suspect the server uses your providers DNs and your workstation uses the one running on your server... which does not seem to be running.

Best of luck.
 
Old 12-17-2008, 08:43 AM   #3
sandeepthug
Member
 
Registered: Nov 2008
Posts: 38

Original Poster
Rep: Reputation: 15
thanks for the quick reply

im using windows machines on lan
and the contents of /etc/resolv.conf are

search viewhosting.com
nameserver 127.0.0.1
nameserver 208.67.222.222
nameserver 192.168.3.1
 
Old 12-17-2008, 09:00 AM   #4
eco
Member
 
Registered: May 2006
Location: BE
Distribution: Debian/Gentoo
Posts: 412

Rep: Reputation: 48
OK,

Try this.

On Your Linux server, type:

host www.google.com 127.0.0.1
host www.google.com 208.67.222.222
host www.google.com 192.168.3.1

See which replies?

On windows do the same in a 'shell' (CMD)

nslookup www.google.com <Linux server IP>
nslookup www.google.com 208.67.222.222
nslookup www.google.com 192.168.3.1

Report back your findings
 
Old 12-17-2008, 09:16 AM   #5
sandeepthug
Member
 
Registered: Nov 2008
Posts: 38

Original Poster
Rep: Reputation: 15
on linux mahine

host www.google.com 127.0.0.1
;; connection timed out; no servers could be reached

host www.google.com 208.67.222.222
Using domain server:
Name: 208.67.222.222
Address: 208.67.222.222#53
Aliases:

www.google.com is an alias for google.navigation.opendns.com.
google.navigation.opendns.com has address 208.67.217.231
google.navigation.opendns.com has address 208.67.217.230

host www.google.com 192.168.3.1
;; connection timed out; no servers could be reached


on windows machine

nslookup www.google.com 127.0.0.1
*** Can't find server name for address 127.0.0.1: No response from ser
Server: UnKnown
Address: 127.0.0.1

*** UnKnown can't find www.google.com: No response from server


nslookup www.google.com 208.67.222.222
Server: resolver1.opendns.com
Address: 208.67.222.222

Non-authoritative answer:
Name: google.navigation.opendns.com
Addresses: 208.67.217.231, 208.67.217.230
Aliases: www.google.com


nslookup www.google.com 192.168.3.1
Server: router
Address: 192.168.3.1

DNS request timed out.
timeout was 2 seconds.
DNS request timed out.
timeout was 2 seconds.
*** Request to router timed-out
 
Old 12-17-2008, 09:24 AM   #6
eco
Member
 
Registered: May 2006
Location: BE
Distribution: Debian/Gentoo
Posts: 412

Rep: Reputation: 48
Hi,

So the only DNS that works for you is 208.67.222.222

On your Linux server, change your resolv.conf to:
search viewhosting.com
nameserver 208.67.222.222

On windows, edit your DNS settings to include the above IP.

You can check what you currently have by typing ipconfig /all

Let me know if this helps.
 
Old 12-17-2008, 09:25 AM   #7
hasanatizaz
Member
 
Registered: Nov 2007
Location: Pakistan
Distribution: Redhat and Debian
Posts: 302
Blog Entries: 1

Rep: Reputation: 34
go to /etc/nsswitch.conf

in
hosts "files dns"
change to "dns files"
 
Old 12-17-2008, 09:27 AM   #8
eco
Member
 
Registered: May 2006
Location: BE
Distribution: Debian/Gentoo
Posts: 412

Rep: Reputation: 48
Argh, so sorry. Can't read. Problem was with LAN not WAN.

All the same, you have DNS entries that didn't work so nothing's lost but still... sorry.
 
Old 12-17-2008, 09:36 AM   #9
sandeepthug
Member
 
Registered: Nov 2008
Posts: 38

Original Poster
Rep: Reputation: 15
thanks it worked

i just changed the dns on windows machines

thanks a lot once again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Restarting samba service dahoule Linux - Networking 13 12-11-2012 11:17 AM
squid service not restarting celebnavin Linux - Server 1 11-22-2007 07:45 AM
Remotely restarting a service seefor Linux - Networking 3 02-15-2007 12:52 AM
restarting network service in windows nick021 Linux - General 1 12-16-2006 04:20 AM
Restarting DNS Service in Slackware jademan83 Linux - Networking 1 05-27-2005 08:25 PM


All times are GMT -5. The time now is 02:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration