LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-06-2002, 04:31 PM   #1
soko
LQ Newbie
 
Registered: Jun 2002
Posts: 5

Rep: Reputation: 0
resolving host...


when i am playing with the net after awhile (or when i bump my pcmcia slot or the cord wiggles) it loses connection.. but it leaves the modem open
so i cant disconnect even when i kill kppp.. is there a way i can free up the modem without rebooting?
if so how?
 
Old 07-06-2002, 04:47 PM   #2
mrGee
Member
 
Registered: Dec 2001
Location: Netherlands
Distribution: redhat suse mandrake freebsd
Posts: 344

Rep: Reputation: 30
hi
don't know if this will work, but i use it from time to time to
check and free up my cdrom, because some prog or process
is claiming it and therefore i can't unmount it.
try
lsof /dev/modem (or any link/device you know for certain that
is connected to your modem device)

do a kill -9 idnumberofprocess
o and make sure you are root before trying this
good luck
 
Old 07-06-2002, 05:18 PM   #3
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,535

Rep: Reputation: 148Reputation: 148
AFAIK kppp uses pppd. So killing pppd may help.
 
Old 07-06-2002, 05:22 PM   #4
lynch
Member
 
Registered: Nov 2000
Location: A Mid-Atlantic state
Distribution: SuSE 8.1,Knoppix 3.2,Mandrake 9.1
Posts: 388

Rep: Reputation: 30
Go into your kppp setup and choose the option to automatically disconnect when you logout. Then ....logout.
lynch
 
Old 07-06-2002, 07:01 PM   #5
soko
LQ Newbie
 
Registered: Jun 2002
Posts: 5

Original Poster
Rep: Reputation: 0
ok
first when i type isof or lsof (or Isof) it dosent know the command


and to lynch-
in setup all i could find is disconnect on x-server shutdown
that is already marked
i put on auto reconnect
but the problem is
when you get the resolving host thing happening
you can tell it to disconnect
its just the modem is still being used after you are disconnected from the internet
so it dosent let you reconnect
just says "modem is busy"
 
Old 07-06-2002, 07:24 PM   #6
taz.devil
Senior Member
 
Registered: Nov 2001
Location: Wa. State
Distribution: Slackware
Posts: 1,261

Rep: Reputation: 45
Since it sounds like although you lose the connection (seemingly) to your ISP, the modem is not resetting itself unless you reboot obviously. I can't say why, but I do believe that you could try updating pppd or, along with the other suggestions do---> killall pppd
That usually kills any link between my modem and pppd.
 
Old 07-06-2002, 08:46 PM   #7
lynch
Member
 
Registered: Nov 2000
Location: A Mid-Atlantic state
Distribution: SuSE 8.1,Knoppix 3.2,Mandrake 9.1
Posts: 388

Rep: Reputation: 30
I was typing from memory,which is always a bad proposition.
Disconnecting on Xserver shutdown was what I was referring to.Funny but thats worked for me.
 
Old 07-06-2002, 11:20 PM   #8
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
If it's not too big of problem, and you have the option to restart on Xserver shutdown, why not do an Xserver shutdown? CTRL+ALT+F2 and login, then type init 3 That will kill your Xserver, then you can type either init 5 or startx, and start it over again. Better than restarting anyway. Or, like has been suggested a few times, kill pppd.
 
Old 07-07-2002, 05:03 AM   #9
mrGee
Member
 
Registered: Dec 2001
Location: Netherlands
Distribution: redhat suse mandrake freebsd
Posts: 344

Rep: Reputation: 30
as for lsof: use it as root
it does a list of open files that relates to the wanted device
man lsof
word list starts with L > lsof
good luck
 
Old 07-07-2002, 05:10 AM   #10
soko
LQ Newbie
 
Registered: Jun 2002
Posts: 5

Original Poster
Rep: Reputation: 0
lsof = nill

bash: lsof: command not found

no manual entry for lsof


im using mandrake 8.2

im logged in as root
still dosent know it
heh
 
Old 07-07-2002, 10:50 AM   #11
mrGee
Member
 
Registered: Dec 2001
Location: Netherlands
Distribution: redhat suse mandrake freebsd
Posts: 344

Rep: Reputation: 30
rpm -qa|grep -i lsof
should return the name of the package
like for inst lsof-4.60-1mdk
if not install it from one of your cd's
rpm -ivh lsof-4.60-1mdk or use rpmdrake to do this
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Resolving <www.some remote host>.... failed: Host not found. koodoo Linux - Newbie 2 06-27-2005 08:48 AM
more resolving host problems rmindell Mandriva 0 03-13-2005 01:24 PM
resolving host problem Veteq Linux - Newbie 4 06-03-2004 01:45 PM
resolving host problem scorpion777 Mandriva 0 05-17-2004 12:23 AM
Resolving IP for an external LAN host MadCactus Linux - Networking 1 07-05-2003 04:58 PM


All times are GMT -5. The time now is 05:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration