LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-18-2006, 10:51 PM   #1
Plantmiester
LQ Newbie
 
Registered: Aug 2005
Location: Western Canada
Distribution: Ubuntu 9.10
Posts: 12

Rep: Reputation: 0
Resolution with Syncmaster 940BW


I can't seem to get my Samsung SyncMaster 940BW to get proper resolutions (1440*900). My current max is 1024*768. I can't figure out how to adjust it from the already installed programs, and my searches haven't given me any hints either.

I'm running Ubuntu 6.06.

Thanks,
Sherwood
 
Old 09-19-2006, 12:28 AM   #2
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Which video card are you using?

Either the monitor is not recognized in which case conservative settings are specified for the horizontal sync and vertical refresh or the video card driver needs a bit of configuring.

For the first issue, you can check horizsync and vertrefresh in the config file against the specs of your monitor. I could only find 81 kHz as the max horizsync and 75 Hz as the max vertrefresh.

Please post the sections device, monitor and screen of your X configuration file (usually located in /etc/X11 or similar) if you need more help.
 
Old 09-19-2006, 06:32 PM   #3
Plantmiester
LQ Newbie
 
Registered: Aug 2005
Location: Western Canada
Distribution: Ubuntu 9.10
Posts: 12

Original Poster
Rep: Reputation: 0
Hmm, I couldn't make much of that out (first week of linux use), so I might need a bit of help decoding that.

Sorry about missing the graphics card bit, just slipped my mind.

I run an MSI GeForce 4Ti 4200 8x

I thought I'd take a shot at reinstalling the drivers and see how that went, problem is I'm still not familiar with alot of terminal commands, and execution, and apparently I need to do the following:
Quote:
Prior to beginning the installation, you should exit the X server and kill all OpenGL applications (note that it is possible that some OpenGL applications persist even after the X server has stopped). You should also set the default run level on your system such that it will boot to a VGA console, and not directly to X.
Problem is
a) I don't know HOW to do those things
b) I'm not sure I feel safe enough doing those things even if I had the command line knowledge.

So I could use a hand puzzling through, and isolate and limit risks.

Thanks again,
Sherwood
 
Old 09-20-2006, 01:14 AM   #4
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Please post the sections as asked for in my previous post and we will help you decode it and advise on the changes. From there we will take it further. It might not be necessary to (re-)install drivers.

If you insist on 'shuttting down the X server', the following can do it. Some notes first.
You're going to modify the file 'inittab' and you need root permissions for that. In ubuntu this is achieved by prceedinbg a command with the word 'sudo'.
Further I'm only familiar with vi, so I have to push that down your throat. You might want to use nano or pico that might be less powerfull but more user friendly. All stuff is case sensitive (quite common in the unix world), so make sure that <capslock> is off. Further I use the notation like <ctrl>. These are special keys (in this case the control key).
  1. press <ctrl><alt><F1>; this will take you to a terminal (out of the GUI); you might have to replace <F1> by <F2> or <F3> (up to <F6>) but one of them will work
  2. login with your username and password
  3. make a backup of the file that you're going to change by typing cp /etc/inittab inittab.bck and press <enter>; this will make a backup in your current directory
  4. type sudo vi /etc/inittab, enter your password and you will see the content of a text file
  5. press '/' without the quotation marks; you're taken to the bottom of the screen where you can enter a word to search for
  6. type initdefault and press <enter>; this will take you to a line like
    id:3:initdefault:
  7. type yy followed by p; the characters will not be echoed; 'yy' will copy the line to a buffer and 'p' will paste it after the current line so you will now have two identical lines
  8. goto the begining of one of the lines, press i (small letter 'i'); the 'i' will not be echoed but will allow you to insert text
  9. type a '#' (again without the quotation marks) and press <ESC>
  10. goto the other line and use the cursor keys to place the cursor on the 3
  11. press r (small letter 'r'); again, the 'r' will not be echoed but allows you to change one character
  12. type a 2; the 3 will change to a 2
  13. press : (colon); you're again taken to the bottom of the screen where you can enter commands
  14. type wq and press <enter> to save the file and quit vi

before doing the last step above, verify that your lines now look like
Code:
#id:3:initdefault:
id:2:initdefault:
Now you can reboot your machine and your GUI will be gone as the X server is no longer running.

Do the rest of your business and restore the original inittab afterwards.
  1. follow the instructions above to start editing inittab (up to step 6)
  2. position the cursor on the '#' that you added earlier
  3. press x (small character 'x'); this will remove the '#'
  4. goto the beginning of the other line and press P (capital character 'P'); this will paste the '#' before the cursor
  5. press : (colon); you're again taken to the bottom of the screen where you can enter commands
  6. type wq and press <enter> to save the file and quit vi

before doing the last step above, verify that your lines now look like
Code:
id:3:initdefault:
#id:2:initdefault:
Reboot your machine and you will have your GUI again.


Some notes on vi:
vi can run in two modes, a command mode and an edit mode. When you start it, it will be in command mode. You can always get back to command mode by pressing <ESC>. To go to edit mode, you can press e.g. 'i' for insert, 'o' to start a new line after the current one, 'O' to start a new line before the current one and 'R' to replace a number of characters.
As said, <ESC> will take you back to command mode.

The official keys to navigate though a file (in command mode) are 'h','j','k' and 'l' but most of the times the cursor keys will also work.

When in command mode, you can press ':' (colon). You're taken to the bottom of the screen where you can enter other commands (like 'wq').
'w' will write, 'q' will quit, 'q!' (q followed by exclamation mark) will quit without saving the changes since the last write.

Last edited by Wim Sturkenboom; 09-20-2006 at 01:15 AM.
 
Old 09-20-2006, 09:01 PM   #5
Plantmiester
LQ Newbie
 
Registered: Aug 2005
Location: Western Canada
Distribution: Ubuntu 9.10
Posts: 12

Original Poster
Rep: Reputation: 0
Alright, as I stated before, I wasn't clear on what you were telling me to do in the initial X config situation.

I've investigated that, and found a negative on the config file. According to my sources (read: I used google) it should be "/etc/X11/XF86Config" but that file doesn't exist, only the directory "/etc/X11/"

If you could give me a hand figuring out where that config file would be, I'd be glad to tell you the contents of the Devince, Monitor and Screen sections of it.

I'll try and hold off on the driver install until after I try and get this running.
 
Old 09-21-2006, 01:32 AM   #6
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
There are two 'systems'. Older ubuntu versions use XF86Config-4.
If there is not something called XF86....conf, check for a file called xorg.conf .
In both case, the files should be in /etc/X11; so analyse the contents of that directory.
 
Old 09-21-2006, 09:07 AM   #7
Plantmiester
LQ Newbie
 
Registered: Aug 2005
Location: Western Canada
Distribution: Ubuntu 9.10
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Section "Device"
Identifier "NVIDIA Corporation NV28 [GeForce4 Ti 4200 AGP 8x]"
Driver "nv"
BusID "PCI:1:0:0"
Quote:
Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-51
VertRefresh 43-60
Quote:
Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV28 [GeForce4 Ti 4200 AGP 8x]"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection

There are all three Device, Monitor, and Screen respectively. It was the xorg file, thank you for letting me know that.
 
Old 09-21-2006, 10:56 PM   #8
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
As far as I can see, there are a few things that need to change.
If HorizSync is not correct (too low), the system will not be able to use the max resolutions.
Code:
HorizSync 28-81
VertRefresh 60,75
Check the monitor manual for the exact settings (as stated in a previous post). The change for VertRefresh is not strictly necessary (1440x900 should work with the settings that are there now for it). It tells the system to only use 60 or 75 and nothing in between.

Your system uses a default depth of 24, so add the required resolutions in that subsection.
Code:
SubSection "Display"
Depth 24
Modes "1440x900" "1024x768" "800x600" "640x480"
EndSubSection
You need root permissions to change the xorg file. Make a backup before you start modifying. After the modification, the X server needs to be restarted. You can restart the X server by pressing <ctrl><alt><backspace> while in the GUI.

The used nv driver (see section device) is a generic driver for nvidia cards. It is possible that the generic driver does not support 1440x900 and that the above advised changes will not have an effect because of that.

If you're happy with the options of this driver, you don't have to change it. Although I'm not familiar with your card, I think that the 'official' nVidia drivers support your card as well (if not, they will tell you when you install the drivers).

Installing the drivers might be tricky on Ubuntu as certain files are needed and I'm not sure if they are supplied with Ubuntu. You might have to get them seperately (can't help you with that).

I further suggest that you check out the ubuntu forum for posts regarding nvidia. You might find some usefull advise there as well.

Good luck

Last edited by Wim Sturkenboom; 09-21-2006 at 11:01 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samsung SyncMaster 930B Cosmic Linux - Hardware 1 04-30-2006 04:01 AM
Samsung SyncMaster 914V nutbrownhares Linux - Hardware 2 03-19-2006 08:11 AM
LCD SyncMaster refresh ? coxis Linux - Hardware 0 01-07-2005 05:45 PM
Samsung SyncMaster 3 pcflight Linux - Hardware 1 08-27-2004 07:46 PM
Samsung SyncMaster LCD's pallbearer Linux - Hardware 12 04-09-2004 08:42 PM


All times are GMT -5. The time now is 03:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration