LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-13-2013, 05:41 PM   #1
sbolokanov
Member
 
Registered: Feb 2013
Location: абвг
Distribution: Slackware
Posts: 82

Rep: Reputation: 18
Resolution problem - no valid modes and invalid EDID


Solved:
The problem was in EDID checksum.
Fixed it be adding this line to xorg.conf - Option "IgnoreEDIDChecksum" "CRT"
Thanks for your support John VV and allend



Hello guys, I found myself unable to resolve this resolution problem.

I should get up to 1440x900 resolution at 60Hz on my display KTC W9006S, but for some reason currently max resolution is 640x480.
The GPU is Nvidia GT430 with proprietary drivers v310.32. Installed from nvidia's binary.

Distro is Slackware 14 x86_64 + added multilib.

After search over the web I tried to setup xorg.conf myself, but for some reason I can't get it working.
Check my xorg.conf below and the log file from xorg.

edit: Had to shrink the log file because of post limit, but i kept most noticable warnings. A few invalid mode warnings and invalid EDID.
Also forgot to mention that im getting only 640x480 and 320x240 as option for resolution in Nvidia X server

xorg.conf

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 310.32  (buildmeister@swio-display-x86-rhel47-01)  Mon Jan 14 15:51:51 PST 2013

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/lib64/X11/fonts/misc/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/misc/"
    FontPath        "/usr/lib64/X11/fonts/Type1/"
    FontPath        "/usr/lib64/X11/fonts/Speedo/"
    FontPath        "/usr/lib64/X11/fonts/100dpi/"
    FontPath        "/usr/lib64/X11/fonts/75dpi/"
    FontPath        "/usr/lib64/X11/fonts/cyrillic/"
    FontPath        "/usr/lib64/X11/fonts/TTF/"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       16
        Modes      "1400x900" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1400x900" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       32
        Modes      "1400x900" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection
Xorg.0.log

Code:
[    53.032] 
X.Org X Server 1.12.3
Release Date: 2012-07-09
[    53.032] X Protocol Version 11, Revision 0
[    53.032] Build Operating System: Slackware 14.0 Slackware Linux Project
[    53.033] Current Operating System: Linux overlord 3.2.29 #2 SMP Mon Sep 17 14:19:22 CDT 2012 x86_64
[    53.033] Kernel command line: BOOT_IMAGE=Slackware ro root=803 vt.default_utf8=0
[    53.033] Build Date: 23 August 2012  02:03:27PM
[    53.033]  
[    53.033] Current version of pixman: 0.26.2
[    53.034] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    53.034] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    53.035] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Feb 13 20:13:32 2013
[    53.035] (==) Using config file: "/etc/X11/xorg.conf"
[    53.035] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    53.036] (==) ServerLayout "Layout0"
[    53.036] (**) |-->Screen "Screen0" (0)
[    53.036] (**) |   |-->Monitor "Monitor0"
[    53.036] (**) |   |-->Device "Device0"
[    53.036] (**) |-->Input Device "Keyboard0"
[    53.036] (**) |-->Input Device "Mouse0"
[    53.036] (==) Automatically adding devices
[    53.036] (==) Automatically enabling devices
[    53.036] (WW) The directory "/usr/share/fonts/local" does not exist.
[    53.036] 	Entry deleted from font path.
[    53.036] (WW) The directory "/usr/share/fonts/CID" does not exist.
[    53.036] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    53.036] (WW) Disabling Keyboard0
[    53.036] (WW) Disabling Mouse0

[    53.338] (WW) NVIDIA(GPU-0): The EDID read for display device CRT-1 is invalid: the
[    53.338] (WW) NVIDIA(GPU-0):     checksum for EDID version 1 is invalid.
[    53.338] (--) NVIDIA(GPU-0): 
[    53.338] (--) NVIDIA(GPU-0): Raw EDID bytes:
[    53.338] (--) NVIDIA(GPU-0): 
[    53.338] (--) NVIDIA(GPU-0):   00 ff ff ff ff ff ff 00  08 83 92 19 01 00 00 00
[    53.338] (--) NVIDIA(GPU-0):   01 10 01 03 68 29 1a 78  ea f0 65 98 57 51 91 27
[    53.338] (--) NVIDIA(GPU-0):   21 50 54 ad cf 00 95 00  81 80 81 40 71 4f 01 01
[    53.338] (--) NVIDIA(GPU-0):   01 01 01 01 01 01 9a 29  a0 d0 51 84 22 30 50 98
[    53.338] (--) NVIDIA(GPU-0):   36 00 9a 00 11 00 00 1c  00 00 00 fd 00 38 4b 1f
[    53.338] (--) NVIDIA(GPU-0):   50 0e 00 0a 20 20 20 20  20 20 00 00 00 fc 00 43
[    53.338] (--) NVIDIA(GPU-0):   06 57 01 90 30 30 02 20  08 08 20 20 00 00 00 fe
[    53.338] (--) NVIDIA(GPU-0):   00 0a 20 20 20 20 20 20  20 20 20 20 20 20 00 08
[    53.338] (--) NVIDIA(GPU-0): 
[    53.338] (--) NVIDIA(GPU-0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
[    53.338] (--) NVIDIA(GPU-0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
[    53.338] (--) NVIDIA(GPU-0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
[    53.338] (--) NVIDIA(GPU-0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
[    53.338] (--) NVIDIA(GPU-0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
[    53.338] (--) NVIDIA(GPU-0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
[    53.338] (--) NVIDIA(GPU-0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
[    53.338] (--) NVIDIA(GPU-0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00

[    53.341] (WW) NVIDIA(0): No valid modes for "CRT-1:1400x900"; removing.
[    53.341] (WW) NVIDIA(0): No valid modes for "CRT-1:1280x1024"; removing.
[    53.341] (WW) NVIDIA(0): No valid modes for "CRT-1:1024x768"; removing.
[    53.341] (WW) NVIDIA(0): No valid modes for "CRT-1:800x600"; removing.
[    53.341] (II) NVIDIA(0): Validated MetaModes:
[    53.341] (II) NVIDIA(0):     "CRT-1:640x480"
[    53.342] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[    53.369] (WW) NVIDIA(0): Unable to get display device CRT-1's EDID; cannot compute DPI
[    53.369] (WW) NVIDIA(0):     from CRT-1's EDID.

[    53.606] (WW) evdev: A4TECH USB Device: ignoring absolute axes.

[    54.647] (WW) NVIDIA(GPU-0): The EDID read for display device CRT-1 is invalid: the
[    54.647] (WW) NVIDIA(GPU-0):     checksum for EDID version 1 is invalid.

[    55.197] (WW) NVIDIA(GPU-0): The EDID read for display device CRT-1 is invalid: the
[    55.197] (WW) NVIDIA(GPU-0):     checksum for EDID version 1 is invalid.

[    55.259] (WW) NVIDIA(GPU-0): The EDID read for display device CRT-1 is invalid: the
[    55.259] (WW) NVIDIA(GPU-0):     checksum for EDID version 1 is invalid.

[    55.259] (--) NVIDIA(GPU-0): 
[    55.259] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[    55.259] (**) NVIDIA(0):     device CRT-1 (Using EDID frequencies has been enabled on
[    55.259] (**) NVIDIA(0):     all display devices.)

Last edited by sbolokanov; 02-17-2013 at 09:20 AM. Reason: solved
 
Old 02-13-2013, 07:42 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,989

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
this is a bit "odd"
Code:
DefaultDepth    24
    SubSection     "Display"
        Depth       16
        Modes      "1400x900" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1400x900" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       32
        Modes      "1400x900" "1280x1024" "1024x768" "800x600" "640x480"


here is a copy of my working xorg.conf created by the TESTING NVIDIA-Linux-x86_64-313.18.run
--- the device & screen sections --
Code:
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTS 240"
EndSection

Section "Screen"

    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "1920x1080 +0+0" "1400x900 +0+0" "1280x1024 +0+0" "1024x768 +0+0" "800x600 +0+0" "640x480 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
add to the "metamodes" in REDthe sixes with the +0+0
 
Old 02-13-2013, 10:02 PM   #3
sbolokanov
Member
 
Registered: Feb 2013
Location: абвг
Distribution: Slackware
Posts: 82

Original Poster
Rep: Reputation: 18
Changed my Screen section to:
Code:
Section "Screen"

    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "metamodes" "1440x900 +0+0" "800x600 +0+0" "640x480 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
But i got fatal error.
Also tried to eliminate the resolutions 1 by 1 but I left with none in the end.

Code:
[    91.025] 
X.Org X Server 1.12.3
Release Date: 2012-07-09
[    91.026] X Protocol Version 11, Revision 0
[    91.026] Build Operating System: Slackware 14.0 Slackware Linux Project
[    91.026] Current Operating System: Linux overlord 3.2.29 #2 SMP Mon Sep 17 14:19:22 CDT 2012 x86_64
[    91.026] Kernel command line: BOOT_IMAGE=Slackware ro root=803 vt.default_utf8=0
[    91.027] Build Date: 23 August 2012  02:03:27PM
[    91.027]  
[    91.027] Current version of pixman: 0.26.2
[    91.027] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    91.027] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    91.029] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Feb 14 04:55:41 2013
[    91.076] (==) Using config file: "/etc/X11/xorg.conf"
[    91.076] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    91.111] Parse error on line 62 of section Screen in file /etc/X11/xorg.conf
	"800x600 +0+0" is not a valid keyword in this section.
[    91.111] (EE) Problem parsing the config file
[    91.111] (EE) Error parsing the config file
[    91.112] 
Fatal server error:
[    91.112] no screens found
[    91.113] 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    91.113] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    91.113] 
[    91.125] Server terminated with error (1). Closing log file.

Last edited by sbolokanov; 02-13-2013 at 10:19 PM.
 
Old 02-13-2013, 10:18 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,989

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
you installed the *.run
so you have two tools to config it
"nvidia-xconfig" will write a new file -- default settings
and
"nvidia-settings" a GUI

run "nvidia-settings" as root
set the settings you need
and save to the xorg.conf
 
Old 02-13-2013, 10:49 PM   #5
sbolokanov
Member
 
Registered: Feb 2013
Location: абвг
Distribution: Slackware
Posts: 82

Original Poster
Rep: Reputation: 18
Ok, i removed the old xorg.conf and created a new one with nvidia-xconfig.
Now what i'm missing about nvidia-settings.
All i have at this point is 640x480 and 320x240.
Can i create new resolution within nvidia-settings?

here is how looks my new xorg.conf

Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 310.32  (buildmeister@swio-display-x86-rhel47-01)  Mon Jan 14 15:51:37 PST 2013

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 310.32  (buildmeister@swio-display-x86-rhel47-01)  Mon Jan 14 15:51:51 PST 2013

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
    FontPath        "/usr/lib64/X11/fonts/misc/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/misc/"
    FontPath        "/usr/lib64/X11/fonts/Type1/"
    FontPath        "/usr/lib64/X11/fonts/Speedo/"
    FontPath        "/usr/lib64/X11/fonts/100dpi/"
    FontPath        "/usr/lib64/X11/fonts/75dpi/"
    FontPath        "/usr/lib64/X11/fonts/cyrillic/"
    FontPath        "/usr/lib64/X11/fonts/TTF/"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-1"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 430"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-1"
    Option         "metamodes" "640x480_60 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Last edited by sbolokanov; 02-13-2013 at 10:52 PM.
 
Old 02-13-2013, 11:21 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,989

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
a few screenshots

launch "nvidia-settings" as root
Code:
su -
---- root password when asked ---
nvidia-settings
3 shots in this photo callery
http://imgbox.com/g/d5eoGUU8qt

the gray highlight is the selection in mt BLACK theme
"x server Display Configuration "
first photo
http://imgbox.com/adrGzDaZ

and in that window is the sizes
the second photo
http://imgbox.com/adoEohgs

and save to xorg.conf
third photo
http://imgbox.com/aclJ66Z1


if you do not see the long selection in the second photo

edit your xorg.conf as fallows ( in red )
Code:
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-1"
    Option         "metamodes" "640x480_60 +0+0"
    SubSection     "Display"
        Depth       24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection
but most OS's no longer NEED a "xorg.conf"
they only use IF it is present
if not udev and hal auto set it up

nvidias own README documentation
in clickable html format (( yes it is on a ftp site)
ftp://download.nvidia.com/XFree86/Li...DME/index.html

everything is in there

configuring X
ftp://download.nvidia.com/XFree86/Li...igoptions.html

Last edited by John VV; 02-13-2013 at 11:30 PM.
 
1 members found this post helpful.
Old 02-13-2013, 11:42 PM   #7
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,463

Rep: Reputation: 1370Reputation: 1370Reputation: 1370Reputation: 1370Reputation: 1370Reputation: 1370Reputation: 1370Reputation: 1370Reputation: 1370Reputation: 1370
From the xorg.0.log
Quote:
[ 53.338] (WW) NVIDIA(GPU-0): The EDID read for display device CRT-1 is invalid: the
[ 53.338] (WW) NVIDIA(GPU-0): checksum for EDID version 1 is invalid.
Try adding the line in blue to your xorg.conf
Code:
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option "IgnoreEDID" "true"
EndSection
 
1 members found this post helpful.
Old 02-14-2013, 08:22 AM   #8
sbolokanov
Member
 
Registered: Feb 2013
Location: абвг
Distribution: Slackware
Posts: 82

Original Poster
Rep: Reputation: 18
@John VV
I did that in the very beginning, no success whatsoever.

Added modes to xorg.conf manualy.
Then tried with removing xorg.conf and recreating it with resolution append to --mode
example: nvidia-xconfig --mode 1440x900
which leads to mode getting removed and reversed to nvidia-auto

Code:
[   413.301] (WW) NVIDIA(0): No valid modes for "CRT-1:1440x900"; removing.
[   413.301] (WW) NVIDIA(0): 
[   413.301] (WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
[   413.301] (WW) NVIDIA(0):     "nvidia-auto-select".
[   413.301] (WW) NVIDIA(0): 
[   413.301] (II) NVIDIA(0): Validated MetaModes:
[   413.301] (II) NVIDIA(0):     "CRT-1:nvidia-auto-select"
[   413.301] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[   413.329] (WW) NVIDIA(0): Unable to get display device CRT-1's EDID; cannot compute DPI
[   413.329] (WW) NVIDIA(0):     from CRT-1's EDID.
[   413.329] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[   413.329] (--) Depth 24 pixmap format is 32 bpp
[   413.329] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[   413.329] (II) NVIDIA:     access.
[   413.332] (II) NVIDIA(0): Setting mode "CRT-1:nvidia-auto-select"
@allend no change with this too. Also tried to set "UseEDID" to "FALSE" but still nothing changes.

In the end i always end up with 640x480 and 320x240 and no higher

edit:
Solved it be adding - Option "IgnoreEDIDChecksum" "CRT".
Thank you both for your time, i really appreciate it

Last edited by sbolokanov; 02-14-2013 at 08:30 AM. Reason: solved
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No valid modes: 2048x1152 on Samsung 2343BWX with Quadro FX 500/600 jonboede Linux - General 1 01-06-2010 08:56 AM
Intel GMA X3100 VESA no valid modes lzcn Red Hat 16 06-08-2009 05:36 PM
VIA (0) No valid modes found n0idx80 Slackware 4 04-12-2008 05:58 PM
RHEL 5+ No Valid Modes + Fatal Server Error victvishwa Linux - Newbie 2 01-17-2008 03:46 AM


All times are GMT -5. The time now is 10:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration