LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-08-2009, 08:03 AM   #1
sickcom
LQ Newbie
 
Registered: Feb 2009
Posts: 4

Rep: Reputation: Disabled
resolution of graphix card


i have purchased a new lcd monitor for an aging comp that i run ubuntu8.04 on (used for net and amsn for my daughter) and i have hit a snag as the monitor needs a resolution of 1360x 768 and when i check the resoltion available in settings, it ends at 1200, is this the end for the graphics card, or what ubuntu has set as necessary. i can't set it any higher but can't tell if the graphics card will take more. i have the latest nvidia driver from a repository. what i would like to find is somewhere in the program that tells me what the graphics card is,(model make ect) which will help solve the problem but i don't know where to find this.(ps, I am not able to do anything remotely clever with source code or the like)
cheers
 
Old 02-08-2009, 08:43 AM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,043

Rep: Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977
As root type in a terminal:
Code:
lspci|grep VGA
and forward the results
 
Old 02-08-2009, 09:06 AM   #3
johnsfine
Guru
 
Registered: Dec 2007
Distribution: Centos
Posts: 5,055

Rep: Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104
If the limit really is in the card, you can almost certainly get the higher resolution by reducing the number of colors. I expect you have 32 bit color. I don't know if 24 bit color would work. I expect 16 bit color would work and get the desired resolution.

More likely, the card can do the desired resolution even with 32 bit color. It just needs an appropriate modeline in the xorg.conf file.

The important info for figuring this out is usually buried in
/var/log/Xorg.0.log
That is likely rather large for posting the whole thing (though maybe it is OK). Even an expert might have some trouble picking out the details that explain a given problem, but see if you can spot and quote some chunks of that that seem related to this issue.

I just grabbed the /var/log/Xorg.0.log of a server here (where no one even cares about the local display) and chunks that would have been relevant if we had a problem similar yours are surprisingly obvious:
Code:
(--) NV(0): VideoRAM: 131072 kBytes
(==) NV(0): Using gamma correction (1.0, 1.0, 1.0)
(WW) NV(0): config file vrefresh range 50-180Hz not within DDC vrefresh ranges.
(II) NV(0): Monitor0: Using hsync range of 30.00-95.00 kHz
(II) NV(0): Monitor0: Using vrefresh range of 50.00-180.00 Hz
(II) NV(0): Clock range:  12.00 to 400.00 MHz
(II) NV(0): Not using default mode "1600x1200" (hsync out of range)
and similar stuff further on, such as
Code:
(WW) (2048x1536,Monitor0) mode clock 266.95MHz exceeds DDC maximum 240MHz
So we get to see how much video ram is available (the primary limit on an older card supporting a higher resolution) as well as the horizontal, vertical and pixel timing constraints that the driver thinks it is subject to, as well as some resolutions it rejected and why.

Typically the driver is confused about the true timing constraints of the monitor and that can be overridden in xorg.conf. Or maybe some timing constraint of the old card is too low for a standard modeline for the resolution. But LCD's tend to do quite well (unlike CRT's) with lower refresh rate. So if the card has low timing limits, you can get it all to work by selecting some non standard lower refresh rate.

Earlier in the log are some details maybe useful to experts, such as
Code:
(II) Primary Device is: PCI 07:00:0
(--) NV(0): Chipset: "Quadro NVS 285"
You can get that part from lspci as well, but I don't think the parts you can get in lspci are as good for solving the problem as finding the right parts of that .log

Once you figure things out from the right parts of that .log, you would edit /etc/X11/xorg.conf to fix it. Probably you should post what you have there to begin with in order to get advice on what to edit.

Last edited by johnsfine; 02-08-2009 at 09:14 AM.
 
Old 02-08-2009, 09:18 AM   #4
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,722

Rep: Reputation: 195Reputation: 195
Make it easy.

It is for good reason the standard usage in English is to use capital letters when beginning a sentence and a period or other mark of punctuation at the end, dividing subjects considered into separate sentences.

A block of text such as yours is harder to read and therefore less likely to gain a considerate reading and a willing reply. You might profit by this link, looking both at its content and form of presentation.

http://www.linuxquestions.org/linux/...Ask_a_Question

Otherwise, good luck with the problem.

Last edited by thorkelljarl; 02-08-2009 at 12:24 PM.
 
Old 02-08-2009, 10:28 AM   #5
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Your nvidia driver may have come with an "nvidia-settings" program, which is very similar to the program they have for windows. However, your resolution is a very odd one. I doubt xorg configuration program has setting for your particular monitor unless you can select the exact model.

You may need to use the `gtf' program to generate a custom modeline and add it to the `section "Monitor"' section of your /etc/X11/xorg.conf file, and add the label to the Modes line.
example:
Code:
gtf 1360 768 60 -x

  # 1360x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 84.72 MHz
  Modeline "1360x768_60.00"  84.72  1360 1424 1568 1776  768 769 772 795  -HSync +Vsync
You would remove the `.00' from `60.00' and insert these lines into the section with the header `section "Monitor"'
Code:
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LPL"
    HorizSync       30.0 - 75.0
    VertRefresh     60.0
  # 1360x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 84.72 MHz
  Modeline "1360x768_60"  84.72  1360 1424 1568 1776  768 769 772 795  -HSync +Vsync

EndSection
Then in the section with the header `Section "Screen"', insert "1360x768_60"
Code:
Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1360x768_60" "1280x1024"  "1280x960" "1152x864" "1024x768" "800x600"
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1360x768_60" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1360x768_60" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1360x768_60" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection
I highlighted the changes that would be made. Don't use this modeline. Generate your own using the gtf command I used.
You could first try adding "1360x768" to the `Screens' section alone. Xorg may figure out the mode line for it automatically, but
for odd entries might not.

Good Luck!

Last edited by jschiwal; 02-08-2009 at 10:32 AM.
 
Old 02-08-2009, 10:44 AM   #6
johnsfine
Guru
 
Registered: Dec 2007
Distribution: Centos
Posts: 5,055

Rep: Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104
Quote:
Originally Posted by jschiwal View Post
Don't use this modeline. Generate your own using the gtf command I used.
Why? I don't think gtf can look at any information about the hardware on the system where it is run. It should give exactly that same modeline when "sickcom" uses it.

Quote:
You could first try adding "1360x768" to the `Screens' section alone.
I'm pretty certain that wouldn't work in this case.

Also, notice the 47.70 kHz Horizontal sync and 84.72 MHz pixel clock that gtf computed (I assume correctly) for 1360x768 at 60 Hertz. Either of those might be above some incorrect limit computed by the driver or might be above correct limits for that card. In either case that modeline wouldn't work. In one case you also need to override the limit. In the other case you need to select lower than 60Hz.

Plus, all of that assumes the card has enough video ram. If it doesn't you need fewer bits per pixel (probably 16 bit color).
 
Old 02-08-2009, 11:26 AM   #7
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
I didn't want to assume that, but you might be right. The answer seems the same on two computers. ( But why would it use libvdso to simply perform calculations? )

I don't expect the unhighlighted settings to be the same as the OP's. I included the entire sections as examples.
 
Old 02-08-2009, 01:52 PM   #8
johnsfine
Guru
 
Registered: Dec 2007
Distribution: Centos
Posts: 5,055

Rep: Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104
Quote:
Originally Posted by jschiwal View Post
The answer seems the same on two computers.
I'll throw in two more. I couldn't even find gtf in the Mepis repositories to install on the computer I'm on now. But it was preinstalled on a Red Hat and a Centos system I tried when I saw your earlier post. Very different display cards, but both gtf runs matched what you showed.

Quote:
I don't expect the unhighlighted settings to be the same as the OP's. I included the entire sections as examples.
I understood that. I hope anyone reading this for actual help did. The highlighted parts were exactly what you suggest editing into those positions, but the unhighlighted parts were only an approximation, hopefully similar enough to what will be on someone else's system to indicate where the highlighted parts fit.
 
Old 02-10-2009, 05:18 AM   #9
sickcom
LQ Newbie
 
Registered: Feb 2009
Posts: 4

Original Poster
Rep: Reputation: Disabled
resolution

Thanks for the help, I have been able to (with everybodys help)find the answer and now have the screen running at the correct resolution! Thanks for the info.
ps I hope my punctuation and layout is clearer this time,thorkelljarl, I will be more considerate in the future.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ASUS Laptop Graphix screwup remisandotbe Linux - Newbie 1 12-03-2007 12:58 AM
Graphix Card or Open GL not working Take a look BlackRob Linux - Games 10 04-27-2004 09:49 PM
linux display 32 bit graphix kidd Linux - General 2 08-04-2003 11:13 AM
GraphiX Programming NGraphiX Linux - General 0 08-23-2002 03:41 AM
graphix screwup justin19fl Linux - Newbie 8 06-13-2001 11:02 PM


All times are GMT -5. The time now is 05:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration