LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-23-2005, 02:37 PM   #1
aenimax
LQ Newbie
 
Registered: Nov 2003
Location: Texas
Distribution: Mandrake 9.1
Posts: 28

Rep: Reputation: 15
Resolution in Fluxbox - Slackware


Hi. Im new to Slackware. I've used Suse a lot in the past, but i didnt get away from kde much. Now im using slackware and fluxbox trying to learn the more interesting parts of linux. Here's my question. In suse i could set my resolution to 1280x1024 through kde's display settings and didnt have any problems with display. But now on fluxbox the resolution looks big, like 1024x768. I need to find out how to get fluxbox to display in 1280, because everything is too huge on my screen. Thanks a lot in advance
 
Old 10-23-2005, 03:52 PM   #2
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,178

Rep: Reputation: 47
Fluxbox is a very minimalistic wm. It doesn't have all the gui-based config utils. Screen resolution has to be set in your xorg.conf file.
 
Old 10-23-2005, 09:55 PM   #3
aenimax
LQ Newbie
 
Registered: Nov 2003
Location: Texas
Distribution: Mandrake 9.1
Posts: 28

Original Poster
Rep: Reputation: 15
yeah in xorg.conf i changed the display modes and added 1280x1024. I saved it, but nothing ever changed...
 
Old 10-23-2005, 11:44 PM   #4
Ynot Irucrem
Member
 
Registered: Apr 2005
Location: Perth, Western Australia
Distribution: Debian
Posts: 233

Rep: Reputation: 30
added 1280x1024? you have to specify it first in the list for it to be the default:
Code:
Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultDepth     24
                SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes   "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Last edited by Ynot Irucrem; 10-23-2005 at 11:51 PM.
 
Old 10-24-2005, 12:34 AM   #5
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
By the way, if you have a standard CRT monitor then "1280x1024" uses the wrong aspect ratio (5:4), so everything will look slightly fatter than it should. You really want to use "1280x960", "1152x864" or one of the other 4:3 modes (if your monitor can handle it and the refresh rate isn't too low, maybe try "1400x1050").

"1280x1024" is generally for the more squarish lcd panels.
 
Old 10-24-2005, 11:44 PM   #6
aenimax
LQ Newbie
 
Registered: Nov 2003
Location: Texas
Distribution: Mandrake 9.1
Posts: 28

Original Poster
Rep: Reputation: 15
# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present. Each describes
# the configuration of a single screen. A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
Identifier "Screen 1"
Device "VESA Framebuffer"
Monitor "My Monitor"

# If your card can handle it, a higher default color depth (like 24 or 32)
# is highly recommended.

# DefaultDepth 8
# DefaultDepth 16
DefaultDepth 24
# DefaultDepth 32

# "1024x768" is also a conservative usable default resolution. If you
# have a better monitor, feel free to try resolutions such as
# "1152x864", "1280x1024", "1600x1200", and "1800x1400" (or whatever your
# card/monitor can produce)

Subsection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubsection
Subsection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubsection
Subsection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubsection
Subsection "Display"
Depth 32
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubsection

EndSection


So there's my screen section. those 1280x1024's were put in there by me. Am i doing something wrong?
 
Old 10-25-2005, 12:14 AM   #7
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Looks correct to me, but one thing ... check your xorg.log

grep "config file:" /var/log/Xorg.0.log
Is it the same file you're editing?


Cheers,
Tink
 
Old 10-25-2005, 08:00 AM   #8
alagenchev
Member
 
Registered: Oct 2004
Location: USA
Distribution: Slackware, Debian, Ubuntu
Posts: 223

Rep: Reputation: 30
Here is My suggestion. Look up your monitor's and your video card's specs on google. That is refresh rates, chipset, monitor size etc. Then from terminal run xorgconfig, and go through it. It should work.
 
Old 10-25-2005, 07:19 PM   #9
aenimax
LQ Newbie
 
Registered: Nov 2003
Location: Texas
Distribution: Mandrake 9.1
Posts: 28

Original Poster
Rep: Reputation: 15
sweet! i did what you said alagenchev and it worked prefect. thanks a lot!
 
Old 10-25-2005, 08:24 PM   #10
MetaLMilitiA
LQ Newbie
 
Registered: Oct 2005
Posts: 2

Rep: Reputation: 0
I'm getting the same problem. I've installed the NVIDIA drivers, then ran xorgconfig, and even edited the xorg.conf the ways it was edited in this thread, but no luck.

Code:
Section "Screen"
    Identifier  "Screen 1"
    Device      "NVIDIA Graphics Driver"
    Monitor     "My Monitor"

   DefaultDepth 24

    Subsection "Display"
        Depth       24
        Modes "1600x1400" "1024x768" "800x600" "640x480"
    EndSubsection

EndSection
 
Old 10-25-2005, 09:02 PM   #11
MetaLMilitiA
LQ Newbie
 
Registered: Oct 2005
Posts: 2

Rep: Reputation: 0
Alright, I got it working, I guess I missed the part in the thread where CRT monitors only use 4:3 modes, so 1600x1200 worked.
 
Old 10-25-2005, 10:56 PM   #12
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
Well, most (not too old) CRT monitors support 1280x1024 even if the aspect ratio is wrong with a decent refresh rate, and any resolution works as long as it doesn't make it violate the HSync and VRef ranges (and perhaps other restrictions, I'm certainly no expert on monitors) although the refresh rate might be low.

You're best to stick with resolutions that match the actual size of the monitor (don't get me started on people who stretch out broadcast tv signals to fit new widescreen displays!)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fluxbox, slack-current resolution problem jasone Slackware 2 04-24-2005 09:57 AM
How to change the screen resolution in Fluxbox madiyaan Linux - Newbie 1 11-27-2004 06:18 PM
FluxBox Font Size or Resolution SML Linux - Software 2 03-26-2004 01:25 AM
FluxBox and Slackware XPediTioN Linux - Software 1 07-17-2003 12:18 PM
Resolution in X....WM is Fluxbox... Grim Reaper Linux - Software 2 01-17-2003 06:05 AM


All times are GMT -5. The time now is 04:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration