LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-16-2004, 09:52 AM   #1
sanu
Member
 
Registered: Jan 2004
Location: bangalore
Posts: 45

Rep: Reputation: 15
Resolution(GUI) Problem






So far you people were testing my patience.....

I am a new bie, and i ll definitely ask questions again and again...

Ok forget it,

Now i m sending the full details of my problem along with detailed configuration.....


i am facing problem regarding my GUI.

i m using Red Hat 9 version. The problem which i m facing is that, i have to keep my x-windows in lowest resolution ie 640*480. if i increase the resolution, my X-windows does not start.

My video card and dirver configuration is as follws:
------------------------------------------------------------------------------------------------
[Pro Savage DDR K4M266]
Manufacturer: S3 Inc
Driver Card: S3 Pro Savage KM 133
------------------------------------------------------------------------------------------------



My /etc/X11/XF86Config file is as follows:

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "SyncMaster"
DisplaySize 280 210
HorizSync 30.0 - 55.0
VertRefresh 50.0 - 120.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "savage"
VendorName "Videocard vendor"
BoardName "S3 ProSavage KM133"
VideoRam 16384
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


My monitor configuration is follows:


------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Company: Samsung's SAMTRON 15 inch color monitor.

Display Tube:
-------------
Type: 15''(38cm) Full square type (35cm viewable)
Deflection angle: 90 Degree
Dot Pitch: 0.24mm(Horizontal)
Screen Type: Aluminized tri-color phosphor dot trio with black mask.

Maximum Resolution: 1024 Dots,768 Lines
-------------------

Active Display:
----------------
Horizontal: 267 +- 4mm
Vertical: 200 +- 4mm

Synchronization:
----------------
Horizontal: 30 - 55 KHz
Vertical: 50 - 120 KHz

Model Name: 56V (Black)
-----------

Model Code: AN15VW7NK/XPT-M
-----------
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------




The processor which i am using is AMD Athlon XP 2000+...




My question is,
1. Whats the problem exactly is?
2. Is there is any problem in /etc/X11/XF86Config?
3. Is there any problem in video card?
4. If the problem is in video card,then why there was no problemin Red Hat 8 which I was using earlier?
5. Is there any problem in monitor?

I am in a dilema and need help urgently....

thanks in advance....


Hope this time i will not return with disapointment...........


sanu

Bangalore,India
 
Old 01-16-2004, 10:05 AM   #2
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
at first, you might want to change this line in your XF86Config (in section "Screen"):

Modes "640x480"

change it like this to add other resolution options:

Modes "640x480" "800x600" "1024x786"

so you just add a space, then (with quotes) new XxY setup. this makes your XFree to "support" more than one display mode, and might help. OR you can leave the other resolutions off, if you just know one that works. then edit like this: comment out the original 640x480 line in the screen's section, and add the following (and if something won't work, you can just uncomment the first one and comment out the next one to cancel these changes)

#Modes "640x480"
Modes "1024x768"

or just use anything you want instead of 1024x768. this just tells that the line with # is ignored (so it's just like there wouldn't be any line - you may also delete it) and the second line tells that XFree should use resolution 1024*768. Try that out first..

EDIT: does X give any error messages when it won't start?

Last edited by b0uncer; 01-16-2004 at 10:07 AM.
 
Old 01-16-2004, 10:13 AM   #3
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
and to say something about this "error", in my opinion, it can't be any video card or monitor problem, because you said you were able to run it with no problem with RH8 AND your current OS works fine in at least one resolution. so the only thing that's left is that X doesn't know how to draw you something and, based on what I've faced with XFree, this usualy happens because of incorrect resolution or frequency settings..and it seems like your frequencies are ok, so let's try the resolutions out first - and if it won't work out, we'll see what we can do next.

problems are made to be solved... even tough it'd need a step-by-step detective story.
 
Old 01-16-2004, 01:08 PM   #4
aqoliveira
Member
 
Registered: Dec 2001
Location: Portugal
Distribution: /Red Hat/Fedora/Solaris
Posts: 622

Rep: Reputation: 30
howzit

itīs gr8 that u r try to solve it and not give up like most newbies try usibg this cmd before u start digging into config file the cmd is redhat-config-xfree86. make sure u have uīre monitor seetings at hand and this cmd must be run in text mode and as root. Therefor login into X then change to console with Ctrl-Alt-F1 login as root then type in cmd init 3.
if this doesnīt work then run the same cmd again and goto the advanced section and mess around with refresh rates and monitor settings. Another suggestion is for u to bump up the res with less colour depth.

chow
 
Old 01-17-2004, 03:55 AM   #5
sanu
Member
 
Registered: Jan 2004
Location: bangalore
Posts: 45

Original Poster
Rep: Reputation: 15
while following the 1st step(ie, "640x480" "800x600" "1024x768") x-windows was coming, but still resolution was poorer than 640*480. The graphical screen was covering huge area in the monitor.

when i followed 2nd step(ie, "1024x768"), x-windows itself didnt start, just like my earlier problem.

and one more thing, you asked me is that whether any error message comes or not. the answer is "it doesnt show any error message". that is my x-windows fails to start without showing any error message.

So the problem is still not solved. So plz tell me what to do next?

Waitihg for reply...
 
Old 01-17-2004, 06:52 AM   #6
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Hmm....XFree logs it's doings, usually in /var/log/XFree86-N.log (where "N" is the screen number it uses, like if you start it to 0:0 it's XFree86-0.log. So look there too if there is any kind of info what's going on..tough, if it won't show errors, then I guess there aren't msgs in the logfile either.

Now if you have Redhat (I myself haven't used it for some time) then you might want to check out what aqoliveira told: the redhat-config-xfree86. If you need to run it from the console, and you're in X, press CTRL+ALT+BACKSCAPE to close X (if you use graphical login screen, then this may not work). Or, then you must boot into runlevel 3 which is text console (like aqoliveira said).

You should also try (again, like aqoliveira adviced) to reduce DefaultDepth (in the screen section) from 24 to 16, for example. This shouldn't have anything to do with the starting, I guess, if X starts in one video mode...but everything can be tried

And then: how does your X go down when you start it? Does it flash or flicker, or just go straight to black? How long does it try to start, for half a second or half a minute? (these can give a clue on how far X succeeds to read it's config & work out, and what's going on)

I try to find something out of XFree's mans or in the net..meanwhile, try the color depth trick & write here line by line what your X does when you start it...

p.s. Do you have some drivers from the video card's manufacturer? Do you use them? Are those enties in the XFree's config made automatically by some program, or have you put them in manually?

It can't be a big deal after all, what's causing this..at least I think it's a small piece of stone on our way it's just that we need to find where it is - if X starts somehow, the problem is not fatal.

Juho

(edited to fix some "typign erors" )

Last edited by b0uncer; 01-17-2004 at 06:55 AM.
 
Old 01-18-2004, 12:00 PM   #7
sanu
Member
 
Registered: Jan 2004
Location: bangalore
Posts: 45

Original Poster
Rep: Reputation: 15
Angry Resolution(GUI) problem



I did everything as far ur instruction.... Still no sign of success....

As u asked me whether any flikkering happens or not,the answer is "Yes".
A bit flikkering happens for a time limit of (i guess 1/2 second) and ultimately the monitor turns black...

Even i tried by decreasing the default depth, but gives fatal error....

So plz tell me what to do next....

waiting for reply....

sanu

bangalore,india
 
Old 01-22-2004, 01:30 PM   #8
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
mm back in business... I've been in a small hurry, so I haven't had time to get here. hmm..so flickering does happen. as far as I remember, I've only had flickering-problem (and a "black dead screen") when I tried to install some old RH back in the days..the problem then was my graphics card's memory - the installation program guessed something like two megs, but truly there were 32 then. I tried to give it 32, but the only answer I got (by using a "test-button" to start X to see if it would work) was the flickering screen. lowering the memory to 4megs solved problem then...altough it's been a while, and I guess these newer systems can do things better.

but so, if those values in your config file are "guessed" or probed by some program during the installation, and not written by yourself, you can try experimenting with them; try changing the amount of memory (videoram?), but be careful especially if you try to change the frequencies; wrong frequencies won't do good to your screen!

I suggest you surf to the screen manufacturer's website (or try google) and search what frequencies it uses, and see if they differ from your config. it'd be even better if you had a manual for the screen, where you could check out the correct values for all entries in XF86Config, that have something to do with your screen.

if you can't find any info, try googling for "samsung samtron frequency" (but be _completely_ sure it's the same model you have, if you find some values) to see if they match the ones in your config.

also, (did I say this already?) try going to your graphics card manufacturer's website (was it savage or something, your card?) and see if there are any linux drivers to download & use. installing new drivers usually helps, and there you get the info on how to configure completely your XFconf..at least it helped me
 
Old 01-22-2004, 01:48 PM   #9
kaz4u2dig
Member
 
Registered: Jan 2004
Distribution: Suse Pro 9.0
Posts: 84

Rep: Reputation: 15
I have the same problem

I have the same problem only i cannot login to X interface with any user, only root user and password. I get the flicker too using previously set up user and it wont let me in. And resolution in root seems to be the absolute worst. check out my forum posted yesterday (kaz4u2dig). alot of useful info. but i am giving up on my video card and suse 7.0. finding a suse compatible video card and getting Suse 9.0 and paying my technician a bunch of money to get it up and running. Hopefully the cdrom will automatically mount and umount itself too =)
 
Old 01-22-2004, 02:47 PM   #10
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Quote:
Originally posted by sanu


I did everything as far ur instruction.... Still no sign of success....

As u asked me whether any flikkering happens or not,the answer is "Yes".
A bit flikkering happens for a time limit of (i guess 1/2 second) and ultimately the monitor turns black...

Even i tried by decreasing the default depth, but gives fatal error....

So plz tell me what to do next....

waiting for reply....

sanu

bangalore,india
Hello. Is your video card AGP or PCI? Regardless, type as root:

lspci -v

to list all pci devices and give the BusIDs for each. If your card shows as BusID

01:00.0

then you should make your XF86Config file look like:

Code:
Section "Device"
Identifier "Videocard0"
BusID "PCI:01:00:0"
Driver "savage"
VendorName "Videocard vendor"
BoardName "S3 ProSavage KM133"
VideoRam 16384
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
Additionally you should try commenting out the VideoRam section until you get it working properly--let it use the default for now. Another thing, you might want to add to your "Screen" section ViewPort 0 0 to get rid of your virtual desktop being larger than actual screen. So, in total, it will look like this (changes in bold):

Code:
Section "Device"
Identifier "Videocard0"
BusID "PCI:01:00:0"
Driver "savage"
VendorName "Videocard vendor"
BoardName "S3 ProSavage KM133"
#VideoRam 16384
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "640x480" "800x600" "1024x768"
ViewPort 0 0
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
Hope this helps.
 
Old 01-25-2004, 12:38 AM   #11
bela214
LQ Newbie
 
Registered: Jan 2004
Location: Minneapolis, MN
Distribution: Mandrake 9
Posts: 11

Rep: Reputation: Disabled
have you tried adjusting the monitor rather than the system? on some monitors, when the "clock" setting is not absolutely correct, your monitor won't display your screen correctly (or sometimes like in your case, not at all).

i'm a newbie too, thought maybe i'd offer up some ideas.

-Michelle
 
Old 01-26-2004, 10:17 AM   #12
kaz4u2dig
Member
 
Registered: Jan 2004
Distribution: Suse Pro 9.0
Posts: 84

Rep: Reputation: 15
Hey guys I found the problem. My video card was crap. Something like 3D labs generic. Everything was different about the interface after that. Got a matrox. Works fine.
 
Old 01-27-2004, 09:53 AM   #13
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
kaz4u2dig nice you found your problem.. I've been working on my own machine since I installed new distro (oops...better change my user info no gentoo anymore) and did it quite from the beginning...not _totally_ from scratch, but still..

but sanu, I suggest you to run again the xf86config (found in /usr/X11R6/bin/ I guess) and answer all the questions appropriately. I did it because of my distro-switching, and only had to edit few lines "manually" after that (because I had put wrong values in the xf86config and understood it afterwards).

so run, as root(?), "xf86config" and it asks you some questions, answer them and then try startx again....some of the questions are "y/n" -type, some are "choose from list" -type and so on...I think after you've run that through (and perhaps updated your graphics card drivers, if needed) there should be no problem anymore? at least if the problem resides in your current XF86Config, that is.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem in Resolution (GUI) sanu Linux - Newbie 8 10-17-2005 11:30 AM
Modifying GUI screen resolution thru text jenson Red Hat 1 03-18-2005 04:33 PM
Resolution(GUI) problem sanu Linux - Newbie 13 01-12-2004 10:44 AM
name resolution problem mdwstmusik Linux - Networking 5 02-27-2003 10:53 PM
Resolution Problem Black Mammoth Linux - General 5 09-03-2002 04:20 AM


All times are GMT -5. The time now is 06:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration