LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Resizing VirtualBox with LXDE inside doesn't restretch wallpaper (http://www.linuxquestions.org/questions/linux-newbie-8/resizing-virtualbox-with-lxde-inside-doesnt-restretch-wallpaper-741903/)

mmatt 07-22-2009 06:01 AM

Resizing VirtualBox with LXDE inside doesn't restretch wallpaper
 
Hi there. Any ideas how to accomplish this? I've got Arch64 running inside a VirtualBox on a Vista64 Host (boooo). I've got all the guest additions working, including the automatic screen resize. The only problem is that when the screen is resized, the wallpaper doesn't, leading to horrible tile effects (when scaling up) or missing edges (scaling down).

Openbox is my WM, LXDE is the DE.

Thanks, Matt

catkin 07-22-2009 07:25 AM

Hello mmatt :)
Quote:

Originally Posted by mmatt (Post 3616217)
Hi there. Any ideas how to accomplish this? I've got Arch64 running inside a VirtualBox on a Vista64 Host (boooo). I've got all the guest additions working, including the automatic screen resize. The only problem is that when the screen is resized, the wallpaper doesn't, leading to horrible tile effects (when scaling up) or missing edges (scaling down).

Openbox is my WM, LXDE is the DE.

Thanks, Matt

It's a Windows question! Do you have Display properties->Desktop, Position set to stretch?

Best

Charles

mmatt 07-22-2009 07:29 AM

No no, you misunderstand me. It's not the windows desktop which is the problem, its the wallpaper in Arch. VirtualBox is running in Vista64 (boo again), Arch is in VBox and resizing the VBox window automagically resizes Archs desktop except the wallpaper doesn't stretch anymore. If I go into Desktop setting in openbox I set it to stretch again but that doesn't work either. It's like openbox isn't aware of the new screen size.

catkin 07-22-2009 08:01 AM

Hello mmatt :)
Quote:

Originally Posted by mmatt (Post 3616305)
No no, you misunderstand me.

I'm so sorry -- I misunderstood your perfectly clear question and so took your thread off the "Zero Replies" list, reducing your chances of getting an answer.:redface:

Worst is I have no knowledge to help with the question you did ask so I can't make amends.

Sorry again. Hope you do get an answer.

Best

Charles

mmatt 07-22-2009 08:03 AM

Not to worry, thanks for the attempt anyway :). It's not a serious problem, just one of those little annoyances you spend more time solving than doing real work...!

catkin 07-22-2009 08:18 AM

Quote:

Originally Posted by mmatt (Post 3616329)
Not to worry, thanks for the attempt anyway :). It's not a serious problem, just one of those little annoyances you spend more time solving than doing real work...!

Thank you for your kindness.

tekhead2 07-22-2009 08:19 AM

The problems your having are most likely due to the fact that when you configured your xorg install during the original install it didn't have the kernel modules for the vbox guest additions, so your xserver didn't know you could go to such a high resolution. If you just did a standard install and didn't install HAL then thats probably whats happened. If you do have HAL installed then maybe something else is going on.

If the issue is just the wallpaper size I suggest looking for a new one with a larger resolution. From my experience the LXDE default blue wallpaper is only 1024x768, if your screen resolution is going beyond that then you will see the edges of the image. Also you can right click on the desktop and if you have pcmanfm set to display the desktop you can go to the bottom of that menu and change the desktop background. In the wallpaper dialogue you can set the wallpaper mode, usually the mode is set to stetch to fit the entire screen. It sounds like you may have it set to tiled.

Now if you've done this and the image is still tiled then you may want to take a look at your xorg.conf and make sure you have the correct driver setup for the graphics card and that your screen resolution is set right. You can try Xorg -configure to edit your current configuration. Make sure that in the "Device" section you have "Driver" set to be "vboxvideo". I'm not sure but I think that Arch doesn't have a graphical Xorg config tool, but I maybe mistaken.

mmatt 07-22-2009 08:24 AM

That's some good advice tekhead. I do have HAL installed (before Xorg). The wallpaper scales fine if I start VBox fullscreen (it is set to strecth in the LXDE settings). But, once LXDE has started, the wallpaper will not resize again. init 3 then init 5 will readjust it, but that's a little bit overkill... vboxvideo is the driver in Xorg.conf. I basically need to get LXDE to restretch the wallpaper to the new dimensions when Xorg changes the screen size.

tekhead2 07-22-2009 08:30 AM

I've been having similar issues with a dual screen setup using LXDE. It's been my experience that you could just login to an OpenBox session, which will scale the image correctly, then open a terminal and run "lxpanel &" which will background the panel. This will give you sort of a LXDE session, but the session manager will still be OpenBox. Also in order to get desktop icons you will have to run "pcmanfm -desktop &" in a terminal to get the desktop back up. I'm thinking this is a limitation of the pcmanfm application in scaling the wallpaper. I've been doing this and it seems to work well. Just remember that you'll not be able to logout using the lxpanel, you will have to logout using openbox, so I've just been skipping using pcmanfm as the desktop, and just running openbox with lxpanel at the bottom. The best part of LXDE is it's modular design allowing you to do cool stuff like this.

mmatt 07-22-2009 08:48 AM

Just tried that. Unfortunately won't automatically restretch the wallpaper still. Maybe I'll just remove the wallpaper, or maybe I'll look at modifying pcmanfm to handle it, or, better yet, find a replacement for pcmanfm...

tekhead2 07-22-2009 09:20 AM

If you have your heart set on desktop icons you can try idesk, It doesn't handle icons as well, but it works in a pinch. I've just given up on pcmanfm working with larger resolutions.

mmatt 07-22-2009 09:28 AM

To be honest I don't really care for desktop icons, though I do like a nice wallpaper :). I may just go for straight up openbox and install the stuff I need from there. I wonder if the wallpaper will ever automatically scale... Thanks for the suggestions tekhead. If anyone does find a lightweight WM that is VBox friendly I'd like to hear about it.

DetroitLibertyPenguin 07-22-2009 12:09 PM

I have the same problem on my Debian machine once i change the resolution so that other applications are readable. I hate the high res., sure its supposidly better, but BAH, text size are always smaler as a result. Poo on that. Anythign that resolution is important for, like photos and video, work indpendent of the resolution of the machine.

mmatt 07-24-2009 03:05 PM

Solution! Although I've changed WMs to fluxbox I have a working solution which I think can be applied to openbox+lxde too. Here goes...

When VBox resizes the script /usr/bin/VBoxRandR is called (at least on my system, "which VBoxRandR" will show you where on yours). I'm currently using fbsetbg to manage the wallpaper, so appending "fbsetbg -l" to the end of the script makes this work. On openbox+lxde you'll need to work out how to get pcmanfm or whatever manages you're background (I recommend feh) to redraw.

Basically, If you want something to happen on resize (perhaps scaling all the windows too... :)) then put it in VBoxRandR (at the end)!

tekhead2 08-06-2009 08:31 AM

Good work.. you didn't even need our help lol!


All times are GMT -5. The time now is 06:31 AM.