LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-12-2010, 01:03 PM   #1
EnderX
Member
 
Registered: Nov 2006
Posts: 64

Rep: Reputation: 15
Requesting advice on SuSE 9.3 FTP user/password issues - trouble connecting


I've been trying to figure out how to set up vsftpd on a test machine to emulate the ftp setup on our current ftp server. I was able to track down part of what I needed with the gracious help of poster AlucardZero on this forum, who pointed out that the vsftpd process likely being run via xinetd.

I've managed (or so I thought) to set everything up correctly - but I cannot connect to my test box as the user the ftp client program we're using expects. I can see in the vsftpd log that I'm making contact, but the client program is automatically failing, and attempts to get in from the Windows command line (ftp <ip>) request user and password, then fail out with '530 Login incorrect'.

Everything I've seen online so far indicates that the ftp login for a local user (with vsftpd configuration settings including anonymous_enable=NO and local_enable=YES) should be the same as the 'normal' login for that user, and that the passwords should be the same as well. This is the case on the current FTP server, where a Windows command line login uses the same password as attempting to su into the user in question. On my test machine, I can su into the user in question with the password as well. I simply cannot seem to connect with this user via ftp.

Below are the things I've found so far during my search on the two servers:
Code:
User in question exists on both systems.
User password is same on both systems.
User is part of same groups on both servers and has same gid on both servers.  (Differing uid values)
    [Had to create and set group values on test machine for myself]

Linux versions are not identical: 
	FTP Server is SuSE 9.0
	Test Server is SuSE 9.3

xinetd.conf files are identical.
xinetd/vsftpd files are identical
vsftpd.conf files are identical
hosts.allow files are identical (commented out)
hosts.deny files are identical (http-rman : ALL EXCEPT LOCAL)

neither server has a file /etc/vsftpd.allowed_users
neither server has a file /etc/vsftpd.denied_users
I'm obviously missing something simple, because I've read many posts on this site and others concerning successful setups - I simply haven't managed one on my own. Most of these eventually boiled back down to this howto page, and I've tried to follow the 'add and change user' instructions shown there to no avail.

If someone here has a suggestion for another filename to search on or a different howto that might explain my problem, I would greatly appreciate the chance to see it.
 
Old 11-12-2010, 01:22 PM   #2
Davethesnake
LQ Newbie
 
Registered: Oct 2010
Posts: 25

Rep: Reputation: -14
thats a reall bad bug boy-check your soft or maybe try a different user
 
0 members found this post helpful.
Old 11-12-2010, 01:30 PM   #3
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Quote:
Originally Posted by Davethesnake View Post
thats a reall bad bug boy-check your soft or maybe try a different user
This is an unhelpful, meaningless reply which has unfairly removed this thread from the zero-reply list. As such, this reply and any further replies related to this one, be removed, restoring zero-reply status to this thread.

Please do not post to a thread if you have nothing constructive to add.
 
Old 11-12-2010, 01:46 PM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 18,331

Rep: Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881
Quote:
Originally Posted by EnderX View Post
I've been trying to figure out how to set up vsftpd on a test machine to emulate the ftp setup on our current ftp server. I was able to track down part of what I needed with the gracious help of poster AlucardZero on this forum, who pointed out that the vsftpd process likely being run via xinetd.

I've managed (or so I thought) to set everything up correctly - but I cannot connect to my test box as the user the ftp client program we're using expects. I can see in the vsftpd log that I'm making contact, but the client program is automatically failing, and attempts to get in from the Windows command line (ftp <ip>) request user and password, then fail out with '530 Login incorrect'.

Everything I've seen online so far indicates that the ftp login for a local user (with vsftpd configuration settings including anonymous_enable=NO and local_enable=YES) should be the same as the 'normal' login for that user, and that the passwords should be the same as well. This is the case on the current FTP server, where a Windows command line login uses the same password as attempting to su into the user in question. On my test machine, I can su into the user in question with the password as well. I simply cannot seem to connect with this user via ftp.

Below are the things I've found so far during my search on the two servers:
Code:
User in question exists on both systems.
User password is same on both systems.
User is part of same groups on both servers and has same gid on both servers.  (Differing uid values)
    [Had to create and set group values on test machine for myself]

Linux versions are not identical: 
	FTP Server is SuSE 9.0
	Test Server is SuSE 9.3

xinetd.conf files are identical.
xinetd/vsftpd files are identical
vsftpd.conf files are identical
hosts.allow files are identical (commented out)
hosts.deny files are identical (http-rman : ALL EXCEPT LOCAL)

neither server has a file /etc/vsftpd.allowed_users
neither server has a file /etc/vsftpd.denied_users
I'm obviously missing something simple, because I've read many posts on this site and others concerning successful setups - I simply haven't managed one on my own. Most of these eventually boiled back down to this howto page, and I've tried to follow the 'add and change user' instructions shown there to no avail.

If someone here has a suggestion for another filename to search on or a different howto that might explain my problem, I would greatly appreciate the chance to see it.
Seen a few things cause the 530 message:
  • Users created with no shell (i.e. some 'ftp only' accounts). Set the shell to be /bin/false. Check the check_shell option in vsftpd.conf too.
  • Try adding "pam_service_name=vsftpd" to your /etc/vsftpd/vsftpd.conf
  • Do you have selinux enabled/firewall on? (probably not, but still...)
  • Is there a delay between boxes when you try to log in? Could it be trying to do a reverse-lookup?
Just some thoughts.
 
Old 11-12-2010, 02:33 PM   #5
EnderX
Member
 
Registered: Nov 2006
Posts: 64

Original Poster
Rep: Reputation: 15
TB0ne, thank you for your prompt response.

In answer to the items you brought up:

1)pam_service_name=vsftpd was already present inside the vsftpd.conf file.

2)There was about a thirty-second delay yesterday before connecting, but it was missing today. The Windows command line ftp command didn't even let me issue the user name until after that.

As for the other two items you brought up - I dunno; I couldn't find that 'check_shell' inside the vsftpd.conf file, so I'll go look it up. Thanks for the advice.
 
Old 11-12-2010, 03:29 PM   #6
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 18,331

Rep: Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881
Quote:
Originally Posted by EnderX View Post
TB0ne, thank you for your prompt response.

In answer to the items you brought up:

1)pam_service_name=vsftpd was already present inside the vsftpd.conf file.
2)There was about a thirty-second delay yesterday before connecting, but it was missing today. The Windows command line ftp command didn't even let me issue the user name until after that.

As for the other two items you brought up - I dunno; I couldn't find that 'check_shell' inside the vsftpd.conf file, so I'll go look it up. Thanks for the advice.
Hope it helps. But, check the user ID's themselves in the /etc/passwd file (providing you're not using virtual users), and see what's defined for their shell's. Doing a "usermod -s /bin/false <userid>" may fix it, without having to define the check_shell option.
 
Old 11-12-2010, 05:05 PM   #7
EnderX
Member
 
Registered: Nov 2006
Posts: 64

Original Poster
Rep: Reputation: 15
Thanks. I think I've got it solved - managed to get in and download via 'get' command, anyway.

Turned out the /etc/pam.d/vsftpd files weren't matched to each other. Once that was solved, everything else worked. Thanks for pointing the 'pam_service_name=vsftpd' line out to me - I noted it was present, but then later started thinking about what that might actually mean. Better late than never, I guess. Thank you again for your assistance.
 
Old 11-13-2010, 11:37 AM   #8
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 18,331

Rep: Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881
Quote:
Originally Posted by EnderX View Post
Thanks. I think I've got it solved - managed to get in and download via 'get' command, anyway.

Turned out the /etc/pam.d/vsftpd files weren't matched to each other. Once that was solved, everything else worked. Thanks for pointing the 'pam_service_name=vsftpd' line out to me - I noted it was present, but then later started thinking about what that might actually mean. Better late than never, I guess. Thank you again for your assistance.
Not a problem, glad it helped.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble connecting to an FTP server KenjiKinya Linux - Newbie 9 08-02-2009 06:30 AM
Trouble connecting to wifi with a password protected accesspoint; Debian Delta_X Linux - Networking 6 10-28-2008 02:35 PM
Requesting advice on network layout skibler1223 Linux - Networking 4 07-08-2008 06:30 PM
Requesting advice on buying a graphics card for TV-out cdhgee Linux - Hardware 1 12-16-2007 03:11 PM
Requesting Networking Advice gulo Linux - Networking 1 08-27-2004 11:35 PM


All times are GMT -5. The time now is 01:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration