LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-28-2012, 08:22 AM   #1
y_mullah
LQ Newbie
 
Registered: Sep 2012
Posts: 15

Rep: Reputation: Disabled
Request Tracker 4


Hello!

I have installed request tracker 4.0.1 on my CentOS 5 distribution. I have not been able to access the RT web interface. I get a
Not Found

The requested URL /rt was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

error when i try to connect to request tracker's web interface. Below are my /etc/httpd/conf.d/rt4 and /opt/rt4/etc/RT_SiteConfig.pm files respectively:

<VirtualHost *:80>
ServerName http://axxentis.com
ServerAdmin root@localhost
### Optional apache logs for RT
# ErrorLog /opt/rt4/var/log/apache2.error
# TransferLog /opt/rt4/var/log/apache2.access
# LogLevel debug

AddDefaultCharset UTF-8

DocumentRoot "/opt/rt4/share/html"
# RequestTracker
<Location /rt>
Order allow,deny
Allow from all

SetHandler modperl
PerlResponseHandler Plack::Handler::Apache2
PerlSetVar psgi_app /opt/rt4/sbin/rt-server
</Location>
<Perl>
use Plack::Handler::Apache2;
Plack::Handler::Apache2->preload("/opt/rt4/sbin/rt-server");
</Perl>

# force rt over https always
RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteCond %{REQUEST_URI} rt
RewriteRule ^(.*)$ https://www.axxentis.com/$1 [R,L]
</VirtualHost>

Set($rtname , "axxentis.com");
Set($Organization , "Axxentis");
Set($MinimumPasswordLength , "5");
Set($Timezone , 'US/Pacific');

Set($DatabaseType , 'mysql');
Set($DatabaseHost , 'localhost');
Set($DatabaseRTHost , 'localhost');
Set($DatabasePort , '');
Set($DatabaseUser , 'rt_user');
Set($DatabasePassword , 'mypassword');
Set($WebPath , "/rt");
#Set($WebDomain, "axxentis.com");

Set($WebPort , 443);
Set($WebBaseURL , "https://axxentis.com");
Set($WebURL , $WebBaseURL . $WebPath . "/");
Set($DatabaseName , 'rt4');
Set($RTAddressRegexp , '^rt(-\S+|-\S+-comment)?\@(www\.)?axxentis.com$');
Set($CorrespondAddress , 'no-reply@axxentis.com');
Set($CommentAddress , 'no-reply@axxentis.com');

Any ideas will be welcome!
 
Old 09-29-2012, 12:35 PM   #2
sackboy
LQ Newbie
 
Registered: Sep 2012
Posts: 20

Rep: Reputation: Disabled
Hi,

Isn't /rt supposed to point to /opt/rt4/share/html?

It looks like you've specified that as your document root.

Perhaps the server is looking for /opt/rt4/share/html/rt when you go to the URL/rt in the browser?

You can try adding an Alias directive for /rt.
 
Old 10-01-2012, 04:43 AM   #3
y_mullah
LQ Newbie
 
Registered: Sep 2012
Posts: 15

Original Poster
Rep: Reputation: Disabled
I have done some editing of the rt4.conf file and this is the error I get when I restart my apache server:

Starting httpd: DBI connect('dbname=rt4;host=localhost','rt_user',...) failed: Access denied for user 'rt_user'@'localhost' (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 103.

RT couldn't connect to the database where tickets are stored.
If this is a new installation of RT, you should visit the URL below
to configure RT and initialize your database.

If this is an existing RT installation, this may indicate a database
connectivity problem.

The error RT got back when trying to connect to your database was:

Connect Failed Access denied for user 'rt_user'@'localhost' (using password: YES)
at /opt/rt4/sbin/../lib/RT.pm line 164.

any ideas how to correct the issue
 
Old 10-04-2012, 08:26 PM   #4
sackboy
LQ Newbie
 
Registered: Sep 2012
Posts: 20

Rep: Reputation: Disabled
Hi,

Are you running the rt-server?

Run: /opt/rt4/sbin/rt-server &

Then restart apache and try to go to /rt (if configured correctly).

RT should use your DB admin credentials to create its db, dbuser, and dbuserpass.

Usually after you do the make install, you also run: # make initialize-database (which does the db creation part)
 
Old 10-05-2012, 04:34 AM   #5
y_mullah
LQ Newbie
 
Registered: Sep 2012
Posts: 15

Original Poster
Rep: Reputation: Disabled
I followed your advice and this is what I get:

[root@localhost ~]# /opt/rt4/sbin/rt-server &
[1] 3709
[root@localhost ~]# WARNING: RT couldn't start up a web server on port 443.
This is often the case if the port is already in use or you're running /opt/rt4/sbin/rt-server
as someone other than your system's "root" user. You may also specify a
temporary port with: /opt/rt4/sbin/rt-server --port <port>

[1]+ Done /opt/rt4/sbin/rt-server
 
Old 10-05-2012, 06:10 PM   #6
sackboy
LQ Newbie
 
Registered: Sep 2012
Posts: 20

Rep: Reputation: Disabled
Hi,

It looks like apache is already running on 443.

Try this:

1. Stop apache
2. /opt/rt4/sbin/rt-server --port 1443 &
3. visit your server in a browser: https://server.ext:1443

What do you see when you do that?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[OpenSUSE 10.3] Request Tracker (RT) noir911 Suse/Novell 2 09-02-2008 07:04 AM
request tracker tester^_^ Linux - Newbie 5 09-01-2008 10:33 PM
request tracker system tester^_^ Linux - Software 2 07-30-2008 05:02 PM
Request Tracker Problem aston127 Linux - Newbie 5 06-01-2005 09:14 PM
Request Tracker in FC3 adm1329 Linux - Software 2 03-04-2005 10:24 AM


All times are GMT -5. The time now is 05:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration