LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-13-2009, 09:48 AM   #1
seeker48
LQ Newbie
 
Registered: Mar 2009
Posts: 17

Rep: Reputation: 0
repository conflict


I am a Fedora 9 beginner

I seem to have made the error of accessing conflicting repositories and am getting the following errror message with both yum update as well as the GUI update:-

Test Transaction Errors: file /lib/modules/2.6.27.21-78.2.41.fc9.x86_64/extra/nvidia/nvidia.ko from install of kmod-nvidia-2.6.27.21-78.2.41.fc9.x86_64-173.14.15-1.fc9.12.x86_64 conflicts with file from package kmod-nvidia-2.6.27.21-78.2.41.fc9.x86_64-173.14.15-1.fc9.5.x86_64

Please help me out.

regards
 
Old 05-13-2009, 09:52 AM   #2
forrestt
Senior Member
 
Registered: Mar 2004
Location: Cary, NC, USA
Distribution: Fedora, Kubuntu, RedHat, CentOS, SuSe
Posts: 1,288

Rep: Reputation: 99
Try uninstalling and reinstalling kmod-nvidia:

Code:
sudo yum erase kmod-nvidia
sudo yum install kmod-nvidia
HTH

Forrest
 
Old 05-13-2009, 10:59 PM   #3
seeker48
LQ Newbie
 
Registered: Mar 2009
Posts: 17

Original Poster
Rep: Reputation: 0
Thumbs down repository conflict

Quote:
Originally Posted by forrestt View Post
Try uninstalling and reinstalling kmod-nvidia:

Code:
sudo yum erase kmod-nvidia
sudo yum install kmod-nvidia
HTH

Forrest
tried the suggested command; result appended:-
Loaded plugins: fastestmirror, fedorakmod, kernel-module, refresh-packagekit,
: refresh-updatesd
Setting up Remove Process
No Match for argument: kmod-nvidia
Loading mirror speeds from cached hostfile
* livna: rpm.livna.org
* rpmfusion-nonfree-updates: astromirror.uchicago.edu
* fedora: fedora.iitm.ac.in
* rpmfusion-free-updates: astromirror.uchicago.edu
* rpmfusion-free: astromirror.uchicago.edu
* updates-newkey: fedora.iitm.ac.in
* updates: fedora.iitm.ac.in
* rpmfusion-nonfree: astromirror.uchicago.edu
Package(s) kmod-nvidia available, but not installed.
No Packages marked for removal

Thanks; waiting for more suggestions; will check back after 6-7 hrs.
 
Old 05-14-2009, 01:45 AM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
it is looking like your yum and rpm databases are messed up ( it happens from time to time )
to clean ti try the fallowing in the terminal
FIRST and you post the output of this
Code:
yum repolist
then to clean the db
Code:
su -
yum clean all
rpm --rebuilddb
yum update
 
Old 05-14-2009, 05:32 AM   #5
seeker48
LQ Newbie
 
Registered: Mar 2009
Posts: 17

Original Poster
Rep: Reputation: 0
repository conflict

Quote:
Originally Posted by John VV View Post
it is looking like your yum and rpm databases are messed up ( it happens from time to time )
to clean ti try the fallowing in the terminal
FIRST and you post the output of this
Code:
yum repolist
then to clean the db
Code:
su -
yum clean all
rpm --rebuilddb
yum update
--------------------------------------------------------
tried the suggested process twice.

Same error report repeats as appended below:-

Total 34 kB/s | 38 MB 19:07
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
file /lib/modules/2.6.27.21-78.2.41.fc9.x86_64/extra/nvidia/nvidia.ko from install of kmod-nvidia-2.6.27.21-78.2.41.fc9.x86_64-173.14.15-1.fc9.12.x86_64 conflicts with file from package kmod-nvidia-2.6.27.21-78.2.41.fc9.x86_64-173.14.15-1.fc9.5.x86_64

Error Summary

regards and waiting.

----------------------------------------------------------------------
 
Old 05-14-2009, 02:13 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
what software repos are you using ?
post the output of
Code:
yum repolist
if you have the "testing" or "rawhide" turned on then there will be conflicts
 
Old 05-14-2009, 11:23 PM   #7
seeker48
LQ Newbie
 
Registered: Mar 2009
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by John VV View Post
what software repos are you using ?
post the output of
Code:
yum repolist
if you have the "testing" or "rawhide" turned on then there will be conflicts

------------------------------------------------------------------

have done as suggested; results appended:-

repo id repo name status
adobe-linux-i386 Adobe Systems Incorporated enabled: 17
fedora Fedora 9 - x86_64 enabled: 12,444
livna rpm.livna.org for 9 - x86_64 enabled: 3
rpmfusion-free RPM Fusion for Fedora 9 - Free enabled: 0
rpmfusion-free-updates RPM Fusion for Fedora 9 - Free - Updat enabled: 787
rpmfusion-nonfree RPM Fusion for Fedora 9 - Nonfree enabled: 0
rpmfusion-nonfree-updates RPM Fusion for Fedora 9 - Nonfree - Up enabled: 385
updates Fedora 9 - x86_64 - Updates enabled: 14
updates-newkey Fedora 9 - x86_64 - Updates Newkey enabled: 8,216
repolist: 21,866

hope there are still some possible solutions.

best regards and many thanks.

Seeker48
 
Old 05-14-2009, 11:55 PM   #8
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
well nothing in the repo list looks wrong so my guess is a typo in the kmod-nvidia.rpm
seeing as fedora 9 will be hitting End Of Life in just over 1 month ( 5 to 6 weeks )
just uninstall the kmod-nvidia and install the nvidia.run driver
Code:
su -
yum erase kmod-nvidia*
seeing as you are using the " kmod-nvidia-2.6.27.21-78.2.41.fc9.x86_64-173.14.15-1.fc9" driver i take it you have a OLD GeForce 5 card ?
see
http://www.nvidia.com/Download/index.aspx?lang=en-us
http://www.nvidia.com/object/linux_d...173.14.18.html

also you will need to reinstall mesa GL
Code:
su -
yum reinstall  mesa-libGL mesa-libGLU mesa-libGL-devel mesa-libGLU-devel
----------- or -------------
Code:
yum reinstall  mesa-libGL mesa-libGLU 
yum install mesa-libGL-devel mesa-libGLU-devel

Last edited by John VV; 05-14-2009 at 11:56 PM.
 
Old 05-15-2009, 07:58 AM   #9
seeker48
LQ Newbie
 
Registered: Mar 2009
Posts: 17

Original Poster
Rep: Reputation: 0
repository conflict

Quote:
Originally Posted by John VV View Post
well nothing in the repo list looks wrong so my guess is a typo in the kmod-nvidia.rpm
seeing as fedora 9 will be hitting End Of Life in just over 1 month ( 5 to 6 weeks )
just uninstall the kmod-nvidia and install the nvidia.run driver
Code:
su -
yum erase kmod-nvidia*
seeing as you are using the " kmod-nvidia-2.6.27.21-78.2.41.fc9.x86_64-173.14.15-1.fc9" driver i take it you have a OLD GeForce 5 card ?
see
http://www.nvidia.com/Download/index.aspx?lang=en-us
http://www.nvidia.com/object/linux_d...173.14.18.html

also you will need to reinstall mesa GL
Code:
su -
yum reinstall  mesa-libGL mesa-libGLU mesa-libGL-devel mesa-libGLU-devel
----------- or -------------
Code:
yum reinstall  mesa-libGL mesa-libGLU 
yum install mesa-libGL-devel mesa-libGLU-devel
--------------------------------------------------------------------------
tried out as suggested; results appended:-
[moses@localhost ~]$ su
Password:
[root@localhost moses]# yum erase kmod-nvidida*
Loaded plugins: fastestmirror, fedorakmod, kernel-module, refresh-packagekit,
: refresh-updatesd
Setting up Remove Process
No Match for argument: kmod-nvidida*
Loading mirror speeds from cached hostfile
* livna: rpm.livna.org
* rpmfusion-nonfree-updates: mirror.web-ster.com
* fedora: fedora.iitm.ac.in
* rpmfusion-free-updates: mirror.web-ster.com
* rpmfusion-free: mirror.web-ster.com
* updates-newkey: fedora.iitm.ac.in
* updates: fedora.iitm.ac.in
* rpmfusion-nonfree: mirror.web-ster.com
livna | 2.4 kB 00:00
rpmfusion-nonfree-updates | 2.4 kB 00:00
fedora | 2.4 kB 00:00
rpmfusion-free-updates | 2.4 kB 00:00
rpmfusion-free | 951 B 00:00
adobe-linux-i386 | 951 B 00:00
adobe-linux-i386/primary | 11 kB 00:00
adobe-linux-i386 17/17
updates-newkey | 3.0 kB 00:00
updates-newkey/primary_db | 1.1 MB 01:49
http://fedora.iitm.ac.in/updates/9/x...ry.sqlite.bz2: [Errno 4] Socket Error: timed out
Trying other mirror.
updates-newkey/primary_db | 8.0 kB 00:00
http://ftp.cs.pu.edu.tw/Linux/Fedora...ry.sqlite.bz2: [Errno 4] Socket Error: timed out
Trying other mirror.
updates-newkey/primary_db | 5.3 MB 02:05
updates | 2.6 kB 00:00
rpmfusion-nonfree | 951 B 00:00
No Packages marked for removal
[root@localhost moses]# yum erase kmod-nvidida
Loaded plugins: fastestmirror, fedorakmod, kernel-module, refresh-packagekit,
: refresh-updatesd
Setting up Remove Process
No Match for argument: kmod-nvidida
Loading mirror speeds from cached hostfile
* livna: rpm.livna.org
* rpmfusion-nonfree-updates: mirror.web-ster.com
* fedora: fedora.iitm.ac.in
* rpmfusion-free-updates: mirror.web-ster.com
* rpmfusion-free: mirror.web-ster.com
* updates-newkey: fedora.iitm.ac.in
* updates: fedora.iitm.ac.in
* rpmfusion-nonfree: mirror.web-ster.com
No Packages marked for removal

really scratching my itchy head and my ole trigger finger itching to go for a full reinstall!

help!!!
 
Old 05-15-2009, 12:40 PM   #10
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
a typo
Quote:
[root@localhost moses]# yum erase kmod-nvidida
kmod-nvidia
 
Old 05-16-2009, 02:25 AM   #11
seeker48
LQ Newbie
 
Registered: Mar 2009
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by John VV View Post
a typo

kmod-nvidia
-----------------------------------------------------------------------
done and more; results:-

[root@localhost moses]# yum erase kmod-nvidia
Loaded plugins: fastestmirror, fedorakmod, kernel-module, refresh-packagekit,
: refresh-updatesd
Setting up Remove Process
No Match for argument: kmod-nvidia
Loading mirror speeds from cached hostfile
* livna: rpm.livna.org
* rpmfusion-nonfree-updates: mirror.web-ster.com
* fedora: fedora.iitm.ac.in
* rpmfusion-free-updates: mirror.web-ster.com
* rpmfusion-free: mirror.web-ster.com
* updates-newkey: fedora.iitm.ac.in
* updates: fedora.iitm.ac.in
* rpmfusion-nonfree: mirror.web-ster.com
livna | 2.4 kB 00:00
Package(s) kmod-nvidia available, but not installed.
No Packages marked for removal
[root@localhost moses]# install kmod-nvidia
install: missing destination file operand after `kmod-nvidia'
Try `install --help' for more information.
[root@localhost moses]#

waiting eagerly for more suggestions
 
Old 05-16-2009, 12:56 PM   #12
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
ok lets find the name of the kmod.
try
Code:
su -
rpm -qa | grep nvidia
then from the output uninstall the full name ( without the .rpm at the end )
Code:
su -
yum erase kmod-nvidia-2.6.27.21-78.2.41.fc9.x86_64-173.14.15-1
 
Old 05-16-2009, 11:14 PM   #13
seeker48
LQ Newbie
 
Registered: Mar 2009
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by John VV View Post
ok lets find the name of the kmod.
try
Code:
su -
rpm -qa | grep nvidia
then from the output uninstall the full name ( without the .rpm at the end )
Code:
su -
yum erase kmod-nvidia-2.6.27.21-78.2.41.fc9.x86_64-173.14.15-1
---------------------------------------------------------------------------
have done as suggested; no go still. results appended:-

[moses@localhost ~]$ su
Password:
[root@localhost moses]# rpm -qa | grep nvidia
xorg-x11-drv-nvidia-173.14.15-2.fc9.x86_64
kmod-nvidia-2.6.27.21-78.2.41.fc9.x86_64-173.14.15-1.fc9.5.x86_64
akmod-nvidia-173.14.15-1.fc9.5.x86_64
xorg-x11-drv-nvidia-libs-173.14.15-2.fc9.x86_64
[root@localhost moses]# yum erase kmod-nvidia-2.6.27.21-78.2.41.fc9.x86_64-173.14.15-1
Loaded plugins: fastestmirror, fedorakmod, kernel-module, refresh-packagekit,
: refresh-updatesd
Setting up Remove Process
No Match for argument: kmod-nvidia-2.6.27.21-78.2.41.fc9.x86_64-173.14.15-1
Loading mirror speeds from cached hostfile
* livna: rpm.livna.org
* rpmfusion-nonfree-updates: mirror.web-ster.com
* fedora: fedora.iitm.ac.in
* rpmfusion-free-updates: mirror.web-ster.com
* rpmfusion-free: mirror.web-ster.com
* updates-newkey: ftp.jaist.ac.jp
* updates: fedora.iitm.ac.in
* rpmfusion-nonfree: mirror.web-ster.com
livna | 2.4 kB 00:00
rpmfusion-nonfree-updates | 2.4 kB 00:00
fedora | 2.4 kB 00:00
rpmfusion-free-updates | 2.4 kB 00:00
rpmfusion-free | 951 B 00:00
adobe-linux-i386 | 951 B 00:00
updates-newkey | 3.0 kB 00:00
updates | 2.6 kB 00:00
rpmfusion-nonfree | 951 B 00:00
No Packages marked for removal
[root@localhost moses]#


Waiting for further advice. Many thanks for all the effort put in so far on my behalf. Really apprecicate your time and thought.

Very sincerely

moses
 
Old 05-17-2009, 12:37 AM   #14
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
ok you installed the akmod-nvidia-173.14.15-1
that would be the problem
Code:
su -
yum erase akmod-nvidia-173.14.15-1 kmod-nvidia-2.6.27.21-78.2.41
and if that dose not work then clean the yum and rpm data base and see if they are still listed as installed
Code:
su -
yum clean all 
rpm --rebuilddb
rpm -qa | grep nvidia
-- if still there then --
rpm -e akmod-nvidia-173.14.15-1.fc9.5.x86_64.rpm
rpm -e kmod-nvidia-2.6.27.21-78.2.41.fc9.x86_64-173.14.15-1.fc9.5.x86_64.rpm
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
yum Error: Cannot retrieve repository metadata (repomd.xml) for repository: base. glowe Linux - Newbie 8 01-13-2016 11:55 PM
Error: Cannot retrieve repository metadata (repomd.xml) for repository: atrpms. stioanid Linux - Software 3 12-13-2008 02:22 AM
Package Kit Error-- "Cannot retrieve repository metadata (repomd.xml) for repository" mbvpixies78 Linux - Newbie 11 08-22-2008 08:20 PM
Redhat 5.1 Yum Repository vs Fedora x.x Yum Repository lead2gold Linux - Software 1 05-22-2008 03:19 PM
Creating CVS repository: cvs [import aborted]: attempt to import the repository enemorales Linux - Software 3 10-15-2004 05:30 PM


All times are GMT -5. The time now is 10:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration