LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-29-2010, 12:16 PM   #1
Norwood
Member
 
Registered: Feb 2010
Location: A Smidge South O' Boston
Distribution: Debian
Posts: 41

Rep: Reputation: 15
Replaced Compiz over Metacity, some messages


I replaced Metacity with Compiz using:

Code:
compiz --replace&
and got my desired results (preferred window decorations etc). However, after the command I got the following:

Code:
******@**-*********-****-*****:~$ compiz --replace&
[1] 3725
******@**-*********-****-*****:~$ Checking for Xgl: not present. 
No whitelisted driver found
aborting and using fallback: /usr/bin/metacity 
Window manager warning: Log level 16: Unable to locate theme engine in module_path: "aurora",
Window manager warning: Log level 16: Unable to locate theme engine in module_path: "aurora",
Window manager warning: Log level 16: Unable to locate theme engine in module_path: "aurora",
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x1200016 (tilda)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
I did some google-fu and came up with nothing, most errors were not identical (which is to be understood, not everyone's environment is like mine).

So, I'm wondering if there's an easy fix to this or if someone might know what this is all referring to.
 
Old 03-29-2010, 01:32 PM   #2
bret381
Member
 
Registered: Nov 2009
Location: Alabama
Distribution: Arch x86_64
Posts: 650

Rep: Reputation: 78
is your video card supported?

This post may help:
http://www.linuxquestions.org/questi...ti-xgl-611540/http://www.linuxquestions.org/questi...ti-xgl-611540/

Last edited by bret381; 03-29-2010 at 01:34 PM. Reason: added link
 
Old 03-29-2010, 05:46 PM   #3
Bratmon
Member
 
Registered: Jul 2009
Location: 75.126.162.205:80
Distribution: Arch / Mint 17
Posts: 297
Blog Entries: 3

Rep: Reputation: 50
If it ain't broke, don't fix it.
 
Old 03-29-2010, 05:50 PM   #4
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
According to his output, though, it is broke. Based on what he posted, compiz isn't even started, and metacity is being launched instead. I'm not sure what his desired results are, but they presumably don't include running compiz.

Adam
 
Old 03-29-2010, 06:13 PM   #5
bret381
Member
 
Registered: Nov 2009
Location: Alabama
Distribution: Arch x86_64
Posts: 650

Rep: Reputation: 78
I think that the composite part of compiz is working... However emerald is not being loaded and it is defaulting back to metacity. But not real sure.
 
Old 03-29-2010, 06:20 PM   #6
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Code:
No whitelisted driver found
aborting and using fallback: /usr/bin/metacity
That's pretty clear. Compiz is not starting. Perhaps he's normally using a window manager other than metacity, but metacity is starting and has its own compositing enabled.

Adam
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Custom Keybindings in Gnome - Metacity Compiz (Desktop Effect) notorp Linux - Desktop 0 04-29-2009 10:03 AM
LXer: Nomad & Compiz++ To Merge Back Into Compiz LXer Syndicated Linux News 0 02-03-2009 10:20 PM
Skydome background doesn't work with compiz/gnome unless I use the compiz fusion icon The_Trooper Linux - Software 1 07-21-2008 02:08 PM
Why Metacity replaced Sawfish for gnome ? frenchn00b Linux - General 6 01-22-2008 08:41 PM
mdv 2007 compiz cube not displaying and pictures not memorised by gset-compiz Emmanuel_uk Mandriva 0 10-10-2006 03:33 AM


All times are GMT -5. The time now is 10:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration