LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   replace the existing dns servers with OPEN DNS servers in fedora 13 (http://www.linuxquestions.org/questions/linux-newbie-8/replace-the-existing-dns-servers-with-open-dns-servers-in-fedora-13-a-870455/)

z99 03-23-2011 08:00 AM

replace the existing dns servers with OPEN DNS servers in fedora 13
 
hi,
i heard that open dns is faster,so,i try to replace my dns with open dns servers,
i use my mobile phone to connect to the internet,
that's what i've done so far according to this site
http://jbowes.wordpress.com/?s=dns
Copy /usr/share/doc/dhclient-$VERSION/dhclient.conf.sample to /etc/dhclient.conf
and then edit the dhclient.conf file from /etc and replace this line
Code:

prepend domain-name-servers 127.0.0.1;
with
Code:

prepend domain-name-servers 208.67.222.222,208.67.220.220;
this is how my dhclient.conf looks like:

Code:

send host-name "andare.fugue.com";
send dhcp-client-identifier 1:0:a0:24:ab:fb:9c;
send dhcp-lease-time 3600;
supersede domain-search "fugue.com home.vix.com";
prepend domain-name-servers 208.67.222.222,208.67.220.220;
request subnet-mask, broadcast-address, time-offset, routers,
        domain-search, domain-name, domain-name-servers, host-name;
require subnet-mask, domain-name-servers;
timeout 60;
retry 60;
reboot 10;
select-timeout 5;
initial-interval 2;
script "/etc/dhclient-script";
media "-link0 -link1 -link2", "link0 link1";
reject 192.33.137.209;

alias {
  interface "ep0";
  fixed-address 192.5.5.213;
  option subnet-mask 255.255.255.255;
}

lease {
  interface "ep0";
  fixed-address 192.33.137.200;
  medium "link0 link1";
  option host-name "andare.swiftmedia.com";
  option subnet-mask 255.255.255.0;
  option broadcast-address 192.33.137.255;
  option routers 192.33.137.250;
  option domain-name-servers 127.0.0.1;
  renew 2 2000/1/12 00:00:01;
  rebind 2 2000/1/12 00:00:01;
  expire 2 2000/1/12 00:00:01;
}

by right clicking on network manager and click on connection information i still see the old dns servers ip,
i think these settings aren't applied on interface ppp0,
how can i do that,
thanks in advance

savona 03-23-2011 08:39 AM

I am not sure if I understand your question correctly but I will try...

If you want to use opendns for your system to resolve dns names put them in /etc/resolv.conf


here is an example of resolv.conf:


# cat /etc/resolv.conf
# replace IP address below with opendns
nameserver 192.168.1.2
nameserver 192.168.1.3

z99 03-23-2011 09:10 AM

thanks savona,
i edit the resolv.conf and it works,i mean,the site can check if we are using Opendns or not,and I've got: Success! You're now using OpenDNS,
but they said i have to edit dhclient.conf,but it was not needed,it could be done just by editing resolv.conf,
why should we use dhclient.conf when it could be done with resolv.conf?
and what is it for (dhclient.conf) ?
thanks

savona 03-23-2011 09:29 AM

dhclient.conf is the client app that gets an ip address from your dhcp server.

Now here is a possible problem. Are these machines using DHCP?

If so the DNS servers might change next time you renew your IP address, because DNS servers are usually handed out by the DHCP server.

If this is the case you have a few options.


1) Change your DNS server to give out opendns DNS servers.

2) Hard code your IP address in your linux machines.

3) Turn off network manager so it doesnt overwrite your /etc/resolv.conf file.


All times are GMT -5. The time now is 08:39 PM.