LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-26-2007, 11:39 AM   #1
almon
Member
 
Registered: May 2007
Location: india
Distribution: ubuntu7
Posts: 73

Rep: Reputation: 15
repairing ntfs file system


I have lost windows as usual.....I had mounted ntfs partitions with entries like that
in fstab:
/dev/sda2 /media/alekh1 ntfs-3g default 0 0
now the ntfs-3g is not mounting ntfs drives(oh!!i have too many!!)
I even added the option
/dev/sda2 /media/alekh1 ntfs-3g default 0 0,force 0 0
but it also didnt worked.....
if i do it manually it give error like this
Volume is scheduled for check. Please boot into Windows TWICE, or
use the 'force' mount option. For example type on the command line:

mount -t ntfs-3g /dev/sda10 /dev/alekh1 -o force

Or add the option to the relevant row in the /etc/fstab file:

/dev/sda10 /dev/alekh1 ntfs-3g defaults,force 0 0
what should i do???
 
Old 06-26-2007, 06:13 PM   #2
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
Quote:
Originally Posted by almon
Volume is scheduled for check. Please boot into Windows TWICE,
Usually, when you get a message like this, booting up Windows twice in a row does the trick. You can also run scandisk in Windows on the partitions giving you problems by right clicking on the drive's icon and selecting either "Properties" or "Maintenance" or similar, look for "Tools". Keep your line in /etc/fstab as quoted below, this works great every time I use it like this:
Quote:
/dev/sda2 /media/alekh1 ntfs-3g default 0 0
Some distributions like Mandriva, I leave the options the way they were and just add the (-3g) after ntfs, and remove (ro), below is my /etc/fstab line in both Mandriva and Debian, but the above example works great also:
Code:
/dev/sda3 /data ntfs-3g umask=0,nls=utf8, 0 0

Last edited by Junior Hacker; 06-26-2007 at 06:17 PM.
 
Old 06-27-2007, 08:46 AM   #3
almon
Member
 
Registered: May 2007
Location: india
Distribution: ubuntu7
Posts: 73

Original Poster
Rep: Reputation: 15
But isnt there a way to clean my ntfs system without booting windows(I have lost my windows!!!)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I cannot do fsck. Why is that? Repairing Linux ext2 or ext3 file system LinuxCrazy Linux - General 5 06-18-2007 05:01 PM
How to read .chm file in fedora, can't mount ntfs file system ishti_du Linux - Newbie 12 03-06-2007 04:27 AM
LXer: Repairing ReiserFS file system with reiserfsck LXer Syndicated Linux News 0 07-15-2006 02:03 AM
Writing to an NTFS volume using captive-ntfs (repairing boot.ini) macskeeball Linux - General 3 02-06-2005 10:28 PM
NTFS file system ilengna Linux - Hardware 8 10-08-2003 06:32 PM


All times are GMT -5. The time now is 11:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration