LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-12-2006, 01:37 PM   #1
Timur
LQ Newbie
 
Registered: Oct 2006
Location: Samarkand, Uzbekistan and Oklahoma, USA
Distribution: Debian Sarge
Posts: 29

Rep: Reputation: 15
removing russian language support from the shell


Hi, I have a problem.
I installed debian sarge and installed russian language support (don't remember what I chose - must have been something during the installation phase). Here is what bothers me. When I press ctrl - instead of russian it just types some weard characters (not russian letters). How to I

a) remove russian language from the shell
or at least
b) disable right ctrl button for switching languges. i want it to function as a regular ctrl button.
 
Old 10-13-2006, 06:45 AM   #2
Vitalie Ciubotaru
Member
 
Registered: Dec 2005
Location: Osaka, Japan
Distribution: Ubuntu Trinity
Posts: 153

Rep: Reputation: 30
Never dealt with Sarge, but still...
Character set switching is taken care of by the /etc/X11/xorg.conf (or something like /etc/X11/X86config).
You will find something like
Code:
Section "InputDevice"
    Identifier          "Keyboard0"
    Driver              "Keyboard"
    Option "XkbModel"   "pc105"
    Option "XkbLayout"  "en_US,ru"
    Option "XkbOptions" "grp:switch,grp:ctrl_toggle,grp_led:scroll"
EndSection
You can comment out the
Code:
# Option "XkbOptions" "grp:switch,grp:ctrl_toggle,grp_led:scroll"
line
 
Old 10-16-2006, 03:33 PM   #3
Timur
LQ Newbie
 
Registered: Oct 2006
Location: Samarkand, Uzbekistan and Oklahoma, USA
Distribution: Debian Sarge
Posts: 29

Original Poster
Rep: Reputation: 15
This didn't work for me. Below are the files that I have. You can notice that there is no such line there:

This is one of the files it has:


# XF86Config-4 (XFree86 X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# This file is automatically updated on xserver-xfree86 package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xfree86
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
# cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
# md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum
# dpkg-reconfigure xserver-xfree86

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "vesa"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 28-50
VertRefresh 43-75
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 16
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection



This is the second file. (Don't know which one my system is using :-(. I think that it uses the lower one.

# XF86Config-4 (XFree86 X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# This file is automatically updated on xserver-xfree86 package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xfree86
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
# cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
# md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum
# dpkg-reconfigure xserver-xfree86

Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "vesa"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 28-49
VertRefresh 43-72
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 16
SubSection "Display"
Depth 1
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection
 
Old 10-16-2006, 03:34 PM   #4
Timur
LQ Newbie
 
Registered: Oct 2006
Location: Samarkand, Uzbekistan and Oklahoma, USA
Distribution: Debian Sarge
Posts: 29

Original Poster
Rep: Reputation: 15
Any more suggestions?
 
Old 10-18-2006, 05:30 PM   #5
Vitalie Ciubotaru
Member
 
Registered: Dec 2005
Location: Osaka, Japan
Distribution: Ubuntu Trinity
Posts: 153

Rep: Reputation: 30
Hey, Timur-Khan!
Try changing
Code:
    Option "XkbLayout"  "us"
to
Code:
    Option "XkbLayout"  "us,ru"
This should add Russian keyboard support (is it what you wanted?)

Good luck!!!
 
Old 10-19-2006, 06:07 PM   #6
Timur
LQ Newbie
 
Registered: Oct 2006
Location: Samarkand, Uzbekistan and Oklahoma, USA
Distribution: Debian Sarge
Posts: 29

Original Poster
Rep: Reputation: 15
Didn't work. I changed it in both files, just in one file, commented out this line:
FontPath "/usr/lib/X11/fonts/cyrillic"
Didn't work. Another question. I may be wrong, but doesn't this file influenses X server? I don't need it for X server. I need it for the shell (alt+F1, alt+f2 etc...)
 
Old 10-20-2006, 10:53 AM   #7
Vitalie Ciubotaru
Member
 
Registered: Dec 2005
Location: Osaka, Japan
Distribution: Ubuntu Trinity
Posts: 153

Rep: Reputation: 30
I'm terribly sorry for misleading you, Timur.
Of course, /etc/X11/xorg.conf is a configuration file for the X11 server.
So, you want to disable/fix Russian keyboard support in your shell.
Well, I never needed to type anything non-Latin in the shell, so I just searched this site and found this. This may also be helpful if read carefully and adapted to your case.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
language support Murdock1979 Linux - Software 2 01-19-2006 03:24 PM
Russian language support KopiX Linux - General 3 10-17-2005 12:03 AM
Russian language in non-KDE WMs BaltikaTroika Linux - Newbie 0 07-24-2005 06:13 PM
removing language support to clear space paranoid times Linux - Software 0 04-16-2005 12:46 AM
language support UNIX Linux - Newbie 1 12-07-2002 07:32 AM


All times are GMT -5. The time now is 08:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration