LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-28-2015, 08:03 PM   #1
fiddyschmitt
LQ Newbie
 
Registered: Dec 2015
Posts: 5

Rep: Reputation: Disabled
Remove the hostname in the title bar when running a GUI over X


From a RHEL 5 machine, I'm connecting to another using the following:

Code:
ssh -X user@remotemachine
I then run a GUI application. In the title bar of each window, the hostname is displayed. eg.

Code:
Calculator <@remotemachine>
Is there a way to remove that?

I've tried adding "-nohostintitle" to a bunch of .conf files but have had no luck
 
Old 12-28-2015, 11:25 PM   #2
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,599

Rep: Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241
Interesting question. Unfortunately, I don't have a solution though.

The titles you are referring to appear to be handled by the window manager, which only uses the application titles as a "suggestion". The actual title supplied is the "Calculator" part - and I've been looking for which window manager uses the <user@machine> (or <@machine>) and that part may be generated by the GUI toolkit used by the application, and not the application itself.

One thing I have found is that at least some applications use the environment variable "HOSTNAME" and "USER", and if that is not available, it uses the system hostname instead (xterm and mate-terminal do this even for local terminal windows).
 
Old 12-29-2015, 02:41 PM   #3
ccj4467
LQ Newbie
 
Registered: Jan 2009
Posts: 15

Rep: Reputation: 2
If your shell on the remote machine is bash then the title is being set by bash. There is an environment variable: PROMPT_COMMAND that sets the title, this is set in /etc/bashrc.

In your local .bashrc you can set that variable to a null string.

However the title will still show yourlocalid@localhost.

Also be sure to export the variable

Last edited by ccj4467; 12-29-2015 at 02:42 PM.
 
Old 12-29-2015, 03:09 PM   #4
fiddyschmitt
LQ Newbie
 
Registered: Dec 2015
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by jpollard View Post
Interesting question. Unfortunately, I don't have a solution though.

The titles you are referring to appear to be handled by the window manager, which only uses the application titles as a "suggestion". The actual title supplied is the "Calculator" part - and I've been looking for which window manager uses the <user@machine> (or <@machine>) and that part may be generated by the GUI toolkit used by the application, and not the application itself.

One thing I have found is that at least some applications use the environment variable "HOSTNAME" and "USER", and if that is not available, it uses the system hostname instead (xterm and mate-terminal do this even for local terminal windows).
Thanks jpollard. Yes it must be window manager because when I run those same applications locally, they don't have the <@machine> in the title. Interesting about the HOSTNAME environment variables. I'll see if they make a difference.

Cheers,
Fidel
 
Old 12-29-2015, 03:11 PM   #5
fiddyschmitt
LQ Newbie
 
Registered: Dec 2015
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ccj4467 View Post
If your shell on the remote machine is bash then the title is being set by bash. There is an environment variable: PROMPT_COMMAND that sets the title, this is set in /etc/bashrc.

In your local .bashrc you can set that variable to a null string.

However the title will still show yourlocalid@localhost.

Also be sure to export the variable
Thanks cc. It's not the shell windows I'm concerned with, it's GUI applications running on the remote machine but being displayed on the local machine (over X).

Cheers,
Fidel
 
  


Reply

Tags
rhel 5, x-server, xserver


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
metacity title bar scarrz Linux - Software 0 12-15-2015 02:44 PM
how to remove firefox title bar ? dEnDrOn Linux - General 7 10-01-2015 05:38 PM
Remove App Title bar in GNOME 3 bgalakazam Linux - Desktop 1 06-01-2011 07:53 AM
remove active title bar jdabler Red Hat 1 05-14-2008 12:49 PM
Remove title bar simao20 Linux - Newbie 3 04-16-2004 12:30 AM


All times are GMT -5. The time now is 06:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration