LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-15-2013, 11:02 AM   #1
NotionCommotion
Member
 
Registered: Aug 2012
Posts: 709

Rep: Reputation: Disabled
Remove package which has dependences


I wish to remove a package, so I do the following:
Code:
[root@centosBox src]# rpm -e mysql-libs
error: Failed dependencies:
	libmysqlclient.so.16()(64bit) is needed by (installed) postfix-2:2.6.6-2.2.el6_1.x86_64
	libmysqlclient.so.16(libmysqlclient_16)(64bit) is needed by (installed) postfix-2:2.6.6-2.2.el6_1.x86_64
	mysql-libs is needed by (installed) postfix-2:2.6.6-2.2.el6_1.x86_64
[root@centosBox src]#
To get around it, I know I can use the --nodeps option, but is this too heavyhanded and not good practice? Is there a better way?

PS. The reason I am doing this is that I wish to install a new version of MySQL, but keep getting:
Code:
	file /usr/share/mysql/czech/errmsg.sys from install of MySQL-server-5.6.12-1.el6.x86_64 conflicts with file from package mysql-libs-5.1.69-1.el6_4.x86_64
Maybe I can just update the lib instead of removing it?

Thanks
 
Old 06-15-2013, 02:36 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,889

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Use yum to upgrade to the version number you want.

yum upgrade mysql-14.14

Check the dependencies list before hitting Y. You might need to add other packages to the upgrade list
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to download the package with dependences ramesh14 Linux - Software 2 06-16-2011 04:32 AM
[SOLVED] won't let me install a package or remove a package archie101 Linux - Newbie 5 05-09-2011 04:52 PM
Remove package ust Linux - Software 13 05-29-2009 05:27 AM
How to remove a package riba43 SUSE / openSUSE 12 07-04-2007 11:52 AM
remove package spidna Debian 3 02-26-2005 06:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration