LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-04-2008, 09:30 PM   #1
tombo465
LQ Newbie
 
Registered: Oct 2008
Location: Warren , Michigan
Distribution: Ubuntu 8.04
Posts: 9

Rep: Reputation: 0
Question remove device and associated files


Hello I'm using ubuntu 8.04 and recently started having problems with my mp3 player. I've made sure that I have proper permissions on both the device and the music. Also mtab showed that the mp3 player owner was root (1000) and I changed it to 1001 which is me.Still cannot copy music to the device ( I/O error). How do I remove the device and the associated files,and let ubuntu reinstall the device.The device name is /dev/sdd and the mount point is /media/siren. I have tried the rm command to remove sdd which it did remove but still didn't fix the problem. Thats where I am Please Help !
 
Old 10-05-2008, 01:19 PM   #2
arckane
Member
 
Registered: Sep 2005
Location: UK
Distribution: Gentoo/Debian/Ubuntu
Posts: 307

Rep: Reputation: 38
hi

Are you in all the correct groups for handling attached hardware? Check the /etc/group file and add yourself to ones which relate to hardware as well as the DISKS group.
 
Old 10-05-2008, 09:08 PM   #3
tombo465
LQ Newbie
 
Registered: Oct 2008
Location: Warren , Michigan
Distribution: Ubuntu 8.04
Posts: 9

Original Poster
Rep: Reputation: 0
no that didn't fix it. the only files that i knew to change were the tty file and a file marked disk. Please let me know if there are others i need to add myself to. thank you!
 
Old 10-06-2008, 10:04 AM   #4
arckane
Member
 
Registered: Sep 2005
Location: UK
Distribution: Gentoo/Debian/Ubuntu
Posts: 307

Rep: Reputation: 38
My groups:

Code:
adm:x:4:arckane
disk:x:6:arckane
dialout:x:20:arckane
fax:x:21:arckane
cdrom:x:24:arckane
floppy:x:25:arckane
tape:x:26:arckane
sudo:x:27:arckane
audio:x:29:arckane
dip:x:30:arckane
video:x:44:arckane
plugdev:x:46:arckane
scanner:x:104:hplip,arckane
netdev:x:110:arckane
lpadmin:x:111:arckane
powerdev:x:113:arckane
Plugdev is the one I always needed to be in for removable devices.
 
Old 10-06-2008, 06:37 PM   #5
tombo465
LQ Newbie
 
Registered: Oct 2008
Location: Warren , Michigan
Distribution: Ubuntu 8.04
Posts: 9

Original Poster
Rep: Reputation: 0
I appreciate your time but I think I really screwed up the player with the rm command.I was trying to remove the player and files to let the machine re-recognize it, but there went all the music on it in the blink of an eye. Oh well I've got it all backed-up on dvd's and on the computer because i like messing around with stuff that i really know nothing about.I did put my name by all the things you suggested but i think its to late. probably going to reload the o/s, but i will check back before i do just in case you've seen this and have more things i can try. Man there sure is a lot to learn,sometimes it's fun but sometimes it,s aggravating.
Thanks for your time I appreciate it .I at least got the device to mount but still get Input/Output error when I try to add music.

Last edited by tombo465; 10-06-2008 at 11:25 PM. Reason: add more info
 
Old 10-06-2008, 11:41 PM   #6
tombo465
LQ Newbie
 
Registered: Oct 2008
Location: Warren , Michigan
Distribution: Ubuntu 8.04
Posts: 9

Original Poster
Rep: Reputation: 0
[ 2944.869077] sd 4:0:0:0: [sdd] READ CAPACITY failed
[ 2944.869102] sd 4:0:0:0: [sdd] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK,SUGGEST_OK
[ 2944.869117] sd 4:0:0:0: [sdd] Sense not available.
[ 2944.947995] usb 1-2.2: reset full speed USB device using uhci_hcd and address 5
[ 2945.159898] usb 1-2.2: reset full speed USB device using uhci_hcd and address 5
[ 2953.770764] sd 4:0:0:0: [sdd] Write Protect is off
[ 2953.770793] sd 4:0:0:0: [sdd] Mode Sense: 00 00 00 00
[ 2953.770803] sd 4:0:0:0: [sdd] Assuming drive cache: write through
[ 2953.849647] usb 1-2.2: reset full speed USB device using uhci_hcd and address 5
[ 2954.061571] usb 1-2.2: reset full speed USB device using uhci_hcd and address I ran dmesg and this keeps repeating over and over , so many times I can't even scroll to the top. I am unclear about device names and mount points. the device name is sdd1 is sdd the same. This is driven me mad . Thank You!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to safely remove device? shame VectorLinux 6 09-06-2006 09:23 PM
How to remove ppp0 device smkamene Linux - Hardware 0 12-19-2005 06:00 PM
Is it safe to remove this device? dlublink Linux - General 1 01-22-2005 11:22 PM
how can i remove a device? ligang_feng Linux - Hardware 4 10-27-2004 11:07 PM
how to remove device icons? l32 Linux - Newbie 2 07-02-2004 12:56 PM


All times are GMT -5. The time now is 03:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration