LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-06-2007, 06:26 PM   #16
gallwapa
LQ Newbie
 
Registered: Oct 2005
Distribution: RHEL, SLE
Posts: 28

Original Poster
Rep: Reputation: 15

Thanks for the link. I am slowly trying to catch up on redhat. Until now I've been focusing on SLES - as we've got 3 of them and only the one RHEL server. Additionally, having 65 netware servers and 29 windows servers makes it a bit hard to squeeze in time here and there. I appreciate all the help that has been offered so far.

Here is the error after running up2date from a ssh session

Code:
[root@server root]# gui

New 'server:4 (root)' desktop is server:4

Starting applications specified in /root/.vnc/xstartup
Log file is /root/.vnc/server:4.log


VNC viewer for X version 4.0b4 - built Sep  6 2004 13:13:55
Copyright (C) 2002-2003 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
vncviewer: unable to open display ""
Killing Xvnc process ID 4932
[root@server root]#
 
Old 02-06-2007, 06:43 PM   #17
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
Your X display variable is not being set, so you cannot run any X applications. Did you remember to tunnel X sessions in your Xwin32 client running as ssh?
 
Old 02-07-2007, 10:05 AM   #18
gallwapa
LQ Newbie
 
Registered: Oct 2005
Distribution: RHEL, SLE
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by macemoneta
Your X display variable is not being set, so you cannot run any X applications. Did you remember to tunnel X sessions in your Xwin32 client running as ssh?
No, but I tried this morning and got a different error now.

Code:
[root@server root]# gui

New 'server:4 (root)' desktop is server:4

Starting applications specified in /root/.vnc/xstartup
Log file is /root/.vnc/server:4.log


VNC viewer for X version 4.0b4 - built Sep  6 2004 13:13:55
Copyright (C) 2002-2003 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
X connection to localhost:10.0 broken (explicit kill or server shutdown).
Killing Xvnc process ID 12983

Last edited by gallwapa; 02-07-2007 at 10:41 AM.
 
Old 02-07-2007, 11:32 AM   #19
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
You need to sort out using X first (are you sure you are running the X server on your Windows machine?). Just try getting an xterm window to work properly. Once that's working, this script, and any other X application will work.
 
Old 02-07-2007, 12:20 PM   #20
gallwapa
LQ Newbie
 
Registered: Oct 2005
Distribution: RHEL, SLE
Posts: 28

Original Poster
Rep: Reputation: 15
Oh wonderful. I loaded up Xwin32 then ran the script and the screen displays. Now all I have to figure out is why the keyboard isn't working inside the Xwin32 application. Thank you so much!

Also, when logging into the X session it asks for "password" again - even though I've already authenticated via key for the ssh session. Did I miss a step?

Last edited by gallwapa; 02-07-2007 at 12:51 PM.
 
Old 02-07-2007, 05:06 PM   #21
wpn146
Member
 
Registered: Jan 2005
Distribution: Solaris, Linux Fedora Core 6
Posts: 170

Rep: Reputation: 30
I am not sure you want vnc. Vnc is not the most secure thing to have and many corporations do not permit it on their systems.

What you really need is:

1. The remote machine just doing its own thing at runlevel 3, but be sure the /etc/ssh/sshd_config file is enabled for forwarding "X". (Perhaps this is the reason your Xwin32 is not working?)

2. An "X" server running in the background on your desktop. I think this is what your Xwin32 is for, but I am not familiar with that product. It can be "exceed" ($$$) or Cygwin (free).

3. A client on your desktop to ssh to your target machine. This can be "putty" (free), or a Cygwin ssh inside an xterm. Exceed also provides a client, but I find it clumsy to set up.
 
Old 02-07-2007, 05:24 PM   #22
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
Quote:
Originally Posted by wpn146
I am not sure you want vnc. Vnc is not the most secure thing to have and many corporations do not permit it on their systems.
VNC is being used in the above example only over an SSH protected link. It is as highly secure as remote access can be with current technology. In fact the VNC protocol exists only on the server side; what is transported over SSH is X (no VNC client required on the client side).

Last edited by macemoneta; 02-07-2007 at 05:28 PM.
 
Old 02-08-2007, 05:36 PM   #23
gallwapa
LQ Newbie
 
Registered: Oct 2005
Distribution: RHEL, SLE
Posts: 28

Original Poster
Rep: Reputation: 15
That being said, any idea why the keyboard inside the X session isn't working?

The mouse works and I can click on stuff, but typing is not functional.
 
Old 02-08-2007, 06:01 PM   #24
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
That will be a function of the XWin32 application. I'm not familiar with its operation or configuration. However, the vendor's website had this note:

Quote:
If you launch X-Win32 and notice that your keyboard is not working please do the following.

1. Shut down X-Win32
2. Open X-Config
3. Click On the Input Tab
4. Check the Emulate Numlock box
5. Press Apply
6. Restart X-Win32
If that doesn't work, I suggest you contact the vendor for support.
 
Old 02-08-2007, 06:04 PM   #25
gallwapa
LQ Newbie
 
Registered: Oct 2005
Distribution: RHEL, SLE
Posts: 28

Original Poster
Rep: Reputation: 15
Ok - Great. I'll try some settings - I appreciate all the help, it has been very, very accurate and on target. You rock!
 
Old 02-12-2007, 11:06 AM   #26
gallwapa
LQ Newbie
 
Registered: Oct 2005
Distribution: RHEL, SLE
Posts: 28

Original Poster
Rep: Reputation: 15
A follow up on this - Our version of Xwin32 (5 something) didn't support the keyboard in this mode for some reason. The newest version does, but we decided to go with Cygwin instead.

Thanks again for all the help. I'll see if I can get it working on our SuSE Servers now :-)
 
Old 02-12-2007, 01:18 PM   #27
gallwapa
LQ Newbie
 
Registered: Oct 2005
Distribution: RHEL, SLE
Posts: 28

Original Poster
Rep: Reputation: 15
Well something still isnt right. I have this set up in the following way

authorized_keys configured
Cygwin Xserver running
Paegeant running
Load Putty
Load preset for x forwarding to this server. Login as "root" by key based auth. automatically run "gui" which has been placed in /usr/bin/local
"Open" the connection, the X session doesnt start but the putty window shows this:


Code:
Using username "root".
Authenticating with public key "rsa-key-20070205" from agent

vncserver: couldn't find "xauth" on your PATH.

VNC viewer for X version 4.0b4 - built Sep  6 2004 13:13:55
Copyright (C) 2002-2003 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
X connection to localhost:10.0 broken (explicit kill or server shutdown).
vncserver: couldn't find "xauth" on your PATH.
Yet repeating the same process, only without the "Remote command" filled in, the login goes well. Then when I am presented at the shell I type "gui" and it loads just fine.

Any ideas? (Still on the RHEL4 here)
 
Old 02-12-2007, 01:27 PM   #28
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
Apparently, running with a remote command does not run as a login shell, and as a result your environment variables are not configured (in particular, your PATH). I suggest that you add the PATH to your 'gui' shell script. To find out what it needs to be, login and:

echo $PATH

Then add the result to the top of your gui script.
 
Old 02-12-2007, 03:35 PM   #29
gallwapa
LQ Newbie
 
Registered: Oct 2005
Distribution: RHEL, SLE
Posts: 28

Original Poster
Rep: Reputation: 15
Macemoneta, you are again correct sir.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 10.2 Remote Desktop Console Session JET-33 SUSE / openSUSE 2 03-14-2009 03:35 PM
Default session in gdm Komakino Linux - Software 3 09-04-2004 07:37 AM
gdm overwrites /etc/gdm/Session/fluxbox _flaab_ Mandriva 0 12-21-2003 10:58 AM
GDM Session in 2.4 arthurzap Linux - Software 0 10-01-2003 08:06 AM
add a session to Session of gdm freenet Linux - Software 0 08-07-2003 05:21 AM


All times are GMT -5. The time now is 12:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration