LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-08-2005, 02:29 PM   #1
cliff76
Member
 
Registered: Feb 2005
Location: PA
Distribution: Fedora Core 3
Posts: 48

Rep: Reputation: 15
Remote X apps


I am brand new to Linux but I was reading the Redhat 7 Bible and noticed a section on remote X displays. Apparently you can remote login to another machine and have the display show on your screen using the DISPLAY variable in the remote session. Well I tried and it didn't work. Basically I tried the following:
[ccc@ccc ~]xhost +otherpc
otherpc being added to access control list
[ccc@ccc ~]ssh me@otherpc

[me@otherpc]export DISPLAY=ccc:0
[me@otherpc]export DISPLAY=ccc:0
Error: Can't open display:ccc:0

What gives? Am I doing something wrong or is remote X nolonger supported? Do the Window managers need to be the same accross machines? Please Advise.

Cliff
 
Old 02-08-2005, 02:34 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Can otherpc ping ccc by name? If not,
add it to its /etc/hosts ... if it can, try
export DISPLAY=ccc:0.0

That said you could just as well set-up
ssh to do X forwarding :}


Cheers,
Tink
 
Old 02-08-2005, 03:14 PM   #3
cliff76
Member
 
Registered: Feb 2005
Location: PA
Distribution: Fedora Core 3
Posts: 48

Original Poster
Rep: Reputation: 15
No the remote machine cannot resolve my machine name. That's not the issue though. Should have mentioned that I was using ip addresses instead of names.
 
Old 02-08-2005, 03:23 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
What about the modified DISPLAY variable, tried that?
If that's not it, either ... is ccc behind a firewall that
only allows established connections?


Cheers,
Tink
 
Old 02-08-2005, 04:05 PM   #5
cliff76
Member
 
Registered: Feb 2005
Location: PA
Distribution: Fedora Core 3
Posts: 48

Original Poster
Rep: Reputation: 15
modified variable doesn't work

Tink,

I used

[newaredev@optimus newaredev]$ export DISPLAY=192.168.99.15:0.0
[newaredev@optimus newaredev]$ xclock
Error: Can't open display: 192.168.99.15:0.0

this was all after xhost +192.168.99.125. I'm not behind a firewall of any sort (unless Fedora enables a firewall by default but I'm not sure how to check that off hand). Do I have to run xhost on the remote mahcine or on my machine? I've been running it on my machine to allow the remote machine to connect as that seems natural (also it's how the book said to do it). Let me know if I'm doing anything backwards.
 
Old 02-09-2005, 09:33 AM   #6
cliff76
Member
 
Registered: Feb 2005
Location: PA
Distribution: Fedora Core 3
Posts: 48

Original Poster
Rep: Reputation: 15
I looked into ssh X fowarding and I 'm not sure how to do that either. I'm not even sure if that's what I want to do.
 
Old 02-09-2005, 04:29 PM   #7
Lleb_KCir
Senior Member
 
Registered: Nov 2003
Location: Orlando FL
Distribution: Debian
Posts: 1,765

Rep: Reputation: 45
ssh -X is rather simple:

ssh -X user@IP program_path_to_run
passwordenter p/w when prompted)
poof there it is.

for this IIRC you have to have x11 forwarding configured, and i have no clue how to set it up, it is enabled by default in debian with KDE3.x or better.
 
Old 03-24-2005, 01:31 PM   #8
cliff76
Member
 
Registered: Feb 2005
Location: PA
Distribution: Fedora Core 3
Posts: 48

Original Poster
Rep: Reputation: 15
Sorry it took so long for me to get back to this post. I tried ssh -X and it works like a charm! Thanx!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Question about running remote apps julz_51 Linux - Software 2 09-20-2005 06:17 PM
xhost + on ubuntu (to show remote x apps) tunasashimi Ubuntu 2 07-07-2005 07:18 AM
Remote X apps clergykid Linux - Newbie 2 10-09-2004 11:47 PM
PPTP and remote X apps clergykid Linux - Newbie 2 10-09-2004 11:46 PM
focus in remote x apps bhu73 *BSD 1 05-08-2002 11:41 AM


All times are GMT -5. The time now is 06:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration