LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-20-2006, 05:21 PM   #1
ddu_
Member
 
Registered: Dec 2004
Distribution: Slackware
Posts: 114

Rep: Reputation: 16
Remote Windows Shares


Hey all!

Just wanted your opinion on what the easiest way is to mount a windows share on my lan.

I've got a Slackware 10.2 box and a windows2000 box on my home network. The windows2000 box has 3 hard drives in it totaling 400GB. The D and E drives are where the data is stored (mp3s, etc). I'd like to access to the shares from my linux box.

Thanks guys!
 
Old 02-20-2006, 06:34 PM   #2
exvor
Senior Member
 
Registered: Jul 2004
Location: Phoenix, Arizona
Distribution: Gentoo, LFS, Debian,Ubuntu
Posts: 1,537

Rep: Reputation: 87
Easiest way to access them is to know the share name.

you can do this by going to windows go to run and type // and the ip of the box you want.

for my example i will say i have computer 192.168.0.5 with a share called example.

in linux i would go to a command prompt and type


smbmount //192.168.0.5/example /mnt/network

you may be asked for a password if you have the old shareing methood enabled in windows you can just hit enter if not then it gets more complicated.

/mnt/netowrk : can be replace by where you wanna mount the share.


read smbmounts man page for more info.
 
Old 02-20-2006, 08:58 PM   #3
ddu_
Member
 
Registered: Dec 2004
Distribution: Slackware
Posts: 114

Original Poster
Rep: Reputation: 16
looks like it connects to the machine, but then I get this:

14826: session request to 192.168.1.110 failed (Called name not present)
14826: session request to 192 failed (Called name not present)
Password:
14826: session setup failed: ERRDOS - ERRnoaccess (Access denied.)

I've tried the admin password, with no luck. I've also tried no password as you suggested with the same thing.
 
Old 02-21-2006, 03:06 AM   #4
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
It says that the share name your calling to isn't defined on your Windows box.
Did you share your D: and E: drives? Or at least the folders with data that you want to access on Linux?
In Win Explorer, click right on the drive/folder and select the "sharing" tab. On this tab, make sure
that the folder/drive is being shared and give the share a name you can easily recognize.
You can also use the default sharenames (D$ and E$ for the drives) if you want.

For instance, let's say you want to share the E: drive and it contains some mp3s.
Then share the drive and give it a name like win_mp3 for instance.

On Linux, you can then use "smbmount" to mount
//win-box/win_mp3 on any directory on your filesystem.
The directory where you want to mount the win_mp3 share should be an empty one and it must exist before
you call smbmount.
 
Old 02-21-2006, 02:06 PM   #5
exvor
Senior Member
 
Registered: Jul 2004
Location: Phoenix, Arizona
Distribution: Gentoo, LFS, Debian,Ubuntu
Posts: 1,537

Rep: Reputation: 87
On windows xp and windows 2000 shared (XP only if not in simple file shareing mode) files required a userid and a password to be specified when connecting. The user needs to have a active account on the windows XP or 2k box. smbmount can do this i would show you if i wasent at work ( No nix boxes here).

if you read the man page for smbmount it should tell you how.
 
Old 02-21-2006, 11:37 PM   #6
ddu_
Member
 
Registered: Dec 2004
Distribution: Slackware
Posts: 114

Original Poster
Rep: Reputation: 16
hrm, still having trouble with this...Using win2k

tried smbmount //192.168.1.110/D$ /mnt/homegrown
get this:

22708: session request to 192.168.1.110 failed (Called name not present)
22708: session request to 192 failed (Called name not present)
Password:
22708: session setup failed: ERRDOS - ERRnoaccess (Access denied.)

also tried sharing out a specific folder on the drive:
smbmount //192.168.1.110/mp3s /mnt/homegrown/
22843: session request to 192.168.1.110 failed (Called name not present)
22843: session request to 192 failed (Called name not present)
Password:
22843: session setup failed: ERRDOS - ERRnoaccess (Access denied.)
SMB connection failed

any other ideas? or am I just doing this totally wrong?
 
Old 02-22-2006, 02:55 AM   #7
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
As exvor points out, have you looked at the user credetials that are used to connect to the Windows share?
All Windows shares have permissions on them, so you'll need to give the proper username and password to access them. smbmount passes your credetials (username/password on the Linux box) by default, probably. So if those aren't the ones you need to give to Windows to get access on the share, then you'll need to supply some smbmount options for specifying the right username/passwd.

You should give the shares real names, not use "D$" (the default sharename). Linux shells may misread the $ as a special character, so enclosing it in single quotes (ie '//192.168.1.110/D$') is a good idea too.

Mounting a specific folder like
Quote:
smbmount //192.168.1.110/mp3s /mnt/homegrown/
will only work if the folder itself is shared on the Windows box.
On Windows, you can share both entire partitions (like D:, E:, etc) and folders, or a combination of both.
This is useful in case, for instance, you want to give different access permissions to the contents of
D: and D:\secrets\, but you still want to share both. If you want to share both the partition (like D and a folder on that partition, with the same access permissions, then you'll only need to put a Win share on the partition.

Remember also that, on Windows, share permissions are not the same as folder permissions.

In short, please verify:
1. the Windows share (name, permissions)
2. the username/passwd you're supplying to Windows in order to gain access.

My guess is that 1. is the problem, since you get an error that says that there is no share that has the name you gave.
2. would result in a "access denied" error only, not in the "called name not present" stuff. But with Windows, you can never be sure.
 
Old 02-24-2006, 01:31 AM   #8
ddu_
Member
 
Registered: Dec 2004
Distribution: Slackware
Posts: 114

Original Poster
Rep: Reputation: 16
ok, I must just be stupid.

The D drive is shared out at D$, and the mp3s folder on it is shared out with right for everyone.

am I suppose to be doing smbmount \\192.168.1.110\mp3s /mnt/homegrown or forward slashes
(I use \\ from win boxes)

Cant figure out why this so difficult. I'm pretty familiar with windows.
 
Old 02-24-2006, 03:02 AM   #9
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
On Linux, it's definitely //, not \\. In the path, always forward slashes, not backslashes.
On Windows, it's exactly the opposite (backslashes everywhere).

If you're familiar with Windows, have you looked at the Event Viewer to see what's going on?
Do you have any kind of firewall on Windows or Linux that can be interfering with SMB connections?
Have you enabled the network file & printer sharing in the Properties of your network connection (Windows)?
 
Old 02-24-2006, 09:32 PM   #10
ddu_
Member
 
Registered: Dec 2004
Distribution: Slackware
Posts: 114

Original Poster
Rep: Reputation: 16
Event Viewer is showing nothing.
Browsing from another windows machine, I go to \\192.168.1.110\mp3s

On the machine, it's located on the E: which is also shared out.
so on the local windows box, it's E:\mp3s (E and mp3s is shared out to all)

I've tried smbmount //192.168.1.110/mp3s
1780: session request to 192.168.1.110 failed (Called name not present)
1780: session request to 192 failed (Called name not present)
Password:
1781: tree connect failed: ERRDOS - ERRnosuchshare (You specified an invalid share name)


Unless I'm specifiying the wrong share name still?

No firewalls running either.
 
Old 02-24-2006, 11:23 PM   #11
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,961

Rep: Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530
Try using the netbios name for the PC instead of its IP address.
The command findsmb should show a list of PCs on the network.
 
Old 02-25-2006, 12:16 PM   #12
exvor
Senior Member
 
Registered: Jul 2004
Location: Phoenix, Arizona
Distribution: Gentoo, LFS, Debian,Ubuntu
Posts: 1,537

Rep: Reputation: 87
if its shared as D$ its a hidden share. Windows xp by default shares out all the harddrives to the internet. (and yet somehow this is secure acording to MS) You should go into the mp3 folder on d and share it out. By default XP will not allow you to create a user share of an entire harddrive unless you have simple file shareing enabled. If thats the case then a userid and password are not required to share out.

THINGS TO TRY.


If you have another windows box try connecting to the share via the run line with \\theipaddress\sharename

if it asks for a password then you dont have simple file shareing enabled.


turn it on to simplefly things.


If anything go into windows xp and create a user with the exact name that your user is on the linux box.


Windows xp and win2k and linux do not use by default a simple file shareing scheme they have secuirty options that can make you go in circles. Remeber that samba was developed during the win98 days so it acts like win98 when trying to connect to shares on the network. but there is hope samba can connect to these shares.

In windows does the D drive have a hand under it or no. If not its being shared by the admin and no one other then the admin is able to connect to it. if it does then its being shared in userlevel and its something were doing wrong in the smbmount.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Accessing remote shares with encrypted Samba password at bootup CyberGuy Linux - Software 1 01-09-2005 06:23 PM
Windows Shares brentos Red Hat 7 02-26-2004 10:14 AM
Linux can mount samba shares but not windows shares bindsocket Linux - Software 1 12-01-2003 06:28 PM
Windows Shares (again).. JzL Linux - Networking 3 08-14-2003 02:04 AM
How to mount remote shares at boot up rparkes Linux - Networking 10 07-17-2003 03:48 AM


All times are GMT -5. The time now is 12:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration