LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Remote Desktop using SSH tunnel..... help! (http://www.linuxquestions.org/questions/linux-newbie-8/remote-desktop-using-ssh-tunnel-help-215145/)

redhatbeatswin 08-08-2004 08:27 PM

Remote Desktop using SSH tunnel..... help!
 
hey all,

I finally got tightvnc working using SSH tunnel... now for the hard part...

I need to be able to remote desktop using SSH tunnel for a laptop running windows XP pro.

I've been reading up on this and I am thoroughly confused..

Client (Putty)
SSHD Server (linux box)
AppServer (XP Laptop, third host)

i have putty setup for tunnelling with tightvnc and it works ok, but i am getting stuck on this... any help appreciated.


MC

gvec 08-11-2004 07:08 PM

if you are running putty on Windows OTHER than XP/2003 you just need to setup putty to forward localhost:3389 through ssh tunnel to the XPlaptop:3389
(assuming using default RDP port for XP)
then using MSTSC connect to localhost:3389 and you should be golden

if using XP/putty this is what works for me: copy mstsc.exe and mstscax.dll to a directory somewhere, change the copied mstsc.exe to run in Windows 98 compatability mode and then launch it and point to localhost:3389
(otherwise i would get a message when trying to connect to localhost:3389 about already being connected to this console)

you can setup putty to forward whatever port to the laptop:3389 just as long as you know which port you specify (L3389:laptop:3389 or L6000:laptop:3389, etc) so you use it when connecting to localhost:port to be tunneled through ssh. i use a higher ranged local port and then have it forwarded to my XP:3389 through putty/SSH and it works fine for me

hope this helps

redhatbeatswin 08-11-2004 07:34 PM

different scenario
 
My fault-- I didn't clarify

XP Laptop is behind router, and so is my linux box

only port open is 22, and want to keep it that way.

how to i forward the traffic coming into the router port 22, then going into my linux box, and make it to the XP laptop ?

gvec 08-11-2004 07:59 PM

ok, if you are able to get vnc to work through ssh then you are already able to get into your network behind the router.

the client (the Windows system that is running putty to connect to home linux behind router) will need to be configured to have RemoteDesktop forwarded through the ssh connection established via putty. i use a 'free' port -- lets say 9833 (XP default rdp reversed ;))

in putty you will need to go to the Tunnels section [Connection --> SSH --> Tunnels] once there you will need to specify the local port that will be forwarded (9833 in this example)

source port = 9833
destination = XPip:3389
local radio button is ticked
then add

now when you establish the ssh connection with your linux box at home anything that hits your client port 9833 will be forwarded through the ssh tunnel to XPip port 3389 (the default XP RDP port)

now that we have the port forwarding established, using Microsoft Terminal Services Client (MSTSC) to connect to XP Remote Desktop is simple

for NON-XP client:
launch MSTSC and for Computer put localhost:9833 (since locally port 9833 will be forwarded through the ssh tunnel to XPip:3389
this will then connect to localhost:9833 which has been setup using putty to be forwarded through the ssh tunnel to your XP laptop ip port 3389

if the client is XP then you will need to copy the mstsc.exe and mstscax.dll and set the copied mstsc.exe to Windows98 Compatability mode, once that is done use the copied mstsc.exe and follow steps for non-xp client (when i tried to connect default xp mstsc to localhost i would get error about already being connected to this console and it would never be forwarded, but copying and setting to 98 compat mode would work without error)

gvec 08-11-2004 08:15 PM

you may also find these links helpful

Configuring PuTTY - A step-by-step guide

http://stefan.huberdoc.at/comp/info/ssh_tunnel.html

redhatbeatswin 08-14-2004 11:51 AM

my own stupidity!
 
Hey guys,

thanks for your help!!!

Guess what... I initially was trying to find a port that Remote desktop would work with over my firewall at work--

they block almost everything over 1000

I forgot that one day I was fiddling with the port number in the windows registry for RDP. I changed it to citrix 1494, thinking that my company would allow that traffic, and never changed it back!! Once I changed the port number, and rebooted, i was golden!

Thanks for your help.

its only a matter of time before i dont use micro$oft !


All times are GMT -5. The time now is 08:53 AM.