LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-06-2014, 01:45 PM   #1
jdepp
LQ Newbie
 
Registered: Mar 2013
Posts: 12

Rep: Reputation: Disabled
remote connection to linux port refused


I have a .net process sending messages to a linux server and was trying to send it to a port but keep getting connection refused error with target server actively refused it message. I checked the linux server and the firewall is disabled; found something online referring to listening on localhost instead of ip but don't see how that is related since I specify the ip when creating the tcp connection. How can I enable this to allow incoming data to a specific port? Do I need to make changes to the iptables file
 
Old 03-06-2014, 01:47 PM   #2
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 3,774
Blog Entries: 1

Rep: Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339
You are sending to a port... are you sure the port is open in iptables, and are you sure you have an active listening process, or a process that runs from xinet.d to listen to that port?

Can you connect to the port from localhost using telnet and the port number?
 
Old 03-06-2014, 02:08 PM   #3
jdepp
LQ Newbie
 
Registered: Mar 2013
Posts: 12

Original Poster
Rep: Reputation: Disabled
thanks for responding:

I checked using the following:

netstat -an | grep 1515 | grep LISTEN


and no response tells me it is not being used right?
I tried to telnet and connection refused. Then used one already open by first getting list

netstat -nlt

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 127.0.0.1:199 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:10005 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN
tcp 0 0 :::1514 :::* LISTEN
tcp 0 0 :::9292 :::* LISTEN
tcp 0 0 :::9200 :::* LISTEN
tcp 0 0 :::9201 :::* LISTEN
tcp 0 0 :::9300 :::* LISTEN
tcp 0 0 :::9301 :::* LISTEN
tcp 0 0 :::9302 :::* LISTEN
tcp 0 0 :::22 :::* LISTEN


Used 1514 and that was fine. So how do I enable another port to receive connections.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Port 22 connection refused- Damn Small Linux ashamanmiller Linux - Networking 6 01-05-2011 09:57 AM
port 22 connection refused satimis Linux - Networking 4 09-18-2010 10:55 AM
Remote telnet gets 'Connection refused' ashusharma Linux - Networking 5 01-27-2004 02:12 AM
port 22: connection refused lkalman Linux - Networking 13 06-17-2003 08:55 PM


All times are GMT -5. The time now is 02:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration