LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-03-2011, 11:39 PM   #1
tankbuster24
LQ Newbie
 
Registered: Jun 2011
Posts: 5

Rep: Reputation: Disabled
Regular Laptop speakers work, but my headphones will not.


When I play audio, the sound comes only out of the laptop speakers, not the headphones that are plugged in. I downloaded ALSA mixer and nothing on it seems to help, although at the top in the middle it says Intel IbexPeak HDMI, which I guess is my sound card. Does anyone know a solution?
 
Old 06-04-2011, 03:32 AM   #2
saivnoba
Member
 
Registered: Aug 2010
Distribution: Debian Sid, openSUSE, Gentoo, Slackware64
Posts: 68

Rep: Reputation: 2
Did you check if the headphone is mute?
Code:
alsamixer
and see if the value is 'MM' for your headphone. If its so, type 'm' on keyboard, it will unmute and value changes to '00'.
 
Old 06-04-2011, 06:03 AM   #3
arizonagroovejet
Senior Member
 
Registered: Jun 2005
Location: England
Distribution: openSUSE, Fedora, CentOS
Posts: 1,088

Rep: Reputation: 196Reputation: 196
What version of Linux are you using and which Desktop Environment? (This is information you should always include in posts, or add it to your profile.)

If you are using GNOME, you could try running gnome-volume-control and look in the Output tab.
 
Old 06-04-2011, 09:07 AM   #4
tankbuster24
LQ Newbie
 
Registered: Jun 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
I literally JUST installed Ubuntu yesterday, so i'm using whatever is the newest release.I have never backed up my files, largely because I have no files to back up yet. I'm thoroughly confused by ALSA Mixer, as it appears as just a white screen with volume control bars on it, and i'm not even sure which is which. I hate to sound so clueless, but i'm totally new at this and have very little idea of what i'm doing.
 
Old 06-04-2011, 11:15 AM   #5
arizonagroovejet
Senior Member
 
Registered: Jun 2005
Location: England
Distribution: openSUSE, Fedora, CentOS
Posts: 1,088

Rep: Reputation: 196Reputation: 196
Quote:
Originally Posted by tankbuster24 View Post
I literally JUST installed Ubuntu yesterday, so i'm using whatever is the newest release.
To says that you are using the newest release of Ubuntu because you installed it yesterday is a logically fallacy. I could tell you that I installed Ubuntu yesterday, but that doesn't mean that what I installed was the newest release. I could have installed from an iso I downloaded a year ago.

Quote:
Originally Posted by tankbuster24 View Post
I have never backed up my files...
See that line above it says "When was the last time you backed up your files?"? That's a signature delimiter


Look under Applications menu then under Accessories and run the Terminal application. At the command prompt type
Code:
$ gnome-volume-control
In the window that opens click on the Output tab and fiddle with the stuff in there, especially the Connector options.

I expect there's a way to get that gnome-volume-control window open by just clicking on an icon somewhere but I don't have a copy of the latest Ubuntu to hand. If there's a volume control icon in the top panel somewhere try right clicking on it.

If that doesn't get you anywhere post the output of
Code:
$ lspci -k -nn
This will give yield information about the chipsets you have and the drivers being used, which may help people help you.
 
Old 06-04-2011, 04:23 PM   #6
tankbuster24
LQ Newbie
 
Registered: Jun 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
here is the result of the second terminal command, the first didn't seem to help

00:00.0 Host bridge [0600]: Intel Corporation Core Processor DRAM Controller [8086:0044] (rev 02)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
Kernel driver in use: agpgart-intel
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
Kernel driver in use: i915
Kernel modules: i915
00:16.0 Communication controller [0780]: Intel Corporation 5 Series/3400 Series Chipset HECI Controller [8086:3b64] (rev 06)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
 
Old 06-04-2011, 04:32 PM   #7
arizonagroovejet
Senior Member
 
Registered: Jun 2005
Location: England
Distribution: openSUSE, Fedora, CentOS
Posts: 1,088

Rep: Reputation: 196Reputation: 196
Is that the whole output? There's no mention of an audio device.
 
Old 06-04-2011, 09:59 PM   #8
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 11,657
Blog Entries: 12

Rep: Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894
Ubuntu uses a layer on top of ALSA called pulse audio. I wish they wouldn't, but they do.

Try opening the Gnome Volume Control, clicking on the "Output" tab, and selecting "Headphones." (No this should not be necessary normally, but it's a way to test--in most computers with built-in speakers, jacking in headphones automatically mutes the built-ins.)

Try booting to the Ubuntu install CD in Live mode or to another Live CD such as Knoppix and testing whether the headphones work there.

Are you dual boot with some other operating system? Test the headphones in the other operating system to rule out a hardware problem.
 
Old 06-06-2011, 10:12 PM   #9
tankbuster24
LQ Newbie
 
Registered: Jun 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
If it wasn't complete before, it should be now

00:00.0 Host bridge [0600]: Intel Corporation Core Processor DRAM Controller [8086:0044] (rev 02)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
Kernel driver in use: agpgart-intel
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
Kernel driver in use: i915
Kernel modules: i915
00:16.0 Communication controller [0780]: Intel Corporation 5 Series/3400 Series Chipset HECI Controller [8086:3b64] (rev 06)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
00:1a.0 USB Controller [0c03]: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller [8086:3b3c] (rev 05)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
Kernel driver in use: ehci_hcd
00:1b.0 Audio device [0403]: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio [8086:3b56] (rev 05)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel
00:1c.0 PCI bridge [0604]: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 [8086:3b42] (rev 05)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1c.4 PCI bridge [0604]: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 [8086:3b4a] (rev 05)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1c.5 PCI bridge [0604]: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 [8086:3b4c] (rev 05)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1d.0 USB Controller [0c03]: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller [8086:3b34] (rev 05)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
Kernel driver in use: ehci_hcd
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev a5)
00:1f.0 ISA bridge [0601]: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller [8086:3b09] (rev 05)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
Kernel modules: iTCO_wdt
00:1f.2 SATA controller [0106]: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller [8086:3b29] (rev 05)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
Kernel driver in use: ahci
Kernel modules: ahci
00:1f.3 SMBus [0c05]: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller [8086:3b30] (rev 05)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
Kernel modules: i2c-i801
00:1f.6 Signal processing controller [1180]: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem [8086:3b32] (rev 05)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
Kernel driver in use: intel ips
Kernel modules: intel_ips
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01)
Subsystem: Realtek Semiconductor Co., Ltd. Device [10ec:8181]
Kernel driver in use: rtl8192ce
Kernel modules: rtl8192ce
03:00.0 Ethernet controller [0200]: Atheros Communications AR8152 v1.1 Fast Ethernet [1969:2060] (rev c1)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
Kernel driver in use: atl1c
Kernel modules: atl1c
ff:00.0 Host bridge [0600]: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers [8086:2c62] (rev 02)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
ff:00.1 Host bridge [0600]: Intel Corporation Core Processor QuickPath Architecture System Address Decoder [8086:2d01] (rev 02)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
ff:02.0 Host bridge [0600]: Intel Corporation Core Processor QPI Link 0 [8086:2d10] (rev 02)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
ff:02.1 Host bridge [0600]: Intel Corporation Core Processor QPI Physical 0 [8086:2d11] (rev 02)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
ff:02.2 Host bridge [0600]: Intel Corporation Core Processor Reserved [8086:2d12] (rev 02)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
ff:02.3 Host bridge [0600]: Intel Corporation Core Processor Reserved [8086:2d13] (rev 02)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
tim@tim-Satellite-L650:~$
 
Old 06-06-2011, 10:16 PM   #10
tankbuster24
LQ Newbie
 
Registered: Jun 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
To those who have asked if I have changed my headphone settings; I have yet to see any setting, or even mention of the word "headphone" in either the sound settings or any of the applications I have installed.
 
Old 06-07-2011, 12:26 AM   #11
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Rep: Reputation: 40
METHOD A:

Look on your panel (You may be used to calling it a 'taskbar'), Left-click on the little speaker shape, If just a volume control comes up, try RIGHT clicking, after that look for an option (should be on the bottom) that says PREFERENCES (or Sound preferences), click that, and a window should open, on the top of that window 3- maybe 4- tabs to the right you will see OUTPUT, Left click, and there should be a drop down menu that will most likely say 'Speaker' -OR- 'output' ... You want to click on that and change it to 'Headphones'.

METHOD B:

Click on the Panel menu (windows would call it the start button) Go to-> Control Settings|| find->Sound|| locate the tab that says->Output (3rd or 4th to the right)|| Click the drop menu and change to->Headphones||

At least that is how it works in my version of Zorin which is built on ubuntu, and in my version of dreamlinux which uses ALSA.

If this is not descriptive enough, I have screen shots of me changing mine from speakers to headphones, and will be glad to post if needed. I wish you the best of luck!

Last edited by Hevithan; 06-07-2011 at 12:35 AM.
 
Old 06-07-2011, 03:39 AM   #12
arizonagroovejet
Senior Member
 
Registered: Jun 2005
Location: England
Distribution: openSUSE, Fedora, CentOS
Posts: 1,088

Rep: Reputation: 196Reputation: 196
Quote:
Originally Posted by tankbuster24 View Post
00:1b.0 Audio device [0403]: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio [8086:3b56] (rev 05)
Subsystem: Toshiba America Info Systems Device [1179:fd50]
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel
A couple of minutes on Google shows you're not the only person having trouble with this chipset.

This guy has a solution that works for him https://justcheckingonall.wordpress....c259-in-linux/ but he's using rev 06 of the chipset rather than 05.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Speakers work, headphones don't tommyttt Linux - Newbie 3 01-20-2011 02:47 AM
No audio from internal speakers but headphones work matt1123 Linux - Hardware 5 10-17-2010 03:38 PM
plugging in headphones or speakers doesn't disable my laptop's built in speakers moljac024 Linux - Software 11 02-18-2009 10:24 AM
Laptop speakers off when plug in headphones garyozzy Linux - Hardware 8 02-04-2006 03:44 PM
Can get sound from laptop speakers but not from headphones thetremorchrist Linux - Hardware 4 02-14-2004 04:43 AM


All times are GMT -5. The time now is 06:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration