LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-14-2009, 03:24 AM   #1
ankitgupta191
LQ Newbie
 
Registered: May 2009
Posts: 3

Rep: Reputation: 0
regarding ":set mouse=a" in vim


i hav tried to use the following option in cmd mode in vim:

:set mouse=a

but it gives an error that:

E538: No mouse support: mouse=a

plzz help me out.....
 
Old 05-14-2009, 03:36 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387
Hi,

That option only works with certain terminals. This quote is from the vim help files:
Quote:
'mouse' string (default "", "a" for GUI, MS-DOS and Win32)
global
{not in Vi}

Enable the use of the mouse. Only works for certain terminals
(xterm, MS-DOS, Win32 |win32-mouse|, QNX pterm, and Linux console
with gpm).
For using the mouse in the GUI, see |gui-mouse|.
Are you trying this in one of the mentioned terminals?

Another thing: You don't mention the distro you are using, but is vim fully installed? You can find out by trying the following in a vi(m) session: :version. In the first few lines you should see something like this: Normal version without GUI. Features included (+) or not (-):

Hope this gets you going again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
evdev/xorg help? USB mouse/kbd: 2.6.24="just works">2.6.25="unplug/replug to work". GrapefruiTgirl Linux - Hardware 4 12-13-2012 03:23 PM
error: Error for wireless request "Set Mode" (8B06) : invalid argument "roaming" penguin chick Linux - Wireless Networking 5 08-22-2008 02:16 PM
"Back" and "Forward" side-buttons of my mouse Unforgiven79 Linux - Hardware 1 10-31-2006 01:10 AM
How to set the size of icons for "Starterbar" in "Gdekslets" Blue Jacket Linux - Software 4 11-23-2005 03:42 AM
how to set "wrapping size" in VIM staul Linux - Software 1 04-17-2005 08:39 AM


All times are GMT -5. The time now is 08:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration