LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-20-2005, 01:04 AM   #1
wannabpunker188
LQ Newbie
 
Registered: Sep 2005
Posts: 6

Rep: Reputation: 0
Mandrake wont load


[Thread title changed because of similar issue with Mandrake not redhat]

ok im a complete linux newb. i installed redhat fine. it worked fine but the res was 800x600 so i changed it to 1280x1024 and restarted so it would take effect, now it gets into grub, goes thru the startup check, then it shows the check display settings thing poping up on my monitor(like when u get if the monitor cable is unplugged). how can i change my res back in grub so i can get back into linux?

then how can i change the res back to 1280x1024 without it not freaking out on me?

NEW QUESTION :

so i formatted redhat off and installed mandrake official 10.1. it installed smoothly other than it not recognizing my mouse, but the keyboard was easy to use instead. finalized installation, rebooted, it loads up the loading bar get half way then stops, and doesnt continue.

i pressed escape and it was stuck on [CHECKING FOR NEW HARDWARE] or something similar. it wouldnt move at all for a good 20 mins so sumthin is up.

any suggestions?

Last edited by wannabpunker188; 09-20-2005 at 06:31 PM.
 
Old 09-20-2005, 02:13 AM   #2
linux-rulz
Member
 
Registered: Dec 2004
Distribution: Windows XP Home, Ubuntu Hoary
Posts: 584

Rep: Reputation: 30
Which version of Red Hat? For better hardware support and autodetection use Fedora Core or CentOS. Red Hat is unsupported, unmaintained and outdated. Unless you are talking about Red Hat Enterprise Linux. If so, which version?
 
Old 09-20-2005, 02:30 AM   #3
Stan the caddy
Member
 
Registered: Dec 2003
Location: Victoria, B.C
Distribution: Slackware
Posts: 61

Rep: Reputation: 15
When your monitor goes all funky try fiddeling around with ctrl + alt + + and ctrl + alt + - (+/- must be entered on numpad). Failing that switch to tty2 (ctrl + alt + F2), login, and edit your /etc/X11/xorg.conf file. In the Screen section you should see something like this
Code:
Section "Screen"
      Identifier   "Screen 1"
      Device      "NVIDIA GeForce FX5200"
      Monitor     "FLATRON T710BH"

      DefaultDepth   24

      Subsection "Display"
           Depth   24
           Modes   "1024x768"   "800x600"   "640x480"
      EndSubsection
EndSection
Under modes the 1st entry is the default resolution. Set it appropriatly, save the file, and switch back to X (ctrl + alt + F7). Now restart x (ctrl - alt - backspace).

As for why X is crashing on 1280x1024 i suspect that is because you dont have the correct horizontal sync/vertical refresh specs for your monitor. Find them out on google or whereever and enter them in your /etc/X11/xorg.conf file. If this was not the problem check your /var/log/Xorg.0.log file for clues.

Hope this helps
 
Old 09-20-2005, 03:01 AM   #4
wannabpunker188
LQ Newbie
 
Registered: Sep 2005
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Stan the caddy
When your monitor goes all funky try fiddeling around with ctrl + alt + + and ctrl + alt + - (+/- must be entered on numpad). Failing that switch to tty2 (ctrl + alt + F2), login, and edit your /etc/X11/xorg.conf file. In the Screen section you should see something like this
Code:
Section "Screen"
      Identifier   "Screen 1"
      Device      "NVIDIA GeForce FX5200"
      Monitor     "FLATRON T710BH"

      DefaultDepth   24

      Subsection "Display"
           Depth   24
           Modes   "1024x768"   "800x600"   "640x480"
      EndSubsection
EndSection
Under modes the 1st entry is the default resolution. Set it appropriatly, save the file, and switch back to X (ctrl + alt + F7). Now restart x (ctrl - alt - backspace).

As for why X is crashing on 1280x1024 i suspect that is because you dont have the correct horizontal sync/vertical refresh specs for your monitor. Find them out on google or whereever and enter them in your /etc/X11/xorg.conf file. If this was not the problem check your /var/log/Xorg.0.log file for clues.

Hope this helps
but i cant even get into X. it doesnt even get that far. it gets past where it checks the hardware and then the screen goes black and the "please check display settings" appears and no keystroke can get my out. btw its redhat 9. i downloaded the ISOs for Mandrake 10.1, burned them, but i cant get it to boot to the CD. my current BIOS settings can do it tho because i just did it for redhat (commercial CD). i check the cd in windows and the install mandrake screen comes up but when u click install, nothing happens. obviously..... im so stumped. whether or not to stick with redhat which i cant even get logged into or switch to mandrake which for some reason the burned ISO doesnt like to start on boot.....

HELPP!!!!!!!!!!!!!!
 
Old 09-20-2005, 03:53 AM   #5
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Can you still get into a console? e.g <ctrl><alt><F1>? If not, boot into single user mode (I don't know how to do so from grub but you can find that on the internet).

Now you can edit the Xorg configuration file using vi, emacs or whatever your favorite (nog graphical) editor is.

Till you've fixed the problem, it's advisable to start into runlevel 3 instead of 5. Modify the file inittab:
Code:
id:5:initdefault:
Change the 5 to a 3.

X will not start, and you will be presented with a normal terminal login. Once you've modified the Xorg config file you can start it with startx and test.

Once everything is working fine again, you can change the runlevel back to 5.

PS You have to be root to edit the files.
 
Old 09-20-2005, 05:00 AM   #6
wannabpunker188
LQ Newbie
 
Registered: Sep 2005
Posts: 6

Original Poster
Rep: Reputation: 0
ok lets just say im an ultra NEWB. ive been on windows my whole life, well the past 7 years of it at least. i have no idea what anybody is saying....

the only screen i can logically get to is GRUB where u pick between the two OSs, XP and Redhat. i pick redhat, it goes into that diagnostic screen, then goes black, theres no X on it so i know its not in X. its just a black screen like when u unplug ur monitor cable from ur comp and the warning flashes on screen. i know when i installed linux i ran it in lowres because i had the same issue installing it as i am now. but i just dont know how to change the resolution back.
 
Old 09-20-2005, 08:26 AM   #7
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
1)
Press control and alt and F1 at the same time (that's what I meant by <ctrl><alt><f1> when your system is booted and you have your black screen. It should give you a console where you can login.
Login as root user. You will see a commandline with a prompt (like the dos-box in windows).

2)
Now goto the X11 directory by typing the command cd /etc/X11 and pressing <enter>. Depending on the RH version, there will either be a file 'xorg.conf' or a file 'XF86Config'. Type the command ls and press <enter> to check which file applies to your system.

3)
Make a copy of the file: cp file_that_you_found newfilename and press <enter>.

4)
Type vi file_that_you_found and press <enter>. Go down to the earlier described 'screen' section (nearly at the end of the file) and place the cursor on the line with the word 'modes'.
4a)
We will first make a copy of the line. To do so, press the y twice and press p.
4b)
Position the cursor at the beginning of one of the two lines, press i and press #; press <esc>. The line will now be treated as a comment.
4c)
Move the cursor to the other line and remove all resolutions that you don't want. To do so, move the cursor to the double-quote that starts a resolution that you don't want and press x a couple of times till the closing double-quote for that resolution is removed as well. Repeat for all unwanted resolutions.
If an x shows up when you press x, press <esc>.
I suggest that you only leave the 800x600 in
Code:
modes "800x600"
Press the colon (the cursor will go to the bottom of the screen) and type wq and press <enter>. This will write the file and quit vi.

5)
Now press the control, alt and F7 keys at the same time (<ctrl><alt><F7>). This will give you your black screen. Press control and alt and backspace at the same time (<ctrl><alt><backspace>) to restart X. Let us know the results and we will take it from there.

Please note that all commands are case-sensitive (also in vi). If you want to undo a change in vi, press <esc> once to get out of edit mode and press u as often as necessary.

Last edited by Wim Sturkenboom; 09-20-2005 at 08:34 AM.
 
Old 09-20-2005, 01:06 PM   #8
wannabpunker188
LQ Newbie
 
Registered: Sep 2005
Posts: 6

Original Poster
Rep: Reputation: 0
wow thanks man, that was so totally helpful. it worked perfectly. but because it can only go as high as 800x600, and im used to 1280x1060(?) AND im just realizing that red hat 9 isnt supported anymore by RHN, i cant update to get it to work right. soooo... im in the process of getting the fedora core, i have a copy of mandrake, but im not so sure that isnt being supported anymore either. but all things aside, i am starting to like linux more and more. its got a much better feel to it than XP. the main reason i switched is for security, and to get used to programming in linux.

thank you for the help!! much appreciated!!!!!!
 
Old 09-20-2005, 06:33 PM   #9
wannabpunker188
LQ Newbie
 
Registered: Sep 2005
Posts: 6

Original Poster
Rep: Reputation: 0
bump, thread title changed and new issue in main post.
 
Old 09-22-2005, 01:02 AM   #10
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
I will continue where I left you so you know when you hit the problem again.
---------------------
Now we can start working on the higher resolutions.

First of all, you can add other resolutions to the modes line. Mine looks like:
Code:
Modes "1600x1200" "1400x1050" ..............
Open the file in vi and go to the position where you want to insert a higher resolution. Press i and type the new resolution(s). Press <esc>. Press colon and type wq and press <enter> to save and quit.
I should start by adding 1024x768 before the 800x600 and try it. Next add the next resolution.

In your xorg.conf (in my case XF86Config) is a section monitor. It should contain parameters HorizSync and VertRefreshMine looks like:
Code:
Section "Monitor"
  Identifier       "Monitor0"
  VendorNane  "Monitor Vendor"
  ModelName   "SyncMaster"
  HorizSync      30.0 - 115.0
  VertRefresh   50.0 - 160.0
  Option           "dpms"
EndSection
Find the manual for your monitor (at home, on the internet or wherever) and find the maximum horizontal and vertical frequencies (refreshrates). Modify the HorizSync and VertRefresh in the configuration file accordingly. You should by now be able to do so using vi.

If you keep having problems related to video when using your new distro, we need to know what videocard you're using, which monitor and the content of the sections monitor, device and screen in your xorg configuration file. In that case however I might not be able to help you further (as it might be a driver issue).

Last edited by Wim Sturkenboom; 09-22-2005 at 01:38 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Removed redhat from system and computer wont load in XP lukegt Red Hat 1 01-15-2005 10:13 PM
X Wont Load!!!! joker20 Linux - Newbie 10 09-16-2004 09:01 PM
nvidia driver 5328 redhat 9 module wont load restlekak Linux - Hardware 1 01-24-2004 03:21 PM
Redhat 8 wont load into gui nihility Linux - Newbie 1 01-09-2003 02:47 PM
RedHat 7.1 wont load... Azazel Linux - Newbie 3 04-20-2002 11:38 PM


All times are GMT -5. The time now is 10:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration